Sign in to follow this  
qnh

Problems with CH Products Flight Sim Yoke

Recommended Posts

I am using the CH Products Flight Sim Yoke with FS2002 and FS2004.Here's the problem...The throttle will not remain high and it suddenly jumps back to idle. Thinking this might be a conflict with a particular aircraft and/or FS2004, I experimented and it occurs with all planes and even in FS2002.I have tried making adjustments within the simulator with no luck. I hooked up my Logitech Wingman Extreme and have no problems with the throttle acting up.Anyone have similar problem or suggestions on what might be wrong?Michael Hutton

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have both the yoke and the Wingman hooked up at the same time? If so, there's your problem (unless you have not calibrated the yoke to start with, which could also be a reason).If you wish to use both hooked up together (I do) I recommend disabling the throttle on one or the other. In my case, I've disabled it on the Wingman. Problem gone.Mark "Dark Moment" Beaumonthttp://www.swiremariners.com/newlogo.jpg

Share this post


Link to post
Share on other sites

No, I didn't have the Logitech hooked up at all. It just started doing it recently. It does the same thing when I try to use the throttle in the virtual cockpit too. But only with the Yoke hooked up.-Mike

Share this post


Link to post
Share on other sites

Well.Im having problems with my CH Pro Rudder Pedals USB.They tend to drift to the left and I haven't been able tofix that and also the brakes seems to apply by themselves.You can see the "Differential brakes" message on the lower screen almost all the time . When I depress the aft (back) side of the pedals the message will go away. Ive tried changing settings in the Sensitivity option. But I havent had any luck.... What can I do?Ed

Share this post


Link to post
Share on other sites

Have you tried to set the calibration in FSUIPC?If you have, cancel it all. When I did that I got all sorts of problems also. For what it's worth, I have my throttle sensivity set full right in the sim and the null zone on the first click to the right.Same with brakes ... leave FSUIPC well alone. I have sensitivity set to half slider and null at zero. Note: in assignments, the pedal action must be set to REVERSE. Mark "Dark Moment" Beaumonthttp://www.swiremariners.com/newlogo.jpg

Share this post


Link to post
Share on other sites

Go to www.chproducts.com, select the retail products and then download the Control manager utility and calibrate both the yoke and pedals.--qnh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this