Jump to content

Archived

This topic is now archived and is closed to further replies.

Flaps30

Yoke and Pedals not Recognized When Restarting FSX

Recommended Posts

This never happened on my previous install of FSX with Win Vista. Now I have a new install on a new system with Win 7-64 bit-SP1, and if I exit FSX, come back the next night after the computer was in sleep mode and restart FSX, my CH Flight Yoke and Rudder pedals aren't recognized. I thought it was a calibration problem the first time it happened but I simply could not get them to work. I exited FSX, restarted the computer, and after restarting FSX they worked fine. If I restart right after exiting, they still work, it only seems to happen after long periods when the system has been asleep. Any ideas why this happens now and never did before on my previous system? Thanks. Tom

Share this post


Link to post
Share on other sites

FlapsI think something was posted on CH Hanagr Forums about this in that when Windows wakes up from sleep it does not 'recognise' the CH USB controllers.One poster on http://www.flightsim...p/t-224791.html fixed it by: "I followed instructions in a MS Technet article that modifies the registry entry for each USB host controller - I added ForceHCResetOnResume to the registry entries for each CH product - that change then enabled the next change to be effective". This is for Vista: http://support.microsoft.com/kb/928631 but it explains the procedure.Obviously changing the power settings will also fix the issue.RegardsPeterH

Share this post


Link to post
Share on other sites

Unplugging and replugging the USB connectors also forces Windows to recognize the units.. You can do this without shutting down FSX.


Bert

Share this post


Link to post
Share on other sites

Tom - the default USB Power Management setting in Win7 is for it to "Allow the computer to turn off this device to save power". You can access and change this setting (un-check the box) through the Device Manager -> Power Management. (Rt-Click on Computer, select Manage)

Share this post


Link to post
Share on other sites

Thanks for the help, guys.Paul,I tried to find the "Allow the computer to turn off this device to save power" checkbox you mentioned above but I could not find a Power Management setting under "Manage". The closest I found was under "Hardware and Sound" -> "Change Power Saving Settings" -> "Change Plan Settings"-> ( under High Performance which I have enabled), "Change Advanced Power Settings" -> "USB Settings" -> "USB Selective Suspend Setting" ->which is set to "enabled". I disabled this, restarted the computer, opened FSX and it worked fine. I put the computer to sleep, woke it up, restarted FSX, and the controls did not work. Is this the setting you are referring to? Thanks, TomP.S.Paul, I think I found the setting you mentioned. Under Device Manager I found several "USB Hub" entries. I selected each one and disabled the "Allow Computer to turn off this device" setting. Unfortunately it did not correct the problem.Bert,I had tried the unplugging of the usb chords as you suggested and I heard the "ding dong" for the yoke but could not get it to recognize the pedals after repeated tries. Tom

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    43%
    $10,960.00 of $25,000.00 Donate Now
×
×
  • Create New...