Jump to content

Archived

This topic is now archived and is closed to further replies.

quadraspleen

Controller failure

Recommended Posts

Hi,Been away. Was too busy before I left to get properly stuck in to NGX. NOw I have returned, and got hold of Tom Risagers most excellent and informed "readers digest" of the equally excellent, but swede-creaming PMDG docs. I'm starting from scratch but as soon as I enter the cockpit my controllers stop working. I can't pan; change views nor activate any controller assigned action. I have obviously checked that it works in other payware and FSX aircraft, and it's fine. I use EZdok, and interestingly, even if I use EZStudio I cannot change the view; it's as if the input into the sim via the controller or any proxy thereof stops working.I can still change views via the keyboard and operate switches and stuff using the mouse, but I have no control surface control, so to speak. Is this the "freeze" that people speak of? Is there a fix? I have done a search on "joystick stops working" and not come up with much. Thanks in advance jake SPECS i7 2600k o/c12gb XMP DDR3VelociraptorSaitek Cyborg USB joystick


JAKE EYRE
It's a small step from the sublime to the ridiculous...Napoleon Bonaparte
newSigBetaTeam.gif
lancairuk.jpg

Share this post


Link to post
Share on other sites
I can still change views via the keyboard and operate switches and stuff using the mouse, but I have no control surface control, so to speak.
Ref: Movement of Control Surfaces, with your controller: Untill you start the engine / get Hydraulic pressure, I don't believe you will have much movement of your control surfaces. The PMDG 737NGX requires a little more than just jumping into the cockpit, hitting CTRL-E, and off we go. You really have to read some/(all) of the manuals.

Share this post


Link to post
Share on other sites
Hi,Been away. Was too busy before I left to get properly stuck in to NGX. NOw I have returned, and got hold of Tom Risagers most excellent and informed "readers digest" of the equally excellent, but swede-creaming PMDG docs. I'm starting from scratch but as soon as I enter the cockpit my controllers stop working. I can't pan; change views nor activate any controller assigned action. I have obviously checked that it works in other payware and FSX aircraft, and it's fine. I use EZdok, and interestingly, even if I use EZStudio I cannot change the view; it's as if the input into the sim via the controller or any proxy thereof stops working.I can still change views via the keyboard and operate switches and stuff using the mouse, but I have no control surface control, so to speak. Is this the "freeze" that people speak of? Is there a fix? I have done a search on "joystick stops working" and not come up with much. Thanks in advance jake SPECS i7 2600k o/c12gb XMP DDR3VelociraptorSaitek Cyborg USB joystick
Open up FSX Controllers to see if by any chance you have not unticked 'Enable Controller'. Same happened to me.

Rick Almeida

Share this post


Link to post
Share on other sites

Hi Geoff, Thanks for your reply. I am aware I cannot just jump into the plane and take off. That's why I am using Tom's excellent tutorial. I am an avid follower of all "full-realism" payware sims that offer full startup procedures. I have read a lot of the PMDG stuff but Tom's pdf is too good and easy to follow for the time-limited VP. Forget the part about control surfaces (although I have an engines started save where I still cannot move control surfaces) my real issue is with the fact that as soon as I enter the cockpit, my joystick and all its buttons stop working. I cannot pan the view, nor change the view, nor can I change the view with EZstudio. This is not right. There are about twenty in-cockpit views that I should be able to cycle through using two assigned buttons on my stick. They stop working in NGX even though the assignments are still there, and it is fine in all other planes. I have noticed that I can pan for about two to three seconds after it loads the plane but then it's gone and at whatever aspect I had the pan; if I was panned out the left-hand cockpit window that's where it stays. Only quitting FSX (or loading another plane) will bring it back. Thanks Hi Rick, checked all that. I can move it in properties when i have clicked calibrate in FSX. The hat moves the little red arrows. Quit back to FSX and it isn't there Thanks


JAKE EYRE
It's a small step from the sublime to the ridiculous...Napoleon Bonaparte
newSigBetaTeam.gif
lancairuk.jpg

Share this post


Link to post
Share on other sites

Are these views set up with ezca? If so, did you re-initialize it after installing the ngx?


Kenneth Weir

My Saitek yoke mod

 

i7 2600k @ 4.7

8GB Gskill CAS7

2x GTX580 SLI Surround + GT520 Accessory

Win7x64

Share this post


Link to post
Share on other sites

Hi Ken, I did, yes. And again this evening after installing the August 16th update. No joy. Do you think it might be EZCA related? it still works in all other AC Thanks


JAKE EYRE
It's a small step from the sublime to the ridiculous...Napoleon Bonaparte
newSigBetaTeam.gif
lancairuk.jpg

Share this post


Link to post
Share on other sites

Do you think I should open a ticket? Should I wait until after SP1? Have I missed something? Thanks


JAKE EYRE
It's a small step from the sublime to the ridiculous...Napoleon Bonaparte
newSigBetaTeam.gif
lancairuk.jpg

Share this post


Link to post
Share on other sites
Hi Ken, I did, yes. And again this evening after installing the August 16th update. No joy. Do you think it might be EZCA related? it still works in all other AC Thanks
I don't know. I just remembered reading somewhere that you should reinitialize it after adding an aircraft, so I thought it might have been that. EDIT: If someone doesn't chime in with a possible solution I think I'd open a support ticket.

Kenneth Weir

My Saitek yoke mod

 

i7 2600k @ 4.7

8GB Gskill CAS7

2x GTX580 SLI Surround + GT520 Accessory

Win7x64

Share this post


Link to post
Share on other sites

Thanks Mikael, I am already using that profile..I'm going to open a ticket. Hopefully this will be an SP1-fixed issue


JAKE EYRE
It's a small step from the sublime to the ridiculous...Napoleon Bonaparte
newSigBetaTeam.gif
lancairuk.jpg

Share this post


Link to post
Share on other sites

Hi, please report if the problem is solved, i have the same issue after landing and disconnecting the Autobrake via my Joystick, after that the Joystick is disconnected and can´t be reconnected

Share this post


Link to post
Share on other sites

I've opened a ticket; I'll let you know how I get on. Thanks for all the replies


JAKE EYRE
It's a small step from the sublime to the ridiculous...Napoleon Bonaparte
newSigBetaTeam.gif
lancairuk.jpg

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    42%
    $10,670.00 of $25,000.00 Donate Now
×
×
  • Create New...