Jump to content
Sign in to follow this  
kbutterfield

Registration Key

Recommended Posts

I had to re-insall RC4 on a different computer due to a computer crash.I filled out the registration with the automatic email twice. Once on Friday and again on Monday just incase it didn't go through. Still haven't heard back. Yesterday I emialed the a key request with the information directly JD. Stil haven't received any key.Wha other steps do I need to do to get my key. I've been down with RC4 since Frlday?ThanksKylekbutterfield@hotmail.com

Share this post


Link to post
Share on other sites

Kyle,Send me a PM with your product key and I'll provide a registration key.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

received both key requests, processed them, and keys were sent out. please check your email for more information on the keysjd

Share this post


Link to post
Share on other sites

I never received the keys. For some reason I am not receiving emails from you guys with my hotmail account. Ray tried to send me one yesterday and it did not come through. Not sure which side is blocking.Ray did pm me the key so now it is working.ThanksKyle

Share this post


Link to post
Share on other sites

I'm based in the UK so your ISP would have to be blocking a lot of mail for mine not to come through. You should contact them and establish why they are blocking emails from legitimate sources. My guess is that a hotmail account is probably the reason you didn't receive any of the 3 emails sent.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites
I need a key as well. Who do I contact for it? I have my product ID
If you have submitted the product key and your name in the format requested a key will be provided with 15 minutes. It is an automated process.Check your spam folder. It's almost certainly going to be there.

Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

It's not a process that I have personally used so I'm afraid you will have to wait for a reply from JD.You do have email software installed on the PC running RC4 don't you?


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

You haven't said if you have checked your spam folder. The vast majority of those who say they haven't received their reg key the email was despatched within 15 minutes of receipt and it was found in the user's spam folder.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

I have checked it...the program is not responding...when I put my first and last name in the fields provided and click the button nothing happens! It doesn't give any kind of confirmation that something is getting sent or anything. I have manually sent the email as well with my product ID and still no response from anyone, not the seller or even SW Reg themselves about the issue.

Share this post


Link to post
Share on other sites

You'll have to wait for JD I'm afraid. He monitors the forum on a regular basis so should be along soon. I'll send him an email.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Check the first two pinned topics regarding security applications and missing library components.Make sure you start RC with a right click to run as admin under VISTA and Win 7.As an admin you can look in Windows event manager to see if any errors are logged.Make sure the RC folders and subordinate files are not read only. sometimes that happens if you install from CD if that is how you acquired it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...