Archived

This topic is now archived and is closed to further replies.

avo42

OSM2XP questions...

Recommended Posts

Hi all

 

Can anyone help me out here please to understand why im having this issue.

 

Ok here goes ... if i convert the openstreet data of the UK pop this folder into my x-plane 10 custom scenery folder all buildings and roads ect.. show up just fine

if i then install VFR photo scenery i loose all the roads from my conversion but the buildings are all there i'm confusted as to why this would be i have looked at the log file and the osm2xp data is being loaded just fine but just not showing.

 

Any thoughts or ideas please that i could try

 

Thank you...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Most likely the photo scenery has an exclusion tag which is removing the default roads.

Share this post


Link to post
Share on other sites

Hi

 

Thank you for your reply , do you know if its possible to remove these tags or have the files been procesed this way and there is nothing that i can do..

 

 

Cheers.

Share this post


Link to post
Share on other sites

This also is an issue in FSX IIRC , I think the photo scenery overlaps the OSM. Why not try emailing XPX support , they are quite helpful.

Share this post


Link to post
Share on other sites

Just to let you know encase anyone else is having the same issue i did i found these roads for UK and Republic of Ireland (hope i'm ok to post link) http://marginal.org....y/packages.html with photo scenery installed these roads and conversion of openstreetmap data using OSM2xp you can produce some great results (the car / trucks and trains now look great on the road moving)..still not sure why these work and the ones converted do not with photo scenery installed.

Share this post


Link to post
Share on other sites

Hello

 

Xplane loads scenery folders using name for priority.

So if the vfr scenery has some exclusions AND has a name which will makes xplane loads it first, it will hide osm2xp objects.

So just rename osm2xp using a name that will makes xplane load it before your UK VFR scenery.

 

Cheers

 

Ben

Share this post


Link to post
Share on other sites

Hello

 

Xplane loads scenery folders using name for priority.

So if the vfr scenery has some exclusions AND has a name which will makes xplane loads it first, it will hide osm2xp objects.

So just rename osm2xp using a name that will makes xplane load it before your UK VFR scenery.

 

Cheers

 

Ben

 

Ben,

 

you are right in what you say, still I havent't beenn able to make OSM created data to be displayed on screen. I am able to see the forests , street lights and some buildings (probably due to the buildings attributes in the .osm file) but no roads. It might have to do with the fact that there is very little data for the area I live in (Gloucester, UK) still I'm sure the roads data is there , is just not being displayed by X-plane with the VFR scenery installed...

 

Any ideas?

Share this post


Link to post
Share on other sites

OSM2XP only does buildings and forests, it doesn't do roads or rail. The photoscenery more than likely has an exclusion which removes the default scenery, and it's the default scenery which contains the roads.

 

I'm not sure moving the priority around would fix it, the only way would be to either open the photoscenery tiles yourself using WED and remove the exclusions (Far too much work), or find an overlay compatible photoscenery which doesn't do this. I believe XP10 only photoscenery does this.

Share this post


Link to post
Share on other sites