Jump to content

Archived

This topic is now archived and is closed to further replies.

aviascorp

Problem Loading Air Port Chart Gauge by Holgar Maass in Windows 7

Recommended Posts

Holgar Maass had coded a wonderful gauge for FS9/FSX which provided an in-cockpit taxiway layout in a GPS type gauge.

 

Unfortunately, Windows 7 users (including myself) were not able to use this gauge. I have extensively searched various forums for a remedy to the solution and on not finding any, tried some debugging myself.

 

I'm happy to report that the issue is caused by the 'security settings' of the Windows 7.

 

By default, the gauge automatically installs to ...../Program Files (X86)/Mahosoft/Airport Chart Gauge. Since the install folder is located in the 'program files (x86)' folder, windows restricts access to any sub-folder in this folder. After installing the airport chart gauge in the usual manner, navigate to your program files (x86) folder and locate the folder 'Mahosoft'. Right click on this folder and click 'properties'. In the 'General' tab of the resulting window, look for 'Attributes' of this folder. The first attribute "Read-only (Only applies to files in this folder) would have a blue fill in the check box next to it. Click on this 'check box' to ensure that it is UNCHECKED (i.e. remove the read only attribute for this folder). When you hit okay, windows will ask you if you want to apply this attribute to all the sub-folders of this folder, click 'Yes'.

 

Do not close the 'program files (x86) folder, and run the 'Airport Chart DB Builder'. This time it WILL rebuild the database from FSX and your gauge will now work in FSX. After you close the 'program files (x86)' folder, the read only attributes will be reapplied to the Mahasoft sub-folder again, but it doesn't matter because the gauge doesn't require the 'write' attributes till you rebuild the database again.

 

This worked for me. Hope it helps you folks as well.

 

Mickey AviaScorp.

 

Do let me know, if this post helped any of you. Thanks.

 

Mickey AviaScorp.

 

Please do let me know, if this fix works for you folks.

 

Mickey AviaScorp

Share this post


Link to post
Share on other sites

no succes...

 

I'm sorry to hear that Jan.

This guage had worked flawlessly on my earlier XP based system, but had not initially worked on my Win 7 64bit system. I had 'googled' extensively to find a solution, but couldn't find anything that worked for me. But, after a little bit of tweaking with my security settings, the above stated tweak worked for me, and the gauge works for me now.

 

I'm confident, what ever it is that is causing this gauge NOT to function, is related to the security settings of Win 7. I'm sure you have already done that, but just to verify, did you turn your UAC off and also do you run the install and DBbuilder 'as administrator'.

 

Mickey

 

Hi. I saw your post here about APC Viewer. I have tried installing it per your instructions on my WIN7 64 bit system. I used to have it working fine on my old XP system.

 

I ran the setup and it asked where I wanted to install it. I said C:\Program Files (x86)\Microsoft Games\Flight Simulator X.

 

Is this correct? I did not get any Mahosoft folder in C:\Program Files (x86). I found my Mahosoft folder on my old system and copied it into C:\Program Files (x86). See no place to run the database builder.

 

Can you please explain exactly how to install it? I'd sure appreciate it.

 

Thanks, best regards, Bob

 

 

Dear Bob,

 

I'm happy to help, though I'm no software geek either. I only got to this tweak, because I really like to use this gauge and I didn't find any workable solution to my problem, in my extensive google search on the topic.

 

Just so that we are on the same page.

 

1. Make sure your UAC is 'OFF'.

 

2. Make sure you run the install AND the database builder 'As Administrator'.

 

Now, as I see from your post above, you installed the program at C:\Program Files (x86)\Microsoft Games\Flight Simulator X,tso this is where you will find the "Mahasoft" folder. In my case I had installed the gauge to its default location of C:\Program File (x86) so it created the Mahasoft folder in the root directory. Since, you appear to have installed it a different path, you will find it at that place.

 

Inside the 'Mahasoft' folder, you should find three files. DBA.dll, DBBuilder.exe and manual.pdf.

 

Run DBBuilder.exe as administrator as per the steps listed in my first post.

 

Do confirm, if it works for you this time.

 

Happy landings,

 

Mickey

Share this post


Link to post
Share on other sites

Gents,

 

If you follow the steps listed above, even though you will be able to build the 'database' but i have discovered that the gauge is still not usable inside the cockpit. Still working on trying to get it to work. If I make any headway, I will make a post here.

 

Thank you for your patience.

 

Mickey

Share this post


Link to post
Share on other sites

Mickey, I'm not familiar with this gauge, but if Holger is depending on a PDF viewer module anywhere along the line, be aware that the latest version of Adobe Acrobat does not support these older modules.

Share this post


Link to post
Share on other sites

Use Adobe Acrobat v10.0 or earlier. The current version of Acrobat is built with Flash and has given me serious stick in my RL job.

 

-Dai

Share this post


Link to post
Share on other sites

HEY GUYS...

 

AFTER MANY WEEKS OF TRYING TO DOWNLOAD THE AIRPORT DATA BASE IN WIN 7 64 BIT SEARCHING THE FORUMS FOR FIZES AND FOLLOWING THE INSTRUCTIONS ABOVE I HAD NO JOY......

 

SO OUT OF PURE FRUSTRATION AND LAST RESORT I DECIDED AFTER TRYING THE ABOVE AND STILL NOT WORKING TO LOAD UP FSX AND TRY IT.....

 

GUESS WHAT...IT UPDATED THE AIRPORTS....

 

SO BASICALLY IF YOU CAN'T GET YOUR AIRPORTS DOWNLOADING...LOAD UP FSX.... WHILE IN THE MAIN (FIRST SCREEN)

OPEN THE DATABASE BUILDER AND UPADTE...

 

WOW IT WORKS!

 

I FELT REALLY STUPID NOT TRYING THIS BEFORE BUT NO WHERE COULD I FIND IT SAYS  YOU HAVE TO HAVE FSX RUNNING BEFORE UPDATING THE AIRPORTS.

 

HOPE THIS WORK FOR OTHERS ....

 

****UPDATE****

So I did a stupid thing and tried this again and tried to update / re build the databse...it re built it all right...with NO airports and know can't get it to build again....... so sorry for the bogus info...back to square 1...no idea how I  got it to work that first time......

 

1 thing I did notice is that the folder always reverts back to the read only (box being blue) so think this may be the problem but can't find a fix..... :(

Share this post


Link to post
Share on other sites

×
×
  • Create New...