Jump to content

Archived

This topic is now archived and is closed to further replies.

skylim

FSX Rudder deflection to the right

Recommended Posts

Dear flightsimmers,

 

Since a few days I'm experiencing a problem with my rudder.

My rudder deflects about a half of the maximum deflection to the right, without any input.

I use the Saitek rudder pedals, but I use them two years now and never had any trouble with them.

 

Today I reïnstalled FSX, but it didn't solve the problem.

I've also searched through the forum but I could't find a solution.

 

A help-out for this annoying problem would be very much appreciated!

 

Regards

Share this post


Link to post
Share on other sites

Have you tried to recalibrate your pedals? And does that happen also when your pedals are not connected?

Share this post


Link to post
Share on other sites

Tnx for your quick response!

 

Yes I recalibrated them but it doesn't help.

Disconnecting the pedals doesn't help either...

Share this post


Link to post
Share on other sites

This may come in like a stupid question, but did you check if it happens just on the ground? Reason is that, with the yaw damper active, some (sim) planes tend to develop a rather nervous rudder behaviour while on the ground.

 

One can see it in the external view, the YD may correct for something and the rudder is moving, even when parked with the engines running. With the YD off, everything is fine and the takeoff run is 'all yours'. Turning it on when airborne then leads to normal and useful rudder deflections.

 

Another one would be to accidentally enable autorudder in the realism settings. This causes any aileron movement to also deflect the rudder and even the nose wheel (if steerable). So perhaps check if autorudder is off.

Share this post


Link to post
Share on other sites

Dear CoolP,

 

It happens on the ground, on the water and in the air. Autorudder and YD are off.

And whenever I give a rudder imput, the correct deflection is given, but it returns to the original deflection after 1 second.

 

Thanks for your response!

Share this post


Link to post
Share on other sites

have you checked the actual signal the rudder pedals send within the calibration window? worst case scenario might be, that the pedals are broken.

just fire up the windows calibration preferences, press the pedals around a little and check if the input is correct in the test tab display.

if it is, then at least you can rule out a hardware defect.

Share this post


Link to post
Share on other sites

have you checked the actual signal the rudder pedals send within the calibration window? worst case scenario might be, that the pedals are broken.

just fire up the windows calibration preferences, press the pedals around a little and check if the input is correct in the test tab display.

if it is, then at least you can rule out a hardware defect.

 

Just did the calibration check again and the pedals behaved like they should.

Apart from that, the problem also occurs when flying with my joystick.

So I suspect it is a FSX setting, but I have no idea which...

Share this post


Link to post
Share on other sites

Guys,

 

I'm glad to let you know I've found the problem.

The rudder sensitivity was too low/high, because the only solution was to set it around 50%.

 

 

Everyone thanks for trying to help me out! :smile:

Share this post


Link to post
Share on other sites

Without knowing more of your setup, addons and the planes you fly, I can just try to give a few more suggestions that come to mind:

 

Have you checked your trim? It could be that somewhere you have a conflicting input that you press during setup that also changes trim?

 

Another thought on a similar basis was another source for rudder input other than your pedals. For example, check that your joystic twist axis is not also affecting the rudder.

 

Hope you manage to find the source of your problem!

 

Uhh, how did that happen! I'm sure your post wasn't there when I wrote mine.. Oh well, glad it is sorted! :smile:

Share this post


Link to post
Share on other sites

×
×
  • Create New...