Jump to content

Archived

This topic is now archived and is closed to further replies.

SKEWR

nVidia disabling Aero

Recommended Posts

I'm having a problem with nVidia drivers disabling aero. I'm not in love with aero, but when I try to start FSX, I get the warning that my video card (ev3a 580GTX) is not compaitable. Anyone have a fix for this or do I just stay at 301.24 forever? :(

 

Problem:

Aero not enabled with latest drivers on my system

With new drivers, it appears to think I have a second monitor (i do not) as you can scroll the mouse off the right side of the screen

 

System listed in specs (Summary: i7 2600k, 8GB RAM, GTX580)

 

What I tried:

Driver sweep then installing 301.42, restart (disabled aero, no FSX)

Driver sweep then installation of beta 306, restart (no aero, no FSX)

Driver Sweep of all nVidia drivers, then Safe mode installation of driver 301.42, then restart

Insuring that montior and HDMI cable were connected to the right connector

nVidia control panel set to "Single Monitor"

 

What I tried using Google

"brute force" (through regedit) of turning on aero

Enabling and disabling Aero peek through regedit

Searching AVSIM/internet forums for others who have had this issue (most common solution was to select an aero theme in Personalize desktop. Proposed solution did not work)

 

 

Desired outcome

Able to run FSX with the most current drivers

 

Thanks for any help you can provide.

Share this post


Link to post
Share on other sites

 

 

Hi Cory. I'm curious if your problem is that Aero is disabled or if you're completely unable to run FSX.

 

Aero, by default, is disabled when starting FSX thanks to some incompatibilities. This is desirable.

Share this post


Link to post
Share on other sites

Hi Zach.

 

When the aero theme is not working (as disabled by the new nVidia drivers), FSX gives the video card error message.

 

With the 301.24, Win7 disables aero and FSX works with no issues.

Share this post


Link to post
Share on other sites

Hi Zach.

 

When the aero theme is not working (as disabled by the new nVidia drivers), FSX gives the video card error message.

 

With the 301.24, Win7 disables aero and FSX works with no issues.

 

I see. I also notice this is a BETA driver! Do you have a specific reason for not using an official, stable release?

Share this post


Link to post
Share on other sites

Hi Cory

I loaded this 306.xx beta driver recently and very soon I was seeing black screens and long freezes when trying to run FSX - which eventually did run. It took me nearly 3 days to uninstall this driver even though I cleaned out the registry and the nvidia folders manually, In the end I clean installed the latest WHQL driver the 304.48 and everything is working again, but I had to install the latest PhysX driver before I could get the driver install and also load windows 7 at startup in Low video mode. Weird!! :lol: There seems to be an interaction on my system between the inbuilt Intel 3000 on board graphics as I was prompted to load drivers for this even though it is disabled in the BIOS, (this may give rise to the aero issue - I have aero switched off).

 

This was not a good driver for me amd there are quite a few reports in the forums postulating that thre are issues with the driver.

Hope you get it fixed.

 

PeterH

Share this post


Link to post
Share on other sites

I see. I also notice this is a BETA driver! Do you have a specific reason for not using an official, stable release?

I tried driver 301.42 with no success.

 

@FreeSpirit: I'll look to see if I can find 304.48

 

Thanks for your responses!

Share this post


Link to post
Share on other sites

Good luck, Cory. Sorry I have no experience with that card. Perhaps someone will come along that does!

Share this post


Link to post
Share on other sites

Just to close this out (in case anyone else gets this)

 

1) Driver Sweeper (or a similar driver removal program)

2) Go into safe mode (F8) before the windows splash screen

3) Run as adminstrator (dont think you need this but I did it anyway)

4) Reboot after installation

5) Profit!

 

I did these steps last night, but I guess today is a different day.

Thanks again for those folks trying to help.

Share this post


Link to post
Share on other sites

Aero, by default, is disabled when starting FSX thanks to some incompatibilities. This is desirable.

 

If you want fsx with aero enabled there is a pinned topic called: "addendum to vsync fix" :smile:

 

(Found latest whql driver from nvidia is 301.42,rest is all beta!)

 

 

Regards John

Share this post


Link to post
Share on other sites

×
×
  • Create New...