Jump to content

Archived

This topic is now archived and is closed to further replies.

Recommended Posts

First off I would like to say thankyou so very much to all of you that have posted on this forum and others, you have helped me incalculably over the last couple of years to get my fsx running beyond my expectations. unfortunately I don't have the expertise to be able to add any fresh advice to this knowledge base, but i am here because I have an issue i cannot understand and cannot find posted anywhere.

 

Anyway it had been a while since i'd done any tweaking but now I've just done a fresh windows install and FSX is driving me nuts.

 

The issue is that my aircraft are displaying.loading incorrectly - wheels on top of the fuselage, horizontal stabilizer running through the cockpit - etc etc

 

It was fine before but somewhere along the line (unfortunately I'm to tired to remember exactly when lol) it went beserk.

 

 

I initially had a feeling it was to do with newer nvidia drivers but now I'm thinking it might be to do with FTX AU. Have already reset default flight in fsx cfg, cfg is optimized, fsx was running, but after installing FTXAU (twice) this problem occurred, which seems weird to me because I would assume that FTXAU doesn't edit simobjects files?

 

Here is my specs:

ASRock G41M-S3 - has DPC Latency issues with high autogen resulting in audio crackle, any advice?)

Q6600 G0 @ 2.7GHz - I know, i got real unlucky, it won't go any higher on stock vcore, isn't stable at 3GHz with 1.4vcore :O

 

8GB DDR3 GEIL Enhance 9-9-9-24

ASUS GTX660 OC 2GB

OCZ Vertex 4

WD Raptor

Win 7 Ultimate x64 SP1

 

And a screenshot:

 

 

 

Anyway if any of you have come across this or have any ideas as to what it could be it would be much appreciated. Thanks.

Share this post


Link to post
Share on other sites

Actually, I know exactly what your problem is! You have installed Shader 3 Mod and you miss 2 lines in your FSX.cfg!

 

Put this in your FSX.cfg under [GRAPHICS]. Hope that helps you!

[GRAPHICS]

ForceFullScreenVSync=1

ALLOW_SHADER_30=1


Regards, Albert Miu
                                                            CPU: Intel i7 4790k @4.6Ghz GPU: ASUS GTX 1080 8GB OC Motherboard: Asus MAXIMUS VI Hero RAM: Corsair Vengeance Pro 16GB 1866mhz 
                                               PSU: EVGA SuperNOVA 850W G2 Case: Corsair VENGEANCE C70 Cooler: Corsair Hydro Series H110 Monitor: BENQ 1920x1080 Windows: 10 x64 Professional

                                                                                                X-Plane 11 Group:     Facebook

Share this post


Link to post
Share on other sites

Hey man, thanks for the quick reply, I fell asleep haha.

 

I haven't installed a shader mod, other than cfg tweaks, uiautomationcore.dll, some water tweaks and a few others I haven't modified it a whole lot.

 

I tried what you said anyway and deleted the shader cache so fsx would rebuild it but to no avail.

 

I think this something a bit more messed up.

 

I've repaired both the fsx and accel installs and still nothing.

 

I'm going to try uninstalling ftx and see what happens.

Share this post


Link to post
Share on other sites

Did you add in your FSX.cfg what I said, try to find the Shader 3 Mod, it will resolve your problem, and give you a performance boost! Its an exe file!


Regards, Albert Miu
                                                            CPU: Intel i7 4790k @4.6Ghz GPU: ASUS GTX 1080 8GB OC Motherboard: Asus MAXIMUS VI Hero RAM: Corsair Vengeance Pro 16GB 1866mhz 
                                               PSU: EVGA SuperNOVA 850W G2 Case: Corsair VENGEANCE C70 Cooler: Corsair Hydro Series H110 Monitor: BENQ 1920x1080 Windows: 10 x64 Professional

                                                                                                X-Plane 11 Group:     Facebook

Share this post


Link to post
Share on other sites

Yeah I did but I didn't try the mod, didn't want to possibly create more problems, but I'm all out of ideas so I'll give it a shot after this repair completes.

 

Would you recommened *******' Mod or SweetFX?

 

Thanks again man

Share this post


Link to post
Share on other sites

You will not have any problems, I have it and its given me 5-6FPS more!! http://www.lockonfil...der-30-mod-v16/

 

JUST RUN THE EXE NOTHING ELSE in the archive!!!!!!!!


Regards, Albert Miu
                                                            CPU: Intel i7 4790k @4.6Ghz GPU: ASUS GTX 1080 8GB OC Motherboard: Asus MAXIMUS VI Hero RAM: Corsair Vengeance Pro 16GB 1866mhz 
                                               PSU: EVGA SuperNOVA 850W G2 Case: Corsair VENGEANCE C70 Cooler: Corsair Hydro Series H110 Monitor: BENQ 1920x1080 Windows: 10 x64 Professional

                                                                                                X-Plane 11 Group:     Facebook

Share this post


Link to post
Share on other sites

Thanks for the link - gave it a shot, no dice. Still loads up as above and even just in the aircraft preview screen fps appears very low. I'll leave it installed anyway as I'm sure once I get FSX working it will look nicer.

 

I'm using DX9 if that makes a difference.

 

I also have frame rate locked at 30 in nvidia control panel (adaptive limiting).

 

here is my cfg as well if it helps. I know the bufferpool is high, but I tweaked for hours and that's what worked best. UsePools=0 made it very glitchy.

 

 

[bufferPools]

UsePools=1

PoolSize=1073741824

RejectThreshold=2097152

 

[GRAPHICS]

HIGH_MEM_FIX=1

D3D10=0

TEXTURE_MAX_LOAD=4096

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=1

AIRCRAFT_REFLECTIONS=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=1

AC_SELF_SHADOW=0

EFFECTS_QUALITY=2

GROUND_SHADOWS=0

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

ForceFullScreenVSync=1

ALLOW_SHADER_30=1

SHADER_CACHE_PRIMED_10=1693500672

SHADER_CACHE_PRIMED=1693500672

 

 

[sOUND]

AmbientUIMusicVolume=-6.000000

PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}

VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}

SOUND=1

SOUND_QUALITY=2

SOUND_LOD=0

UISound=0

AmbientUI=0

SOUND_FADER1=0.500000

SOUND_FADER2=0.500000

SOUND_FADER3=0.500000

SOUND_FADER4=0.500000

AmbientUIMusic=FSX01

 

 

[Display]

ChangeTime=4.000000

TransitionTime=4.000000

ActiveWindowTitleTextColor=255,255,255

ActiveWindowTitleBackGroundColor=0,28,140,64

NonActiveWindowTitleTextColor=255,255,255

NonActiveWindowTitleBackGroundColor=24,33,87,64

InfoUpperRightTextColor=255,0,0

InfoUpperRightBackGroundColor=0,0,0,0

InfoLowerLeftTextColor=255,255,255

InfoLowerLeftBackGroundColor=255,0,0,128

InfoLowerRightTextColor=255,255,255

InfoLowerRightBackGroundColor=255,0,0,128

InfoBrakesEnable=True

InfoParkingBrakesEnable=True

InfoPauseEnable=True

InfoSlewEnable=True

InfoStallEnable=True

InfoOverspeedEnable=True

BLOOM_EFFECTS=0

SKINNED_ANIMATIONS=1

TEXTURE_BANDWIDTH_MULT=120

UPPER_FRAMERATE_LIMIT=0

WideViewAspect=True

 

[JOBSCHEDULER]

AffinityMask=14

 

[Main]

DisablePreload=1

User Objects=Airplane, Helicopter

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

SimObjectPaths.6=ORBX\FTX_AU\FTXAI_AIRCRAFT

Location=440,130,1480,908,\\.\DISPLAY6

Maximized=2

HideMenuNormal=0

HideMenuFullscreen=1

ProcSpeed=7722

PerfBucket=7

 

 

[PANELS]

IMAGE_QUALITY=1

DEFAULT_VIEW=1

QUICKTIPS=0

PANEL_OPACITY=100

PANEL_MASKING=1

PANEL_STRETCHING=1

UNITS_OF_MEASURE=0

 

 

[Weather]

WindshieldPrecipitationEffects=1

MinGustTime=10

MaxGustTime=500

MinGustRampSpeed=1

MaxGustRampSpeed=200

MinVarTime=5

MaxVarTime=50

MinVarRampSpeed=10

MaxVarRampSpeed=75

TurbulenceScale=1.000000

WeatherServerAddress=fs2k.zone.com

WeatherServerPort=80

WeatherGraphDataInDialog=0

AdjustForMagVarInDialog=1

DynamicWeather=2

DownloadWindsAloft=1

DisableTurbulence=0

CLOUD_DRAW_DISTANCE=5

DETAILED_CLOUDS=1

CLOUD_COVERAGE_DENSITY=8

THERMAL_VISUALS=1

[DISPLAY.Device.NVIDIA GeForce GTX 660 .0]

Mode=1920x1080x32

AntiAlias=1

Anisotropic=1

 

 

[AccelerationPack]

ControlsFirstRun=0

HomePageFirstRun=0

 

 

[CONTROLS]

Controls_Default=Standard

Controls_Current=Standard

KBDAIL=64

KBDELEV=64

KBDRUD=64

 

 

[TextInfo.1]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

WindDirectionAndSpeed=1,6

 

 

[TextInfo.2]

FrameRate=1,1

LockedFrameRate=1,2

GForce=1,3

FuelPercentage=1,4

 

 

[TextInfo.3]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

WindDirectionAndSpeed=1,6

FrameRate=2,1

LockedFrameRate=2,2

GForce=2,3

FuelPercentage=2,4

 

 

[slewTextInfo.1]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

 

 

[slewTextInfo.2]

FrameRate=1,1

LockedFrameRate=1,2

 

 

[slewTextInfo.3]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

FrameRate=2,1

LockedFrameRate=2,2

 

 

[Trusted]

E:\Programs\Microsoft Flight Simulator X\Modules\FSCopilot.dll.qqiwziobhhtnzrotlchnululquikqteqatrtrbok=1

E:\Programs\Microsoft Flight Simulator X\FsPassengers\bin\fspassengersx.dll.cztunoeticzukcrcollwlbkbbocuzqioqlwrwzuk=1

E:\Programs\Microsoft Flight Simulator X\Modules\FSUIPC4.dll.wibzblnlwnaelulrqkkklbozzoktbzereekikqrr=1

E:\Programs\Microsoft Flight Simulator X\PMDG\DLLs\PMDG_HUD_interface.dll.nnbnaczthtnzlqzrwitzkkqklnwkzakzkcaewizt=1

E:\Programs\Microsoft Flight Simulator X\PMDG\DLLs\PMDGOptions.dll.clktzqaruiekwqwulaneuirwcqneetebbrollcuo=1

E:\Programs\Microsoft Flight Simulator X\PMDG\DLLs\PMDGEvents.dll.ctholttucnehthiblnnlrehhhazlhkkcieqaznlo=1

E:\Programs\Microsoft Flight Simulator X\PMDG\DLLs\PMDGSounds.dll.llhlikubkilibcuuwehiukbabinwzznblhrwbqnk=1

E:\Programs\Microsoft Flight Simulator X\GAUGES\XGauge.DLL.bhainetonzekliihtuaculbzolonunbhhirqtlch=2

E:\Programs\Microsoft Flight Simulator X\GAUGES\Cessna.DLL.hnibwuonnkiucczeaulkbazeizqlehciuibaknlw=2

E:\Programs\Microsoft Flight Simulator X\GAUGES\Cessna172.DLL.heawhbnuqwbrlehewelokqnchenoqrzoknwnwrzr=2

E:\Programs\Microsoft Flight Simulator X\GAUGES\Cessna182s.DLL.baqewzrbzkzootqthtcntwkkqabwiwutkwnoatnz=2

E:\Programs\Microsoft Flight Simulator X\GAUGES\CessnaWAlpha.DLL.lzauquiqahqqiawkkknqhelwkzhkkkhwnrtikotr=2

E:\Programs\Microsoft Flight Simulator X\GAUGES\Bendix_King_Radio.DLL.whalabcbinuokwihtkqlwrcoetwqackzqznoahzq=2

E:\Programs\Microsoft Flight Simulator X\GAUGES\Bell_206B.DLL.hcanwnhkweaiauhqzatqeqtbulrqzbtrekcnltlh=2

 

 

[DynamicHeadMovement]

LonAccelOnHeadLon=-0.020000

LonAccelOnHeadPitch=-0.010000

RollAccelOnHeadLat=0.010000

YawAccelOnHeadLat=-0.100000

RollAccelOnHeadRoll=0.100000

MaxHeadAngle=5.000000

MaxHeadOffset=0.300000

HeadMoveTimeConstant=1.000000

[VirtualCopilot]

VirtualCopilotActive=0

 

 

[uSERINTERFACE]

PageID=1

OpenATCOnCreate=0

ShowAllACPaintSchemes=0

SelectAircraftManufacturer=All

SelectAircraftPublisher=All

SelectAircraftType=All

SHOW_MISSION_CAPTIONS=0

PAUSE_ON_LOST_FOCUS=1

PROMPT_ON_EXIT=1

SITUATION=FLIGHTS\OTHER\FLTSIM

Map_Orientation=2

DisplayFuelAsWeight=1

 

 

[ATC]

ShowATCText=1

COMM_MSG_NONE_COLOR=FFFFFFFF

COMM_MSG_ATC_USER_COLOR=FFB6FFB6

COMM_MSG_USER_ATC_COLOR=FFFFD21B

COMM_MSG_ATC_AI_COLOR=FF00FF00

COMM_MSG_AI_ATC_COLOR=FFFF7840

AutoOpenAirTrafficWindow=0

UsePilotVoice=1

PilotVoice=0

 

 

[PointOfInterestSystem]

CycleSetting=0

 

 

 

 

[sCENERY]

SmallPartRejectRadius=2

LENSFLARE=0

DAWN_DUSK_SMOOTHING=1

IMAGE_COMPLEXITY=3

 

 

[TrafficManager]

AirlineDensity=35

GADensity=20

FreewayDensity=15

ShipsAndFerriesDensity=15

LeisureBoatsDensity=15

IFROnly=0

AIRPORT_SCENERY_DENSITY=5

 

 

[TERRAIN]

TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2000

TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=1700

LOD_RADIUS=4.500000

MESH_COMPLEXITY=100

MESH_RESOLUTION=22

TEXTURE_RESOLUTION=29

AUTOGEN_DENSITY=3

DETAIL_TEXTURE=1

WATER_EFFECTS=7

 

[AContain]

ShowLabels=0

ShowUserLabel=0

ShowLabelManufacturer=1

ShowLabelModel=1

ShowLabelTailNumber=0

ShowLabelDistance=1

ShowLabelAltitude=1

ShowLabelAirline=0

ShowLabelAirlineAndFlightNumber=0

ShowLabelFlightPlan=0

ShowLabelContainerId=0

ShowLabelAirspeed=0

ShowLabelHeading=0

LabelDelay=1000

LabelColor=FFFF0000

 

 

[iNTERNATIONAL]

ASLAT=3

ASLON=0

MEASURE=0

[REALISM]

PFactor=1.000000

Torque=1.000000

GyroEffect=1.000000

CrashTolerance=1.000000

General=1.000000

UnlimitedFuel=False

AllowEngineDamage=True

TrueAirspeed=False

AutoCoord=False

RealMixture=True

StressDamage=True

GEffect=True

ManualLights=True

GyroDrift=False

CrashWithDyn=True

CrashDetection=True

AutoTrim=False

 

[sIM]

SYSCLOCK=1

 

[sTARTUP]

DEMO=0

SHOW_OPENING_SCREEN=1

STARTUP_DEMO=

LoadWindow=1

 

[FACILITIES]

COUNTRY=

STATE=

CITY=

GTL_BUTTON=1334

 

 

[Misc]

Com_Rate=7

[MAPVIEW_MAP]

SHOW_AIRPORTS=1

SHOW_VORS=1

SHOW_NDBS=1

SHOW_APPROACHES=1

SHOW_INTERSECTIONS=0

SHOW_VICTOR=0

SHOW_JET=0

SHOW_AIRSPACE=1

SHOW_FLIGHTPLAN=1

SHOW_WEATHERSTATIONS=1

SHOW_WEATHERSYSTEMS=1

SHOW_DATATAGS=1

SHOW_TERRAIN=1

show_flight_history=1

[MULTIPLAYER]

condAccoutPassword=0

 

 

thanks again really appreciate the help

Share this post


Link to post
Share on other sites

I've had this problem a few times before myself and its always been related to something I mucked up in the .cfg. You could try renaming your fsx.cfg and letting it rebuild, see if that fixes it, then reinsert all your tweaks?


ckyliu, proud supporter of ViaIntercity.com. Find my spec and settings in "About me" on my profile.

support1.jpg

Share this post


Link to post
Share on other sites

Ok so I let it rebuild cfg and I got this with the untouched rebuilt fsx.cfg

 

 

 

Don't you just love FSX lol

 

Going to revert back to old one, thanks for the suggestion all the same, seems like this is some seriously random issue

 

Update: Old one restored textures, but the planes are still messed up. Also this is occuring for every single plane.

Share this post


Link to post
Share on other sites

wait!!!!!!!!!!

Delete your CFG and put the lines that I posted up, in [graphics]!!!! Se what happens!!!!


Regards, Albert Miu
                                                            CPU: Intel i7 4790k @4.6Ghz GPU: ASUS GTX 1080 8GB OC Motherboard: Asus MAXIMUS VI Hero RAM: Corsair Vengeance Pro 16GB 1866mhz 
                                               PSU: EVGA SuperNOVA 850W G2 Case: Corsair VENGEANCE C70 Cooler: Corsair Hydro Series H110 Monitor: BENQ 1920x1080 Windows: 10 x64 Professional

                                                                                                X-Plane 11 Group:     Facebook

Share this post


Link to post
Share on other sites

Sorry man was typing this didn't see your post, trying it now

 

I guess by process of elimination I can rule out shaders and cfg?

 

Does this section of aircraft cfg look normal? I've never looked a this section before

 

thanks again

 

 

 

[airplane_geometry]

wing_area = 163.0

wing_span = 33.0

wing_root_chord = 8.3

wing_dihedral = -1.0

wing_incidence = 5.0

wing_twist = 0

oswald_efficiency_factor= 0.60

wing_winglets_flag = 0

wing_sweep = 30.0

wing_pos_apex_lon = 4.0

wing_pos_apex_vert = 3.0

htail_area = 0

htail_span = 0

htail_pos_lon = 0

htail_pos_vert = 0

htail_incidence = 0

htail_sweep = 0

vtail_area = 6

vtail_span = 2

vtail_sweep = 0

vtail_pos_lon = 3

vtail_pos_vert = -1

elevator_area = 0

aileron_area = 0

rudder_area = 0

elevator_up_limit = 37.0

elevator_down_limit = 35.0

aileron_up_limit = 20.0

aileron_down_limit = 20.0

rudder_limit = 0

elevator_trim_limit = 20.0

spoiler_limit = 0

spoilerons_available = 0

aileron_to_spoileron_gain = 0

min_ailerons_for_spoilerons= 0

min_flaps_for_spoilerons = 0

auto_spoiler_available = 0

spoiler_extension_time = 0

positive_g_limit_flaps_up = 4.0 //Design G load tolerance (positive, flaps up)

positive_g_limit_flaps_down= 4.0 //Design G load tolerance (positive, flaps down)

negative_g_limit_flaps_up = -2.0 //Design G load tolerance (negative, flaps up)

negative_g_limit_flaps_down= -2.0 //Design G load tolerance (negative, flaps down)

load_safety_factor = 1.5 //Design G load safety factor

Share this post


Link to post
Share on other sites

no need to touch aircraft.cfg!!!


Regards, Albert Miu
                                                            CPU: Intel i7 4790k @4.6Ghz GPU: ASUS GTX 1080 8GB OC Motherboard: Asus MAXIMUS VI Hero RAM: Corsair Vengeance Pro 16GB 1866mhz 
                                               PSU: EVGA SuperNOVA 850W G2 Case: Corsair VENGEANCE C70 Cooler: Corsair Hydro Series H110 Monitor: BENQ 1920x1080 Windows: 10 x64 Professional

                                                                                                X-Plane 11 Group:     Facebook

Share this post


Link to post
Share on other sites

DUDE YES!!! Thankyou so much, that did the trick.

 

I left the rest of the cfg as default and added the entries in under [GRAPHICS] and it worked.

 

I must have mucked something up, weird though because it didn't seem to happen after i tweaked the cfg.

 

Anyway I'll start adding the tweaks back in one by one and if I can isolate the problematic entry I shall let you know.

 

 

THE CULPRIT -

 

It was the bufferpools entry lol. It worked fine when i reloaded in game but for some reason didn't like the setting upon program restart.

 

I did think that I shouldn't be using it as my GPU far exceeds my CPU, but it *seemed* to be making things better

 

I'm going to add other tweaks one by one and il let you know if any other issues crop up.

Share this post


Link to post
Share on other sites

OK!! I'm glad i could help you!! Add one tweak at a time and eliminate the one that create the problem!! Also you should see some improvements with shader 3 mod!!!!


Regards, Albert Miu
                                                            CPU: Intel i7 4790k @4.6Ghz GPU: ASUS GTX 1080 8GB OC Motherboard: Asus MAXIMUS VI Hero RAM: Corsair Vengeance Pro 16GB 1866mhz 
                                               PSU: EVGA SuperNOVA 850W G2 Case: Corsair VENGEANCE C70 Cooler: Corsair Hydro Series H110 Monitor: BENQ 1920x1080 Windows: 10 x64 Professional

                                                                                                X-Plane 11 Group:     Facebook

Share this post


Link to post
Share on other sites

I guess by process of elimination I can rule out shaders and cfg? Does this section of aircraft cfg look normal? I've never looked a this section before

 

Keep out the aircraft.cfg files, you're not going to find a solution in there. However, what you've posted is perfectly normal. When I had the issue you originally posted up I had to revert to an older version of my fsx.cfg to fix it, I found if I removed it and let FSX rebuild it, it just made it worse because of all the addons and tweaks I had. You may find your only fix is to do a fresh install of FSX so you get a clean .cfg, then make sure you keep a copy of this.

 

EDIT: Never mind you've fixed it without a complete reinstall, and now I know what to do in future if I stuff it up again!


ckyliu, proud supporter of ViaIntercity.com. Find my spec and settings in "About me" on my profile.

support1.jpg

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    39%
    $9,880.00 of $25,000.00 Donate Now
×
×
  • Create New...