Jump to content

Archived

This topic is now archived and is closed to further replies.

Tom Wright

Sound Disappears (Win 8)

Recommended Posts

Hi all,

 

I'm another one suffering the loss of all sound after 10-15 minutes under Windows 8. None of the suggestions I've seen - changing Windows sound settings, loading from a saved flight, not using the FS flight planner, updating DirectX (it was already up to date) etc - have worked for me. I know it's on the fix list for the Service Pack but is there anything that you've done that has worked to resolve this issue (a workaround) that I can try or is my aircraft hangared until the SP is released?

 

Cheers!

Share this post


Link to post
Share on other sites

Hi Tom,

 

Have you tried going into your Control Panel > Sound settings, and clicking on the "Communications" tab, then setting the radial button to "Do Nothing" ?

 

The other one that seems to fix the issue for Win 8 owners, is going into the same Control Panel > Sound settings, and this time, on the main "Playback" tab, hit "Properties". Then in the new box that pops up, hit the "Advanced" tab. Now UNcheck the "Allow applications to take exclusive control of this device" option.

 

Worth a try. I'm a Win 7 64bit user, and the 'save flight then quit, restart and load it' solution works for me. But the above has worked for a lot of Win 8 users.

 

Cheers.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for your advice. However the Sound tab in the Control Panel is greyed out for me? FSX is running with the Dash loaded, and the Pause on Task switch option in FSX is unchecked.

 

Cheers

Share this post


Link to post
Share on other sites

In fact on closer investigation the control panel doesn't work at all. Nothing gets sent to the sim.  :huh:

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for your advice. However the Sound tab in the Control Panel is greyed out for me? FSX is running with the Dash loaded, and the Pause on Task switch option in FSX is unchecked.

 

Cheers

I may have misled you Tom; I wasn't referring to the Sound tab of the Majestic Control Panel. ......... I was referring to your Windows Sound Panel.

 

It should look something like this :-

 

12121210.png

 

In fact on closer investigation the control panel doesn't work at all. Nothing gets sent to the sim. :huh:

The Majestic Control Panel only works when FSX is running, and the Q400 is loaded and unpaused.

Share this post


Link to post
Share on other sites

The Majestic Control Panel only works when FSX is running, and the Q400 is loaded and unpaused.

 

Also the Sound tab in the Majestic Control Paenl is greyed out in the Pilot edition, the sound tab will only be available in the Pro and Training editions of the Q400.

Share this post


Link to post
Share on other sites

Thanks guys. I've done that and now seem to have a different problem (it doesn't seem related but it wasn't happening before I did this). As soon as I push the power levers forward to take off, the aircraft just leaps off the ground vertically and goes into a spin! Bizarre!!

Share this post


Link to post
Share on other sites

As absurd as that is... it isn't related. I did those 2 steps as well, and my Dash-8 hasn't suddenly lept into the air vertically. 
Has any other setting changed? Maybe something in Majestic's Control Pänel?

Share this post


Link to post
Share on other sites

The 'leaping' is as far as I know, due to the external flight model system going a little crazy if the starting of the flight set-up isn't quite right.

 

So try setting up a proper 'template' flight for the Q400 and saving it.   (the plane can be in any state you like).  Then try loading that saved flight, and see if you still have the 'leap' ?

Share this post


Link to post
Share on other sites

Hi guys,

 

Thanks for your replies. Unfortunately eventually I lost the sound again even after changing those sound settings. I contacted Support yesterday and got a reply this morning. They were very helpful and have sent me an updated aircraft.cfg file which has permanently fixed the sound issue. If anyone else is using Windows 8 and suffers the same problem I would urge you to do the same!

 

That does seem to make sense regarding the bouncing. I have been doing something similar which seems to work just as well; which is loading a default aircraft, setting the parking brake (which is off by default) and then switching to the Q400. It's not completely cured it but it's certainly suppressed it a lot.

 

I have now finally managed to complete my first flight in it from Gatwick EGKK to Guernsey EGJB. One relatively minor thing I've found is that the control column movement is sometimes laggy and other times smooth. I'm not sure whether it's just the animation or whether it's also affecting the actual flight model. Have you noticed this?

 

Thanks

Share this post


Link to post
Share on other sites

Hi guys,

 

Thanks for your replies. Unfortunately eventually I lost the sound again even after changing those sound settings. I contacted Support yesterday and got a reply this morning. They were very helpful and have sent me an updated aircraft.cfg file which has permanently fixed the sound issue. If anyone else is using Windows 8 and suffers the same problem I would urge you to do the same!

 

That does seem to make sense regarding the bouncing. I have been doing something similar which seems to work just as well; which is loading a default aircraft, setting the parking brake (which is off by default) and then switching to the Q400. It's not completely cured it but it's certainly suppressed it a lot.

 

I have now finally managed to complete my first flight in it from Gatwick EGKK to Guernsey EGJB. One relatively minor thing I've found is that the control column movement is sometimes laggy and other times smooth. I'm not sure whether it's just the animation or whether it's also affecting the actual flight model. Have you noticed this?

 

Thanks

 

That's excellent news! ...... Pleased you got the sound issue sorted :cool:

 

Yes, I have noticed the "lazy" movements of the control column and yoke;  I attributed it to the fact that the model is probably following the incoming flight control movements that come into FSX from the external flight model; hence the lag.    But I tend to remove the column any way once in the 'pit, so it's not a major issue for me.

Share this post


Link to post
Share on other sites

×
×
  • Create New...