Sign in to follow this  
jcmc1405

Help with performance

Recommended Posts

I have noticed a strange behaviour of fsx in my task manager and I wanted to know if a experienced fsx user can help me. I have an Intel core i5-2410m cpu. it has two physical cores and HT on. It seems like fsx is only actively using cores 0 and 2. Im havng a really bad performance right now. In my fsx.cfg I have "affinitymask=4". Also I noticed that fsx is using only about 2.2 GB of VAS. But the preformance is very poor. 

 

My system config is:

 

Intel core i5-2410M cpu

AMD radeon 6630M 

4GB Ram DDR3

 

Im getting less than 10 fps right now. Im very frustrated because I cant enjoy my 777. Please anyone help me!. I know my system has the minimum specs to run the 777 But there must be something that can be done to be at least over 10 fps.

 

Regards

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 
 

Hyperthreading is useless in FSX - you should disable it. FSX will not avail itself of the virtual cores.

 

That leaves you with only two cores to do the work of running your OS, plus FSX etc.

This, in my experience, just isn't enough to properly run FSX alongside a cpu intensive add-on like the 777.

 

The best you can hope for is getting FSX to use both physical cores, with an affinity mask of 3 (0011 read right-to-left). This tells FSX to use both physical cores (with HT off), although core 0 will have to share workload with the OS.

You might also want to try overclocking it, but it's a laptop, right ? Not good for temperatures.

Your CPU has a turbo speed of 2.9GHz. Can you enable this permanently ?

 

Also, the Radeon card isn't doing you any favours - FSX doesn't like ATI as much as nVidia.

 

Try out the AVSIM guide to FSX: http://forum.avsim.net/files/file/41-basic-fsx-p3d-configuration-guide/

 

I found this invaluable in tweaking FSX.

 

For comparison (but not wanting to sound like I'm crowing about it), I have an Intel Haswell 4770K, H100i cooled, overclocked to 4.5GHZ with a GTX760 and I still get sub-20 FPS in EGLL, RJAA, KLAX etc. On these occasions, I just turn off the frame counter.

 

Good luck with your affinity settings, and tweaking.

 

 

Share this post


Link to post
Share on other sites

that AffinityMask should be 14 or 84, use a toshiba sattelite i5 2430m but no PMDG . 

 

And I would not expect anything more that 10-12 on that PMDG on the laptop.

 

Have you tweak the FSX.cfg with Bufferpools and HIGHMEM ?

 

I doubt you shall be able to disable HT on that laptop , at least on mine I cannot and If I do I only get a single core.

 

Careful not to run that thing to full turbo for a longtime it will heat up and may cause throttling, I have left my CPU to 2.2 Ghz when running FSX.

Share this post


Link to post
Share on other sites

that AffinityMask should be 14 or 84, use a toshiba sattelite i5 2430m but no PMDG .

 

And I would not expect anything more that 10-12 on that PMDG on the laptop.

 

Have you tweak the FSX.cfg with Bufferpools and HIGHMEM ?

 

I doubt you shall be able to disable HT on that laptop , at least on mine I cannot and If I do I only get a single core.

 

Careful not to run that thing to full turbo for a longtime it will heat up and may cause throttling, I have left my CPU to 2.2 Ghz when running FSX.

I have this lines:

Highmemfix=1

Usepools=0

 

Hyperthreading is useless in FSX - you should disable it. FSX will not avail itself of the virtual cores.

 

That leaves you with only two cores to do the work of running your OS, plus FSX etc.

This, in my experience, just isn't enough to properly run FSX alongside a cpu intensive add-on like the 777.

 

The best you can hope for is getting FSX to use both physical cores, with an affinity mask of 3 (0011 read right-to-left). This tells FSX to use both physical cores (with HT off), although core 0 will have to share workload with the OS.

You might also want to try overclocking it, but it's a laptop, right ? Not good for temperatures.

Your CPU has a turbo speed of 2.9GHz. Can you enable this permanently ?

 

Also, the Radeon card isn't doing you any favours - FSX doesn't like ATI as much as nVidia.

 

Try out the AVSIM guide to FSX: http://forum.avsim.net/files/file/41-basic-fsx-p3d-configuration-guide/

 

I found this invaluable in tweaking FSX.

 

For comparison (but not wanting to sound like I'm crowing about it), I have an Intel Haswell 4770K, H100i cooled, overclocked to 4.5GHZ with a GTX760 and I still get sub-20 FPS in EGLL, RJAA, KLAX etc. On these occasions, I just turn off the frame counter.

 

Good luck with your affinity settings, and tweaking.

Thank you. I really appreciate your help. I will try setting Afinnity mask to 3 and see what happens. About the computer, yes it's a sony Vaio laptop. It won't let me disable HT, it won't let me overclock anything, it won't let me update my Gpu driver (it has "switchable graphics") so overall sony isn't helping much. Sadly this 2 year old computer is all I can have for now as I'm just a student.

 

Regards

Share this post


Link to post
Share on other sites

Looks to me like 0 and 2 are actually what you want, the two physical cores. 1 and 3 then would be the virtual ones.

Share this post


Link to post
Share on other sites
 
 

 

I have this lines:
Highmemfix=1
Usepools=0

 

 

You should read the AVSIM FSX guide, especially the bit about bufferpools.

On a lower-end system like yours, Bufferpools should be enabled, with specific settings, which can be found in the guide.

 

If you cant disable Hyperthreading on your system, the Affinity Mask should be (I believe) 5.

In binary, 5 = 0101.

Read from the right = 1010 = physical cores 0 & 2 are on to FSX, with no affinity for the HT virtual cores 1 & 3. FSX should basically ignore them.

 

Check this elsewhere, though, as it's from memory, and I've been known to be wrong.

 

Read the AVSIM Guide - Can't recommend it enough :)

 

 

 

Share this post


Link to post
Share on other sites

You should read the AVSIM FSX guide, especially the bit about bufferpools.

On a lower-end system like yours, Bufferpools should be enabled, with specific settings, which can be found in the guide.

 

If you cant disable Hyperthreading on your system, the Affinity Mask should be (I believe) 5.

In binary, 5 = 0101.

Read from the right = 1010 = physical cores 0 & 2 are on to FSX, with no affinity for the HT virtual cores 1 & 3. FSX should basically ignore them.

 

Check this elsewhere, though, as it's from memory, and I've been known to be wrong.

 

Read the AVSIM Guide - Can't recommend it enough :)

I'll give that guide a try. I did once with Word Not Allowed's guide and it made my performance even worst. I'll try avsim guide. Hope it makes it all better since I'm basically playing a slide show right now..

Share this post


Link to post
Share on other sites

I did a lot of tests today with my FSX.Cfg. All can I say to those that replied here trying to help me is THANK YOU!. I can't believe the huge performance increase I got with your advice. Basically, I went from 6-12 FPS to 18-25 FPS. I can't believe I will finally be able to enjoy my 777!!!

 

Again thank you superluminal, fabo and iron maiden!

  • Upvote 1

Share this post


Link to post
Share on other sites
 
 

 

I did a lot of tests today with my FSX.Cfg. All can I say to those that replied here trying to help me is THANK YOU!. I can't believe the huge performance increase I got with your advice. Basically, I went from 6-12 FPS to 18-25 FPS. I can't believe I will finally be able to enjoy my 777!!!

Again thank you superluminal, fabo and iron maiden!

 

That's a pretty good improvement  :smile:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this