Archived

This topic is now archived and is closed to further replies.

Aamir

Can't Close Doors after LR-Turnaround Panel Load

Recommended Posts

Problem is pretty much described in the title, I load up the aircraft and select the default LR Turnaround option, doing so causes me to not be able to operate any of the doors (Cargo or PAX).

Did a Google search, and a Forum search, couldn't come up with anything. Anyone have any thoughts?

 

I've tried multiple different liveries, and I can't figure this one out.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Okay, so after a half hour or so of investigating, I've narrowed it down. The initial problem is misleading, it has nothing to do with the panel state.

 

In any panel state, including the default one, as soon as a door is opened, the options on the FMC change and render me unable to operate any of the doors. 

 

Pictures attached for reference:

 

Normal FMC screen when door is opened:

11524935543_39b13de703_o.png
 
FMC screen 2-3 seconds after the door is opened:
11524796365_f6ba3948ce_o.png
 
So, I'm trying everything right now, but it's fairly stubborn, any time ANY door is opened, the FMC page changes to the second screenshot, effectively rendering it useless.
Need help, my flying is on hold :(

Share this post


Link to post
Share on other sites

The exact same thing happened to me this morning, and I don't have a clue what to do. Too bad, but no flying for me for now.

Share this post


Link to post
Share on other sites

It sucks, I was just about to depart to Dulles from Heathrow as BA217.
 

I guess I'll submit a ticket to PMDG, but I'm such an impatient derp that I'll end up reinstalling it. I only have a precious few Christmas days to do back to back flights and I was really looking forward to this :(

 

EDIT: Waiting for Kyle to jump in with: NEVER REINSTALL SOFTWARE UNTIL IT'S ABSOLUTELY NECESSARY BECAUSE IT BREAKS MORE THINGS THAN IT FIXES! USE IT ONLY AS A LAST RESORT!  ^_^

Share this post


Link to post
Share on other sites

Okay, so I've narrowed down the problem a little.

 

I've noticed that my doors start acting really iffy when the CPU is overclocked.

When I'm running on stock clocks, etc, the aircraft's doors operate just fine.

Share this post


Link to post
Share on other sites

In the middle of reinstalling the software now with my overclock already applied. I've heard that installing software THEN overclocking tends to break it.

So I've manually OC'd this time, proved it nice and stable (the other one was crashing out IBT it seems), and am now installing the software. Fingers crossed all goes well.

Share this post


Link to post
Share on other sites

I had this once only. Could never explain it but starting a new flight fixed it.

Share this post


Link to post
Share on other sites

In the middle of reinstalling the software now with my overclock already applied. I've heard that installing software THEN overclocking tends to break it.

So I've manually OC'd this time, proved it nice and stable (the other one was crashing out IBT it seems), and am now installing the software. Fingers crossed all goes well.

You never ever install new software WHILE overclocked. First you sef the bios back to default then you install software!

 

Also I find it realy weird that your overclock would cause only door problems. But if you say so and if you can reproduce and fix it with the clock speed.....Ok

 

One other thing you could look at is to make sure the time on your PC keeps running correctly. All kinds of weird problems have been reported due to an empty CMOS motherboard battery that caused the time to be wrong.

Share this post


Link to post
Share on other sites

Okay so as it were, I just took off as BA217, door problems seem to have alleviated for this flight, but I'll need to do a couple of other flights to verify.

 

The only other adverse effect I've found the OC to have was that it keeps crashing out my FSX everytime the T7's autocruise needs to back down from 8x (this requires a reload, and the reload constantly causes a fatal error.) It used to work absolutely spiffy before this. A real pity, I guess I'll have to work with 4x. I've tried every single UIAutomationCore.dll trick in the book. 

Share this post


Link to post
Share on other sites

You do know that enough crashes and other overclock related problems can actually ruin/corrupt a perfectly fine system/install right?

 

You need to find out how to get a stable overclock (this involves a lot of reading/learning) or just stay away from it!

Share this post


Link to post
Share on other sites

 

 


You need to find out how to get a stable overclock (this involves a lot of reading/learning) or just stay away from it!

 

My OC survived a 100 passes of IBT, I don't know what else to tell ya. 

 

 

 


You do know that enough crashes and other overclock related problems can actually ruin/corrupt a perfectly fine system/install right?

 

It's one fatal error in one program notorious for CTD'ing. Everything else is perfectly fine.
Just need to sort this out then I'm 100% satisfied with my install..

Share this post


Link to post
Share on other sites

UPDATE: Problem has been alleviated. Used a different (read: new) version of UIAutomationCore.dll, replaced it with the old one in the SYSWOW64 and System32 folders, and used the same one in the FSX Root Folder. No more crashing when acceleration ramps down = happy me! :D

Share this post


Link to post
Share on other sites

I guess Santa needed my plane yesterday, because the problem has disappeared today.

Share this post


Link to post
Share on other sites

 

 


I guess Santa needed my plane yesterday, because the problem has disappeared today.

 

As utterly insane as it sounds, so has mine.  :lol:

Share this post


Link to post
Share on other sites

UPDATE: Problem has been alleviated. Used a different (read: new) version of UIAutomationCore.dll, replaced it with the old one in the SYSWOW64 and System32 folders, and used the same one in the FSX Root Folder. No more crashing when acceleration ramps down = happy me! :D

Good for you.

 

Just in case problems reappear.....a load test pass does not guarentee anything.

 

I am no hardware specialist so I got a lot of help setting up and installing and overclocking my current system.

I learned a lot in the process.

 

And one thing I learned is that even several OCCT load test passes and temps below 80C max dont mean all is fine!

 

A load test helps, but the final and real test is when you run FSX and test your system in combat.

 

In my case FSX CTD-ed despite passing load tests as well.

 

And it did not stop untill I reduced the memory overclock!

 

In the mean time I have upgraded to better memory and run my system stable at 4.4Ghz and DDR3 2400@9-11-11-31.

 

I do not get CTDs anymore, no matter how many times I switch from inside to outside and open up FSX menus.

 

 

You realy have to make sure you get your system stable (reduce clock settings if you get CDTs again) or it will ruin your Windows or FSX or PMDG install.

Share this post


Link to post
Share on other sites

You realy have to make sure you get your system stable (reduce clock settings if you get CDTs again) or it will ruin your Windows or FSX or PMDG install.

Can you explain please? Never heard such a thing.

Share this post


Link to post
Share on other sites

Can you explain please? Never heard such a thing.

I cant explain or proove it, as said above I am no hardware specialist.

 

I rely on info from those who are.

And my best source has told me that software crashes and unstable overclocks can corrupt software.

 

For instance if FSX crashes it can screw up your FSX.cfg (I think because normally when you close FSX, the FSX.cfg is re-saved but with a CTD it cant do that)

But that one is easy to repair.

 

If your whole Windows or FSX install gets corrupted due to crashes then you are looking at a reinstall.

 

To me it sounds logicall...if something crashes....you might damage it.

Crash a plane...it gets damaged.

Crash software.....ditto.....sounds logical to me.

 

I remember when I was completely new to computers and for the first time in my life touched Win95.

I used to close Win95 with the PC power off button.....and that would just cut off power in those days!

So after a few times, data was lost, things would not start up anymore, programs would crash.

I found out later I might have caused all that myself by that hard power off.

 

 

In the end, if you dont believe what my hardware source tells me....then that is ok with me.

Anyone is free to do whatever they feel like with their PC.

 

But I am very carefull with my Win7 FSX install, these are some guidelines I stick to:

No software installed/added while overclocked.

Allways bios to default clock first!

 

Always create a backup image (with Win7 image tool) before installing new software.

 

Never install several addons in one go, always install....run FSX....reboot PC...then install next addon.

 

I even take that one step further and always install only one addon, then test it for a while before installing Anything else. This way I try to make sure that the created images are are good and I am not saving a corrupt install!

Share this post


Link to post
Share on other sites

Totally different over here. I even run several installations in the same time; do not bother to backup anything system/software related (only data and setup files);

Of course, nothing wrong with being extra cautious. :smile:

Share this post


Link to post
Share on other sites

I put quite some time and efford in in my FSX dedicated system (months of reading forums, carefull hardware selection, days of carefull installing and tuning Win7 and FSX).

 

being carefull when installing new stuff is nothing in comparison.

 

Maybe my thoroughness and carefullness are not at all the reason why things are working well in my system.

Your system may be the proof of that.

 

But if things do go wrong I know that it most likely is not my Install or hardware.

And troubleshooting is a heck of a lot easier if you can say (with some certainty) that your system is not causing the problem so it must be the latest addon.

Share this post


Link to post
Share on other sites

My memory is G.Skill Trident X 2400MHz memory, but for now I've left it on AUTO in the BIOS. Is that something I should change?

Share this post


Link to post
Share on other sites

My memory is G.Skill Trident X 2400MHz memory, but for now I've left it on AUTO in the BIOS. Is that something I should change?

I got the same and at auto it runs 1600Mhz :-(

I was told ivy bridge is not guarenteed to run at 2400Mhz, but mine do fine.

 

The higher your RAM frequency and the lower the timing, the better your chances on smooth stutter free flight are.

Not something that has an effect like going from 10fps to 30fps, but if you look carefully enough you will see the difference.

 

So yes, I recommend you change and try it.

 

We have the same PC except for MB.

On my MB I change Ai Overclock from Auto to XMP (in the BIOS).

This will change it to run at 2400Mhz and will set timings 9-11-11-31-2N

Thats all, then save and exit.

 

See how it does.

 

If you want you can even manually change the timing to 1N which is even better and try again.

(I run mine at 2400@9-11-11-31-1N)

Share this post


Link to post
Share on other sites

 

 


We have the same PC except for MB.
On my MB I change Ai Overclock from Auto to XMP (in the BIOS).
This will change it to run at 2400Mhz and will set timings 9-11-11-31-2N
Thats all, then save and exit.

See how it does.

If you want you can even manually change the timing to 1N which is even better and try again.
(I run mine at 2400@9-11-11-31-1N)

 

Okay, so it wouldn't boot at 1N, but all looks good at 2N. 

Running a couple of stress tests now. If this fixes my crashing problem I'll owe ya a beer ;)

Share this post


Link to post
Share on other sites

Okay, so it wouldn't boot at 1N, but all looks good at 2N.

Running a couple of stress tests now. If this fixes my crashing problem I'll owe ya a beer ;)

Eeeh, ok I thought you were just asking if it would be better to run at 2400 or not for performance reasons.

 

I did not realize this was asked as a fix for CTDs because I thought you had that fixed with the UIAutomationCore update?

 

Changing to 2400MHz should not help.

Default settings should be more stable than with XMP@2400.

 

Anyway, if it does fix things I will gladly take the beers :-)

 

Let us know how things go!

Share this post


Link to post
Share on other sites