Jump to content

Archived

This topic is now archived and is closed to further replies.

Ray Proudfoot

What is taking the focus from FSX?

Recommended Posts

I have a problem in FSX that is driving me nuts. I never had it with FS9 running XP. I'm wondering if it's a OS problem or an FSX one.

 

In short, when I press some GoFlight buttons configured as key presses or even the keyboard itself I keep hearing a 'ding' from the speakers. The GoFlight commands are executed but the keyboard ones aren't.

 

The easiest one to replicate is CTRL+Shift+W to display the AES menu. I've tried running Windowed and full screen mode and it happens in both modes. If I switch from full-screen into windowed mode it does cure the problem for a while but it does return.

 

Is anyone else suffering this problem and do you have a solution? I do have two other programs running on the FSX PC - Project Magenta MCP and Avliasoft EFB but I just can't see those taking the focus from FSX.

Share this post


Link to post
Share on other sites

Hi Ray,

From the latest update to FSUIPC 4.927b you can try this:

 

Debug=Please
LogExtras=x40
to the [General] section of the INI file before running FSx, and FSUIC will log details of the process
which is gaining the Focus and/or being Activated and so causing FS to lose its focus

Share this post


Link to post
Share on other sites

Thanks Julian. I shall try that and report back. Probably tomorrow now. Good old Pete - he thinks of everything. :smile:

Share this post


Link to post
Share on other sites

Hi Julian,

 

I added the lines you suggested and have just completed a flight from EGPF-EGLL (Glasgow-Heathrow). FSUIPC log is attached.

 

I can only see one suspicious entry - 3791604 Deactivated - culprit unknown.

 

If that indeed the cause then I'm no nearer finding what it is that is taking the focus away. Appreciate any advice you have but if you can't spot the problem I'll raise it with Pete

 

PS. I did pause the flight when I went for lunch. :wink:

 

Edited: Just a bit more info. I spotted right at the end of the log that sa_wxr.exe was mentioned in relation to lost focus. That is a weather radar program for Project Magenta. I'm going to run the flight again but without sa_wxr to see if that might be responsible.

 

FSUIPC4Log.txt

Share this post


Link to post
Share on other sites

Also make sure that you don't have that key assigned to something else in FSX...I had this going on yesterday when configuring a new add-on and it turned out somehow FSX had reincarnated the original key assignment in the Controls menu.

 

Cheers

Share this post


Link to post
Share on other sites

Ray

 

I hope this suggestion is not too simplistic and rediculous, but it's not FSUIPC ringing the VAS warning gong is it?

 

Phil

 

Phil,

 

That briefly crossed my mind a while back but the 'dings' are only heard when I press a GoFlight button or Ctrl+Shift+W for the AES menu.

 

In any case, I'm running a VAS monitor LUA file via WideFS(see FSX Utilities in Library) and there's plenty of VAS remaining.

Share this post


Link to post
Share on other sites

Hi Ray,

 

Towards the end of your FSUIPC logfile, I see these lines:

 

  7267915 Deactivated for PID=1088, "sa_wxr.exe"
  7267915 Lost focus to PID=1088, "sa_wxr.exe"

 

Could "sa_wxr.exe" be involved in your mystery or did you invoke it towards the end of your session??

 
Edit - I see you spotted that.  Sorry!
 
Are the "Memory in use: 3175Mb, Avail=920Mb" entries coming from the VAS LUA script you mentioned or from something else?  That looks terribly interesting, as do the "Exception 12 "TOO_MANY_REQUESTS" entries....
 
Regards,

Share this post


Link to post
Share on other sites

Also make sure that you don't have that key assigned to something else in FSX...I had this going on yesterday when configuring a new add-on and it turned out somehow FSX had reincarnated the original key assignment in the Controls menu.

 

Cheers

 

Hi Bob,

 

Checked that before my last test flight. No conflicts sadly but thanks for suggesting it.

 

I disabled sa-wxr.exe from running in my latest flight and for a while I thought I'd cracked it. Seems I didn't have the sound loud enough to hear the dings when using GoFlight buttons but after taxiing off the active Ctrl+Shift+W failed to display AES menu and only then did I hear the dreaded 'ding'.

 

The latest FSUIPC.LOG shows no repeat of Deactivated - culprit unknown. This is seriously bugging me. On my next flight I will disable Avliasoft's EFB although I doubt it's responsible.

 

What I will also do is load NotePad before FSX and then at some point in the test manually switch to it and see what is recorded in the FSUIPC log. If all else fails a call to Pete is likely.

 

 

Edit - I see you spotted that. Sorry!

 

No apologies required Travis, thanks. SA-WXR.exe is loaded via a FSAlacrity profile for those that remember it. It just loads and minimises. Weather data is transferred automatically via WideFS to the ND on my other PC.

 

 

 

Are the "Memory in use: 3175Mb, Avail=920Mb" entries coming from the VAS LUA script you mentioned or from something else? That looks terribly interesting, as do the "Exception 12 "TOO_MANY_REQUESTS" entries....

I put this in fsuipc.ini after a conversation with Pete. I think you enter it manually rather than by using the interface. I'll double-check it's not related to that lua plugin.

 

Those "TOO_MANY_REQUESTS" entries are next on my list to sort out. Could it be due to too many Ai aircraft? I have it set to 50% and I run MyTrafficX v5.4c. I searched Pete's forum but couldn't find anything directly related to Ai aircraft.

Share this post


Link to post
Share on other sites

×
×
  • Create New...