Sign in to follow this  
phoenixfly

Prepar3dv2 FTXGlobal problems

Recommended Posts

Hello can some one help me here in the avsim forum.... I can not get any answers from the orbx site.

I downloaded the ftxglobal into my prepar3dv2..both the base110 and the 120. I'm getting microstutters when I turn and getting worse fps.  I was locked at 33fps before the addon, now im at 20fps. Autogen is set to normal and scenery is set to dense. It is an ASUS I7 3+ghz gaming computer. Is there a specific tweak guide for this the prepar3d v2  with orbxftxglobal addon. Or if you know any tricks on how to improve my performance I would appreciate it.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Try lowering autogen one click and see if that helps.

Share this post


Link to post

It is an ASUS I7 3+ghz gaming computer.

 

 

If you post your hardware specs in your profile, your issue will be easier for others here to address. The two things I would do is to set your affinity mask in Prepar3d.cfg such that the app uses all available cores. Without knowing what i7 you have or whether you have the hyperthreading option turned in in your BIOS, no one can give you any sensible advice. The other step would be to set frames to unlimited. Unless you are seeing screen tearing, there is no advantage to using the P3d2 internal frame limiter.

Share this post


Link to post

Sorry computer illitetate......do i add a line in p3dv2 config and if i do what do i add. Also how do I access the bios so I can check hyperthreading? I have win 8.

Share this post


Link to post

First I would try just setting the frame rate to unlimited from within the Prepar3d settings and see if that helps by itself.

 

I assume that you know that Prepar3d.cfg is a hidden file and in Win 8 is is located here:

 

C:\Users\<username>\AppData\Roaming\Lockheed Martin\Prepar3D v2\Prepar3D.CFG

 

Yes, you need to add two lines that look like this:

 

[JOBSCHEDULER]
AffinityMask=nnnn

 

You can add them in various locations in the cfg file, but most people add them at the bottom, so that they can easily find them again. The nnnn part is dependent on the number of cores that your CPU has (probably 4 or 6) and whether HT is on or off. Also, make a backup copy of prepar3d.cfg and rename it something like prepar3d.cfg.original. That way if you do something wrong, you can always go back to the original cfg file.

 

Tell me what brand and model of computer you have. Then look in your Win 8 Control Panel under:

 

Control Panel\System and Security\System

 

and see what model Intel Core i7 CPU that you have.

Share this post


Link to post

Okay here it is.

Asus Republic of gaming

Model asus notebook serise

Intel® core i7-3630 Qm cpu@2.40 ghz 2.40 ghz

64 bit

Ram 16 gb

In the task manager under performance it shows 4 cores

Processes 84 threads1048

How do I tell if HT is on?

So would I add

Affinitymask=4 or 0004?

Share this post


Link to post

The ASUS ROG laptops have what's called a "locked BIOS" which means you can't change certain internal hardware settings such as hyperthreading. Thus HT is always on. The means that you have 4 "real" cores and each will run 2 threads:

 

http://ark.intel.com/products/71459/Intel-Core-i7-3630QM-Processor-6M-Cache-up-to-3_40-GHz

 

So, your CPU can do 8 things in parallel. Affinity masks are in decimal, but to the computer, the mask is in binary. That means:

 

11111111 would use all 8 "cores". That translates to decimal to 255. So the setting would be:

 

[JOBSCHEDULER]
AffinityMask=255

 

BTW, your CPU has turbo mode. It will run at 3.4 GHz, under heavy load (like running P3d) and 2.4 GHz under normal conditions.

Share this post


Link to post

Jabloomf1380. Thank you for your help... I will change the am to 255. What else could i do to help microstutters in the settings ontop of unlimited frames? What about fxaa or the other sliders?

Sorry JABLOOM1230

Share this post


Link to post

jabloomf1230,

 

Do you know the correct affinity mask setting for an Intel I-4770k @ 4.5 ghz with Hyper Threading on?  I have read different posts with some people saying 254 for using 7 cores and 255 for using all 8 cores? Is it better to use 7 or 8 cores?

 

I have also read on Word Not Allowed's website that affinity mask should be set at 84 with Hyper Threading on?

 

Which of the two settings, 84 or 255, do you think are correct?

Share this post


Link to post

The easiest way of convincing yourself that you understand the Affinity Mask is to either download a freeware app that asks you all the right questions and cranks out the mask for you. The next best way is to use the built-in Windows calculator app in Programmer View. Start in binary mode and enter your string of ones and zeros. Then switch to decimal mode. You will then see the AM value that P3d is looking for in the CFG file.

 

As to whether to stop P3d2 from using one or more cores, my view it is best to let P3d2 use all the cores and let the OS worry about core scheduling. You may be able to improve performance by tinkering with the AM, but the results will probably be specific to your hardware/software mix.

 

Your Haswell  beauty has 4 cores and 8 threads with HT on. All cores AM would be:

 

11111111 or 255.

 

With HT off:

 

1111 or 15

 

With HT on:

 

84 as an AM yields 01010100

 

which looks on the surface like it would be wrong. However, the way HT works, the OS won't run a secondary thread on a physical core until at least one thread is running on all physical cores, so 84 blocks core 0 altogether and forces P3d to run only one thread on each of the other three cores. This is a "trick" to in essence turn off HT and keep core 0 open for other apps. IMO, that's a lot of dancing for not much gain. Unless you have other apps that perform better with HT on (or you have a motherboard that has all the BIOS CMOS settings locked), you are better to just turn off HT and go with 15 (all cores).

 

Confused yet?


Jabloomf1380. Thank you for your help... I will change the am to 255. What else could i do to help microstutters in the settings ontop of unlimited frames? What about fxaa or the other sliders?
Sorry JABLOOM1230

Your best bet is to start with lower than the default P3d image quality (IQ) settings and work your way up, changing only one slider at a time until you start to get stuttering. Stuttering generally originates from two sources. One is that the GPU can't maintain a smooth output, because the IQ settings are too high. The second source is from having other apps running while in P3d. Some apps, like weather injectors and TrackIR have to be running. But you might be surprised what Windows is doing "behind your back" while you are running P3d. The built-in Windows task manager and the replacement Process Explorer can both allow you to hunt down CPU-hogging processes that have nothing to do with P3d.

Share this post


Link to post

 It's very confusing, but I think I'll go with the 255 setting and see how it performs.  Thank you sir.

Share this post


Link to post

I'm confused, too, Bronze. You start off by stating that 255 would cause all 8 cores to be used if one had HT enabled. And then you say to use 84 because that effectively disables hyper-threading. What if I don't want to disable HT? Wouldn't 252 (11111100) be a better choice?

 

Frans

Share this post


Link to post

No use, 255, unless you want to prevent P3d2 from using core 0 and then 252 would do so.

 

I was just trying to explain why Kostas suggested 84. There is no real reason to do so. Sometimes too much information is not that helpful. :lol:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this