Sign in to follow this  
Emi

Operations Center missing all 777 information

Recommended Posts

I tried to download a livery for the 777, but it seems the OS center doesn't work anymore.

All options for the 777 are simply missing. Same for their other aircraft covered in the OS Center by the way.

 

So, either PMDG screwed up their Operations Center or there is some work in progress :D

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I tried to download a livery for the 777, but it seems the OS center doesn't work anymore.

(...)

 

 

You should contact Aerosoft support on this.   :P

Share this post


Link to post
Share on other sites

Strange, this is what I am seeing (And yes, the 777 is installed. I changed nothing since it worked last time).

 

Edit: Looks like I can't attach images. Let me explain it this way: I see no options in the 777 menu of the Operations Center and on the upper right of the product page shown I see the BUY NOW button, even though I obviously have already paid for it and got it installed and running normally.


You should contact Aerosoft support on this.   :P

 

We're not selling it yet :D

Edited by Emi

Share this post


Link to post
Share on other sites

I am getting the exact same thing as described in Emi's post. That is following installation on a new computer (it worked fine before).

I could not find any help in this post or elsewhere.

Thank you

Benny K

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this