Sign in to follow this  
Driver170

Saitek Hat Switch And Ezdok

Recommended Posts

Hi my saitek hat switch keeps disabling itself with ezdok.

 

I start the flight with my 737 ngx few mins later the hat switch on my saitek joystick stops working only way i get it to work is exiting ezca and re-launching it.

 

Anyone know why this is doing this?

 

Thanks alot

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You've set the S and A and Shift-S and Shift-A, and selected your joystick on the appropriate EZdok pages, and also disabled your hat switch as an FSX command? 

Share this post


Link to post
Share on other sites

Disabled hat switch in fsx but what are those other commands?

Joystick is selected and all buttons work plus axis etc basically everything works but that hat switch keeps disabling itself?

What is S and A and shift S and shift A

Share this post


Link to post
Share on other sites

I don't know if it's causing your problem, but an essential part of EZdok setup is to go into FSX and disable the default camera switching commands (S, A, Shift S, Shift A) and then add those instead into the EZdok commands.   The particular setup steps are in the basic setup manual somewhere, and if not, certainly in one of those Youtube setup videos that Mr. Marniftarr posted.

 

Get it set up "by the book" first, so you can then rule out simple user setup issues as a cause of your hat switch behaving oddly.

Share this post


Link to post
Share on other sites

I'll double check ,but i'm pretty sure i leave  the hat enabled inside fsx.i use that to pan around inside the cockpits.

 

    steve

yep View pan is set in FSX controls for the Hat switch of my Saitek yoke,

Share this post


Link to post
Share on other sites

Ok i'll try those steps! You mention add those to the ezdok commands can you tell me what commands they are for S and A shift S and shift A thankyouu!

 

Steve if i leave the setting in fsx it works but it can be jittery when looking about.

Share this post


Link to post
Share on other sites

yep it is a bit jittery.but you can change the way it pans by clicking on the different boxes inside the options menu/general settings/top box you will see 3 boxes click on 3d game, and in the HAT Switch Box set to 6.51.that is my settings.try them and see.

make sure your joysticks are recognised in the joystick configuration boxes.

Mine are set J1 saitek yoke Y2 saitek throttle Y3 CH pro peddles.

   

   steve

Share this post


Link to post
Share on other sites

I found that by setting EZCA to control the 'hat' switch only gave me level control, It would not go up and down.

 

So, I resetted the FSX 'hat control' and all is well now.  EZCA is bugged imo and is far from perfect. It was originally set for XP and we have had Vista W7 since which may have caused problems that didn't exist in XP.

Share this post


Link to post
Share on other sites

Right i just looked at my saitek yoke and its been turning itself off? right this second the green screen with the time in it switched off and turned back on? so this is prob causing it to loose ezdok

Share this post


Link to post
Share on other sites

Go to your control panel-->power options-->change plan settings-->change advanced power settings.

 

Open up the [+] bar that says USB settings.

 

You will see something that says USB selective suspend setting.  Is it enabled?  Go ahead and disable it. 

 

If the problem is that your USB port is going to sleep, then I think that will fix it.

Share this post


Link to post
Share on other sites

Ok just done your instructions fingers crossed :) how come its started doing this and not before i've had it for a while? Or maybe i've never noticed as i hardly use the hatch switch on the yoke i tend to use the mouse middle button on my logitech to pan about?

Its done it again :(

Share this post


Link to post
Share on other sites

In device manager

 

Saitek Magic Bus

 

Root Enumerator

 

 

 

There is a yellow triangle warning thing at the root enumerator?

Share this post


Link to post
Share on other sites

Saitek Magic Bus?  This was a pre-existent condition, or happened when you dis-abled the power-saving suspend feature?

 

My device manager shows Saitek Pro Flight Yoke(USB) and Saitek Pro Flight Yoke(HID), so outside of the Who song, I'm not sure what a magic bus is.   Is this something that shows up when you install Saitek control software off of a CD that comes with the yoke? 

 

Since your yoke is a plug and play device, it should go seek out the correct device drivers every time you plug it in.  I would see what happens if you unplug it, then plug it back in, and see if it gets the correct drivers.   If so, does it behave the same way if you plug it into a different USB port?

Share this post


Link to post
Share on other sites

Its all connected up and working fine!

 

Just spotted that saitek magic bus not sure what it is i'll ask on there forums!

 

As for my saitek yoke switching off do you think my USB drivers or something needs updating?

Share this post


Link to post
Share on other sites

Glad it's working.  You might want to search out the matter further, but I'm pretty sure that if you disabled the Suspend mode, then it shouldn't go to sleep anymore.

Share this post


Link to post
Share on other sites

Hi its my USB it keeps on cutting out maybe i have to update the USB driver?

 

My build is only 3 months old i'll check out asus Z87-A for updates.

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "Hardware Controllers & Drivers". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

Found the cause i recently put a mini fridge on the same plug and adapter and each time the fridge would blink out because of temp control it was knocking out my USB and disconnecting my saitek. I removed the fridge and its been over an hour and no cutouts :)

Share this post


Link to post
Share on other sites

Did removal of the mini fridge also happen to fix your MyTraffic X problems? :lol:

 

This is good that you found this.  The next thing I was going to propose was clearing CMOS by pushing the button on your motherboard!

Share this post


Link to post
Share on other sites

Haha i got it installed but at the end of the installation it didn't finish so had to go into the folder and run a bat file called runonce to install the planes but there is also another file called rebuild_mytraffic?

 

Still can't go back to 2012 schedule!

Share this post


Link to post
Share on other sites

Hello, I have the Saitek Proflight yoke, quadrant and pedals.

 
I have FSX Gold.
Win 7 64
 
Tonight I bought EZCA and installed it and watched some videos on how to set it up.
 
It's easy to set up but if I assign a camera view to my yoke buttons it's global.
 
Is there a way to set it up for just say Mode 2 or Mode 3?
I use the Saitek controller software.
 
Any help would be much appreciated.
 
Thanks.

Share this post


Link to post
Share on other sites

I have my right view set up with my hat-switch and when i click on it it uncheck the check mark in the box  in configure joysticks option does any one know how to fix this so when i use my hat switch to view my Right view it doesn't uncheck it 

 

                                                                                                                                                     Thank You

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this