Sign in to follow this  
Colonel X

Microstutters with 780GTX in HDR mode w/VSYNC flying low...

Recommended Posts

Does anyone have experience with microstutters when going low and fast in HDR mode? I can't seem to get rid of those while I am locked at 30 fps via driver ("Adaptive VSYNC"). I crank up the objects slider to "extreme" and LOD to "high", and take a fast jet to fly low over a dense area, such as Brooklyn for example. I get 30fps with the 6GB 780GTX (even a stock overclocked one from ASUS), BUT I also get microstutters, every few seconds, which totally ruin the experience. 


 


I am aware that I am pushing X-Plane to the limits here, especially considering that I conducted this test in a F-16 at 500 kts. But it bothers me that the system seems to be able to handle this smoothly - except for those crazy stutters that have been haunting me since 2010 (even with FSX and on a different system).


 


I will have to try different VSYNC options, also leaving VSYNC off, which has other disadvantages. I am totally in the dark though if this is hardware (performance), driver or X-Plane related, in terms of it being a "bug".


 


Microstutters, man, gotta hate them!


Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I was gonna post this today, but I'll keep an eye on this thread.

 

One thing I notice is that the frame drops when the stutter occurs for a brief second, as if it's out of gram? But according to gpuz it is using 3400 of 4000 available on a 770gtx 4gb?

Share this post


Link to post
Share on other sites

I have the same card with 6 gb and fly with photoscenery 

I see sometimes at rendering that it takes 3.8 vram

as soon as I use HDR then stutters appears.

It is also possible that your CPU is to its limitations.

I overclocked the 3770K to 4.6 but I see it is the limit

what do you use for cpu may that is the weakest part of the chain

Share this post


Link to post
Share on other sites

Are you sure its not x-plane loading in a new area block thing when im flying i get a slight pause when that happens.

Share this post


Link to post
Share on other sites

I recognize that one also

I solved it by going back from 340 to 377 driver

and second to file a bug in some area's in global scenery (vienna and surrounding)

for the rest I think the 4. gz is on the low site of Ian

may be you could also try to find the right spot in nvidia inspector

Share this post


Link to post
Share on other sites

I recognize that one also

I solved it by going back from 340 to 377 driver

and second to file a bug in some area's in global scenery (vienna and surrounding)

for the rest I think the 4. gz is on the low site of Ian

may be you could also try to find the right spot in nvidia inspector

 

I tried going back to 377, same result. I am running a i7 4790k at 4.4Ghz and I believe Microstutters are caused by the GPU and not the CPU ... general Frames are 30+ in that scene, if the CPU had touble, frames would be lower at all times (not just during the stutter).

 

 

Are you sure its not x-plane loading in a new area block thing when im flying i get a slight pause when that happens.

 

I am sure. Microstutters appear every other second, everything should be loaded already.

Share this post


Link to post
Share on other sites

 

 

I am sure. Microstutters appear every other second, everything should be loaded already.

 

Well then I'm at a loss that's the only problem i have had with X-Plane Though my system is not as new as yours im just running a Quad core duo 2.83mHz 4gb ram and a EVGA 570 card.. 

 

Though i do run adaptive with v-sync on.  And control as many of the display options from the native nvidea settings thing.   

 

Well i do hope you find out whats causing it.

Share this post


Link to post
Share on other sites

Think I will try with adaptive vsync and see what happens. I have 1/2 refresh rate at standard at the moment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this