Sign in to follow this  
LB777

Consistent CTD after 20-30 mins of flight

Recommended Posts

So I give up, I won't say I tried everything but I definitely tried a lot of things...

 

I'm getting the good old R6025 -pure virtual fonction call error for no apparent reason really, it started one day and from this day on I keep getting it every single flight.

For reference it started happening on P3D v2.2 and it's still doing it after I installed 2.3 (the full installer not the patch)

 

The usual log :

 

Faulting application name Prepar3D.exe, version : 2.3.11345.0, time stamp: 0x53e4d8e6
Faulting module name: MSVCR100.dll, version : 10.0.40219.325, time stamp: 0x4df2be1e
Exception code : 0x40000015
Fault offset : 0x0008d6fd
Faulting process id : 0x1698
Faulting application start time : 0x01cfb72124798bd0
Faulting application path : I:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Prepar3D.exe
Faulting module path : C:\Windows\system32\MSVCR100.dll
Report Id : 7b065385-2316-11e4-b6e6-5404a617f61c

 

I've tried everything I already found about this error and nothing worked.

 

So all suggestions are welcome even the craziest ones! :lol:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This has been discussed here in this forum quite a bit. Here's one link - http://forum.avsim.net/topic/446279-fsx-freezes-in-mid-flight/?hl=%2Br6025#entry3029743. In your case I believe the problem is with ASN as I heard they have not updated ASN for P3DV2.3 yet. The faulting module belongs to Microsoft Visual C++2010 which is the Visual used by LM to install P3D. Microsoft Visuals are used by the developers to make sure their product is installed properly and as intended. ASN may be using MS Visual 2010 for their products too as ASN is a recent release. Just uninstall ASN for now and use the default weather program until HiFi releases an update for ASN.

 

Best regards,

Share this post


Link to post
Share on other sites

Thanks for you help, unfortunately I don't own ASN so that can't be the culprit.

 

After reading the post you linked I understand that it's most probably only one addon that's causing this. I already tried uninstalling and reinstalling Opus, REX, FS Force2 for my joystick and all my planes one by one without success. I still need to do some scenery addons and hopefully will find the bad one eventually.

Share this post


Link to post
Share on other sites

So it looks like it has to do with hardware tessellation after all.

I had to disable it because I was using the latest Nvidia driver but turning it on seems to solve the issue. Same thing with the 338 driver, no error with tessellation on and CTD mid flight with it off.

 

I had never heard of this before so hopefully Nvidia will pull themselves together and fix this in their next driver.

Share this post


Link to post
Share on other sites

Hello,

 

I have the same driver that you have and the same problem. Did you ever come up with a fix for this? and what is Tessellation and how do I disable it? Please let me kow how to disable this as I can't complete a single flight without a CTD. Thanks a lot for your help.

 

Sincerely, Kit O.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this