Sign in to follow this  
JackSpades

Guauges and Objects stutter/double while moving in VC

Recommended Posts

*Gauges - gah right as I hit send I noticed I spelt it wrong, sorry!

 

Hey guys im having an issue heres some info and background.

 

X-Plane 10.30B8
     -Pilotview Plugin (It works excellent.. not sure why evenyone hates it)
     -Tried vSync on AND off no difference
     -45-60fps Vsync locked
     -Trackir
Mobo: EVGA P67 FTW
CPU: i7 2600k OC @ 4.3
Ram: 16gb @1600
Graphics: AMD HD 5850 OC @ 800/1150
Samsung 1080P LED 32" TV
HDD: 60gb ocz boot | 1TB @7200rpm for everything else
My temps are good

Motion Blur/Building Doubling/Gauges distorting I'm not sure what you call it when I move my head/view in the virtual cockpit. I have seen other videos and streams and it's not supposed to be like this.. so here is the video with Trackir (same problem without Trackir) specifically look at the gauges and the distortion (or what ever you want to call it) doesnt matter if I move fast or slow... The problem doesn't show up as much on the video that vimeo compressed but it does in raw format.

 

Video:
https://vimeo.com/103546917

Things I have tried:
-Tested in default 172, Carenado 172, Dreamfoil 407
-"set all rending options for maximum speed!" - uping 1 item at a time individually / tried all items with no results
-Vsync on/off (off making the horizontal artifacting worse)
-X-Plane no plugins/scenery
-complete reinstall of X-Plane
-format
-all drivers are updated / beta drivers tested or using
-tested x-plane 9 and I get the same problem
-No problem in Arma 3 or Dayz
-Went through and adjusted all CCC settings individually for impact under"3D Application Settings"
-Killed MOM.exe and CCC.exe (saw it in a random guide.. im trying anything and everything I find)

-Tried the game on an actual computer monitor
-The problem persists with Trackir disabled
-The problem persists in the virtual cockpit using the mouse not just Trackir


The numbers for Data & Input for Frame Rate are in the same order as shown in X-Plane: Frame | CPU | GPU.
My numbers:       Frame   CPU     GPU
ACTUAL FPS 55ish | 0,018 | 0,017 | 0,015
They will jump + or - 1 or two when I'm looking around on the ground.
GPU peaked at 0,035 and CPU 0,025 while flying
As you can see in the video the FPS is locked at 30 due to fraps and according to the numbers there is no bottleneck.

 

My settings:

VhelOqJ.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I can't see a problem but I'm on my mobile... Maybe it would be easier to view on the PC.

Share this post


Link to post
Share on other sites

Might be a bit too small on mobile I would recommend PC when you get a chance but look at the guages. Notice at the begining of the video they are clear and within the first second 0-1 when I look right they blur and chop and are not readible and well it just looks choppy. Now pause the video in the middle of the turn. The image is clear... its recording the image perfect but when I move my view in the virtual cockpit its blurred.

 

With that said it's a lot more noticable with the raw file. I don't know a website that doesnt compress the file a bit besides dropfile.. and I doubt people want to download a 500mb video.. if they do ill upload it.

Share this post


Link to post
Share on other sites

Considering your setup, I really don't see a problem.  Your graphics card would be marginal, but your graphic settings are not excessive.  Your card memory is 1GB but you are only requiring 500+.  Your FRs are holding very well.  I personally think that your head movement is excessively fast and I really doubt mine would (I haven't tried it) do any better and I've got a pretty good setup.  When you are focused on any one point, the panel image is clear.  I am old, but if I try (and it is hard to do) to hold my eyes straight ahead and not move the eyes to anticipate the movement, even normal vision is not focused.

 

Again, I don't really see a problem... Slow down and scan... TrackIR (I use it) exaggerates head movement speed.

 

John

Share this post


Link to post
Share on other sites

Thanks John I really appreciate your response. Just to be clear are you saying that your movement speeds are slowed down within the Trackir program (the curves) and you do not get the bluring/double vision on the panel / close scenery objects? That your panel looks perfectly clear (like when you pause my video in the middle of a turn)?

 

What really throws me is that if you pause the video at any point while I am in the middle of one of the head movements the panel will be perfectly clear. It just isn't when im moving my head...

 

 

Keeping in mind the same blur/double vision happens when I used the hat switch on my joystick set at the very fast turn option left and right.

Share this post


Link to post
Share on other sites

Maybe vsync issue?  But like John it look fine to me....  

 

What hz is your LED?  If it's 60HZ and you get 60fps it should be fine.

Share this post


Link to post
Share on other sites

Thanks Ryan, I've already tried Vsync on and off in X-Plane and my drivers. Off just gives me bad hoizontal artifacting. On gets rid of the artifacts but the blur thing still remains.

 

The TV is 60HZ and the issue still persists at 60fps locked in the game using Vsync. Ive also used a regular 60HZ 24" LCD monitor with no difference.

Share this post


Link to post
Share on other sites

Actually, I mean that you should move your head very little to stabilize the view. I really don't see any real problem in what you are seeing as long as the view comes into sharp focus when you stop moving - and yours does just that.

 

I have adjusted my TrackIR curves some to allow for full rotation without damaging this old neck! One direction is harder to move to than the other, so turning off "mirroring" and adjusting the lines/curves independently equalizes the equation.

 

Best of luck,

 

John

Share this post


Link to post
Share on other sites

Thanks John. I really would have to upload the file to dropbox or something for you to see the raw video. I would like it to always be focoused, I do not like the choppy blur effect that its producing. I haven't seen any other trackir X-Plane videos thats like mine. Would you be able to share your profile?

 

They are usually located at C:\Program Files (x86)\NaturalPoint\TrackIR5\Profiles

 

If you don't have anywhere to upload it too you can just open the file with notepad by right clicking and open with>choose default program and find notepad. Be sure to DEclick the box at the bottom "Always use this program" so that it doesn't change all of the file extensions to use notepad. Then post it here. If you have the time. Thanks.

Share this post


Link to post
Share on other sites

<?xml version="1.0" encoding="UTF-16"?>

<Profile>

  <Name>John</Name>

  <Description>Copy of Default Profile</Description>

  <ExclusiveLoad>0</ExclusiveLoad>

  <TrueViewEnabled>1</TrueViewEnabled>

  <Curve>

    <Axis>0</Axis>

    <Enabled>1</Enabled>

    <Inverted>0</Inverted>

    <Mirrored>0</Mirrored>

    <Limited>0</Limited>

    <Limit>180</Limit>

    <Type>0</Type>

    <Inputs>

      <Val>-49.7093</Val>

      <Val>12.1531</Val>

      <Val>-28.4884</Val>

      <Val>9.37799</Val>

      <Val>-13.9535</Val>

      <Val>7.27273</Val>

      <Val>-7.39645</Val>

      <Val>4.10256</Val>

      <Val>-1</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>1</Val>

      <Val>0</Val>

      <Val>7.39645</Val>

      <Val>4.10256</Val>

      <Val>16.2791</Val>

      <Val>7.55981</Val>

      <Val>29.9419</Val>

      <Val>9.66507</Val>

      <Val>49.7093</Val>

      <Val>11.7703</Val>

    </Inputs>

  </Curve>

  <Curve>

    <Axis>1</Axis>

    <Enabled>1</Enabled>

    <Inverted>0</Inverted>

    <Mirrored>0</Mirrored>

    <Limited>0</Limited>

    <Limit>180</Limit>

    <Type>0</Type>

    <Inputs>

      <Val>-49</Val>

      <Val>6</Val>

      <Val>-30</Val>

      <Val>6</Val>

      <Val>-22.4852</Val>

      <Val>6</Val>

      <Val>-6.50888</Val>

      <Val>3.58974</Val>

      <Val>-2.5</Val>

      <Val>0.5</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>2.5</Val>

      <Val>0.5</Val>

      <Val>5.81395</Val>

      <Val>5.45455</Val>

      <Val>21.8023</Val>

      <Val>8.13397</Val>

      <Val>36.3372</Val>

      <Val>9.2823</Val>

      <Val>49.4186</Val>

      <Val>9.66507</Val>

    </Inputs>

  </Curve>

  <Curve>

    <Axis>2</Axis>

    <Enabled>1</Enabled>

    <Inverted>0</Inverted>

    <Mirrored>1</Mirrored>

    <Limited>0</Limited>

    <Limit>180</Limit>

    <Type>0</Type>

    <Inputs>

      <Val>-48.9105</Val>

      <Val>2</Val>

      <Val>-40</Val>

      <Val>2</Val>

      <Val>-30</Val>

      <Val>2</Val>

      <Val>-13.3136</Val>

      <Val>2</Val>

      <Val>-6.21302</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>6.21302</Val>

      <Val>0</Val>

      <Val>13.3136</Val>

      <Val>2</Val>

      <Val>30</Val>

      <Val>2</Val>

      <Val>40</Val>

      <Val>2</Val>

      <Val>48.9105</Val>

      <Val>2</Val>

    </Inputs>

  </Curve>

  <Curve>

    <Axis>3</Axis>

    <Enabled>1</Enabled>

    <Inverted>0</Inverted>

    <Mirrored>1</Mirrored>

    <Limited>0</Limited>

    <Limit>180</Limit>

    <Type>0</Type>

    <Inputs>

      <Val>-48.9105</Val>

      <Val>2</Val>

      <Val>-40</Val>

      <Val>2</Val>

      <Val>-30</Val>

      <Val>2</Val>

      <Val>-20</Val>

      <Val>2</Val>

      <Val>-3</Val>

      <Val>2</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>3</Val>

      <Val>2</Val>

      <Val>20</Val>

      <Val>2</Val>

      <Val>30</Val>

      <Val>2</Val>

      <Val>40</Val>

      <Val>2</Val>

      <Val>48.9105</Val>

      <Val>2</Val>

    </Inputs>

  </Curve>

  <Curve>

    <Axis>4</Axis>

    <Enabled>1</Enabled>

    <Inverted>0</Inverted>

    <Mirrored>1</Mirrored>

    <Limited>0</Limited>

    <Limit>180</Limit>

    <Type>0</Type>

    <Inputs>

      <Val>-49.7041</Val>

      <Val>4</Val>

      <Val>-40</Val>

      <Val>4</Val>

      <Val>-30</Val>

      <Val>4</Val>

      <Val>-19.5266</Val>

      <Val>4</Val>

      <Val>-2.5</Val>

      <Val>4</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>2.5</Val>

      <Val>4</Val>

      <Val>19.5266</Val>

      <Val>4</Val>

      <Val>30</Val>

      <Val>4</Val>

      <Val>40</Val>

      <Val>4</Val>

      <Val>49.7041</Val>

      <Val>4</Val>

    </Inputs>

  </Curve>

  <Curve>

    <Axis>5</Axis>

    <Enabled>1</Enabled>

    <Inverted>0</Inverted>

    <Mirrored>1</Mirrored>

    <Limited>0</Limited>

    <Limit>180</Limit>

    <Type>0</Type>

    <Inputs>

      <Val>-49.4083</Val>

      <Val>2</Val>

      <Val>-40</Val>

      <Val>2</Val>

      <Val>-30</Val>

      <Val>2</Val>

      <Val>-20</Val>

      <Val>2</Val>

      <Val>-3</Val>

      <Val>2</Val>

      <Val>0</Val>

      <Val>0</Val>

      <Val>2</Val>

      <Val>2</Val>

      <Val>24</Val>

      <Val>2</Val>

      <Val>28.1065</Val>

      <Val>0</Val>

      <Val>40</Val>

      <Val>0</Val>

      <Val>48.8</Val>

      <Val>0</Val>

    </Inputs>

  </Curve>

  <Hotkey>

    <Name>Center</Name>

    <ActionID>1</ActionID>

    <Key>123</Key>

    <Enable>1</Enable>

    <Toggle>1</Toggle>

    <Trap>1</Trap>

    <IsDevice>1</IsDevice>

    <DeviceGuid>{4CC2D9A0-8AA2-11E3-8005-444553540000}</DeviceGuid>

    <ButtonID>12</ButtonID>

  </Hotkey>

  <Hotkey>

    <Name>Pause</Name>

    <ActionID>2</ActionID>

    <Key>120</Key>

    <Enable>1</Enable>

    <Toggle>1</Toggle>

    <Trap>1</Trap>

    <IsDevice>1</IsDevice>

    <DeviceGuid>{4CC2D9A0-8AA2-11E3-8005-444553540000}</DeviceGuid>

    <ButtonID>13</ButtonID>

  </Hotkey>

  <Hotkey>

    <Name>Precision</Name>

    <ActionID>3</ActionID>

    <Key>118</Key>

    <Enable>1</Enable>

    <Toggle>1</Toggle>

    <Trap>1</Trap>

    <IsDevice>0</IsDevice>

    <DeviceGuid>{00000000-0000-0000-0000-000000000000}</DeviceGuid>

    <ButtonID>0</ButtonID>

  </Hotkey>

  <Hotkey>

    <Name>Profile</Name>

    <ActionID>4</ActionID>

    <Key>119</Key>

    <Enable>0</Enable>

    <Toggle>1</Toggle>

    <Trap>1</Trap>

    <IsDevice>0</IsDevice>

    <DeviceGuid>{00000000-0000-0000-0000-000000000000}</DeviceGuid>

    <ButtonID>0</ButtonID>

  </Hotkey>

</Profile>

Share this post


Link to post
Share on other sites

Thanks John! That's actually very very close to what my settings are and moves just as fast causing the blur. Looks like im stuck.

 

 

Thanks everyone for your help.

Share this post


Link to post
Share on other sites

Maybe it's a video card driver issue, Are you able to use your video card utility (Not sure about AMD Catalyst?) to override X-planes Vsync option?

Share this post


Link to post
Share on other sites

Thanks ohsirus. I have tried all of the options in CCC under "3D Application Settings" along with beta drivers. I currently do have Vsync forced on inside CCC (which might make a miniscule improvement maybe) as well as inside X-Plane.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this