Sign in to follow this  
CitationMustang

P3D v2.3 CTD

Recommended Posts

Hello all,

 

I just finished installing P3D v2.3 and I am getting a CTD whenever I try to open it. Apparently the faulting module is "clr.dll" which has to do with .NET framework. I'm using ASN and I read somewhere that ASN is what's causing this issue? Even so, I tried running P3D without ASN running and I'm still getting the same CTD with the same faulting module.

 

Any ideas?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

you have to edit out the dll for ASN in your appdata/  subfolder

Share this post


Link to post

you have to edit out the dll for ASN in your appdata/  subfolder

Thank you for the response.

 

Forgive my ignorance, but what is the ASN dll called, and which folder is it located in once I'm in the Lockheed Martin folder?

Share this post


Link to post

Change it to this (False to True for <Disabled>) or just wait for the ASN upgrade for P3d 2.3, which is supposed to be released some time next week:

  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>True</Disabled>
    <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>

Share this post


Link to post

 

Change it to this (False to True for <Disabled>) or just wait for the ASN upgrade for P3d 2.3, which is supposed to be released some time next week:

  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>True</Disabled>
    <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>

Thanks. This fixed the issue with ASN. However, I am still getting a CTD that has nothing to do with ASN. The faulting module that's causing the crash is "clr.dll" which is located in the .NET framework folder. Any ideas?

Share this post


Link to post

You still have ASN loading inside the sim.

Share this post


Link to post

EDIT: Just looked on the HiFi forums (which is where I should have looked in the first place) :rolleyes:  and many other people are having this problem. I'll just have to wait for HiFi to release an update! 

 

Thanks to those of you who helped me with this issue.

Share this post


Link to post

In the DLL.XML file I'm pretty certain that ASN has at least 2 entries, if not 3. So disabling just one isn't going to stop ASN's modules from loading in the sim.

Share this post


Link to post

Like what? That's all I have and P3d 2.3 runs fine with Opus FSX.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this