Sign in to follow this  
mrabduz

Texture loading / blurs.

Recommended Posts

Greetings all,

 

This will be my first post here on AVSIM. I have been running FS9 for a couple of years now. I have been facing this problem in FS9 since the beginning. My textures don't load as far away as i want. Upon seeing my sim from top-down view, the sim makes a kind of a circle, in which the textures are loaded but outside that circle the textures are not loaded and will not load until i reach that area and then so on so forth. 

 

Attached herewith is also a link to a picture that i uploaded showing the problem. Any help on this would be highly appreciated. I have tried most of the tweaks including Nick's cfg file tweaks, but unfortunately did not get any major improvement. My system is good enough for FS9, if not the best in the world ;)

 

http://prntscr.com/4w7xj2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi, and welcome.

 

 

 Upon seeing my sim from top-down view, the sim makes a kind of a circle, in which the textures are loaded but outside that circle the textures are not loaded and will not load until i reach that area and then so on so forth.

 

Sadly, there's a maximum range hard-coded into FS9 for each level of detail. The distance to which the blurred scenery loads (as opposed to the generic vague greens and browns) can be extended by selecting 'Use Extended Textures', or something similar, but the highest definition stuff will only appear in that small circle directly beneath your plane.

 

Even selecting extended textures doesn't have much of an effect from high altitude, except maybe to cause a deterioration in load times. Extending everything to the horizon has been the subject of a Holy Quest since FS9 was released!

 

I feel the best that can be done is to tweak for improved load-times and to increase the atmosphere's haze to mask the worst bits of the ground.

 

Regards,

Dave

Share this post


Link to post
Share on other sites

Check your Terrain section of the fs9.cfg file and see if it is something similar to this:

 

[TERRAIN]
TERRAIN_ERROR_FACTOR=100.000000
TERRAIN_MIN_DEM_AREA=10.000000
TERRAIN_MAX_DEM_AREA=200.000000
TERRAIN_MAX_VERTEX_LEVEL=19
TERRAIN_TEXTURE_SIZE_EXP=8
TERRAIN_AUTOGEN_DENSITY=5
TERRAIN_USE_GRADIENT_MAP=1
TERRAIN_EXTENDED_TEXTURES=1
TERRAIN_DEFAULT_RADIUS=9.500
TERRAIN_EXTENDED_RADIUS=4.500
TERRAIN_EXTENDED_LEVELS=232

 

If not, try them.  Back up your original first.
 

Hope this helps,

Share this post


Link to post
Share on other sites

The terrain detail texture (generic grass detail, pick an airort and turn detail on and off to see what I mean) will also only display right underneath the plane. This sharpens up the textures considerably. Again unfortunately there is nothing that can be done about that.

 

A trick I used is to experiment with the lod bias using Nvidia Inspector. You have to unclamp the setting first. On negative settings textures are generally sharper. Since you rarely look directly beneath your plane you can correct this issue at least somewhat.

 

You will need higher AA and anisotropic filtering settings as you will get a flimmering effect the lower you put the bias.

 

 

I don't know if there is a similar setting for ATI cards, sorry.

 

Regards,

Sascha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this