Sign in to follow this  
J van E

Solution for 8 bit look at night?

Recommended Posts

I usually never fly in the dark but lately I've been flying more and more at real time and so a lot in the evening and so a lot in the dark. I noticed my graphics look very bad at night, as if I am running the sim at 16 or 8 bit. Looks like a bad png... Is there anything I can do about this? I've seen it before but it never bothered me (since I seldom flew at night) but now it's annoying me... Clouds with only 2 or 3 shades, lines all over the VC... ugly...

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Jeroen-

 

If my weak memory serves me correctly, I had this issue way back when I moved from a CRT to an LCD monitor which didn't exhibit what you're describing.

 

Anyway, I think I found somewhere that even though you're running 32bit through the game and card, LCDs can only display at 24bit, hence the banding, etc. that you're experiencing.

 

The fix for me was (is) to not fly at night  :lol:

Share this post


Link to post

Hi Jeroen-

 

If my weak memory serves me correctly, I had this issue way back when I moved from a CRT to an LCD monitor which didn't exhibit what you're describing.

 

Anyway, I think I found somewhere that even though you're running 32bit through the game and card, LCDs can only display at 24bit, hence the banding, etc. that you're experiencing.

 

The fix for me was (is) to not fly at night  :lol:

 

Actually cheaper LCDs are usually with 6-bit color reproduction per colur, which makes them capable of displaying 262144 colours compared to 8-bit LCD which again puts out 16.7 million colours and then some. These 6-bit LCDs use dithering technique, which applies slightly different shades for adjacent pixels to fool the eye and display those "missing" colours. This may again cause banding for surfaces which naturally have low variance for different shades and dithering can't make up for the difference. On the otherhand, fastest panels (TN) are usually 6-bit so speed is their advantage. 

 

Best and most expensive monitors designed for photoediting and such professional tasks, where best possible colour reproduction is required, are always 8-bit panels. They are in most cases very bad choice for gaming, though, as they usually have very slow response time and tend to display ghosting and may also have extensive input lag. There are some PVA panel models out there that are capable of good colour reproduction and decent response time. One example that comes to my mind are Eizo's Foris multimedia/gaming monitors.

Share this post


Link to post

Jeroen, I believe this is not the problem of P3D, rather the settings and quality of you LCD monitor. It could very well be that your monitor is incapable of handling dark scenes, which is a common problem for many LCDs on the market.

 

I get very nice night scene both on my plasma TV and in Oculus DK2 which uses an OLED panel. Both plasma and OLED are good at black levels, especially OLED. In DK2 the night scene of P3D is incredible, every bit as real as it can be and absolutely a jaw-dropping experience. I guess it helps that DK2 has the OLED panel and is an HMD that puts your eyes in a complete dark (i.e. light-controlled) environment.

 

If your LCD is a TV set then make sure that you set it at the right input mode (sth like PC or native) and remove all those TV "enhancement" settings for sharpness, contrast, picture etc. LCD is not famous for handling deep blacks and it's possible that you just have to live with it or buy a better monitor.

Share this post


Link to post

For what its worth, this problem went away for me once I activated HDR lighting.

Share this post


Link to post

For what its worth, this problem went away for me once I activated HDR lighting.

 

That's enabled already on my PC.

 

I suppose it's a monitor thing then and not much you can do about it apart from buying a better one. It's odd though because I've played numerous games on this monitor which never had this problem, also games like Splinter Cell where you are in the dark most of the time: always looked great.

Share this post


Link to post

That's enabled already on my PC.

 

I suppose it's a monitor thing then and not much you can do about it apart from buying a better one. It's odd though because I've played numerous games on this monitor which never had this problem, also games like Splinter Cell where you are in the dark most of the time: always looked great.

 

I have the same issue which I did not have on 2.3. I have a moderate monitor(Hanns G 28" at 1920X1200). My HDR is also on. Very odd and very distracting.

Share this post


Link to post

Very odd, night looks fantastic on my system, love flying at night and no banding issues at all.

 

Some things you might want to look into to:

 

1.  Connection type (DVI-D vs. DVI-I) from GPU to Monitor (do NOT use VGA adapter) ... check GPU to see if it has a DVI-D port (preferred)

2.  Video card drivers control panel ... make sure color depth = 32bit (if not try setting up a custom resolution, refresh, color depth)

3.  If you use nVidia Inspector make sure you aren't using any settings that reduces output to 8bit

 

But black banding is usually indicative of a monitor's capabilities ... P3D's night isn't really a black black ... it's very fine gradients that will show up if the monitor isn't up to the task.  How well a monitor deals with "black" and gradients will impacts it's review (positive or negative) - it's one of those key test items that separates bad, good, ugly.

 

Most 3D shooters don't use high quality gradients for night time ... nothing like you'd see in P3D (that's how 3D shooters help keep fps high - that and highly managed 3D scene in terms of polygon count and distance).

 

As a test, select your location, pick a day where the moon is just a sliver ... this will help: http://www.moonconnection.com/moon_phases_calendar.phtml and see if the banding is more or less.  My hunch on a night with no or not much moon the banding will be less.

 

Cheers, Rob.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this