Sign in to follow this  
Blaze

Help With UT2 in P3dv2.4 (got it working just need a bit of help)

Recommended Posts

I have installed UT2 using the EMT into P3D 2.4 but it didn't go as well for me as others.  I have followed previous threads and made the required mods created a FSX.exe and added the line 

 

SimObjectPaths.9=SimObjects\UT2 Aircraft

 

To the [Main] section of my P3d.cfg file

 

 

When I launch P3d it doesn't launch UT2,  I have to go in and manually execute the UT2 Services.exe to get the program to launch and show up under the in game add on menu. 

 

 

Here is what I have in my exe.xml file...

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
    <Descr>Launch</Descr>
    <Filename>exe.xml</Filename>
    <Disabled>False</Disabled>
    <Launch.ManualLoad>False</Launch.ManualLoad>
    <Launch.Addon>
    </Launch.Addon>
    <Launch.Addon>
        <Disabled>False</Disabled>
        <ManualLoad>False</ManualLoad>
        <Name>GoFlight Hardware Interface</Name>
        <Path>X:\Program Files (x86)\GoFlight\GFDevP3D.exe</Path>
        <CommandLine></CommandLine>
    </Launch.Addon>
   <Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>V:\Lockheed Martin\Prepar3D v2\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
    <Launch.Addon>
    <Name>EZdok camera addon</Name>
    <Disabled>False</Disabled>
    <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
    </Launch.Addon>
    </SimBase.Document>

 

There is nothing in my DLL.XML file that references UT2 at all.

 

Got any suggestions?
 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

If V:\Lockheed Martin\Prepar3D v2 is indeed you P3D directory, it looks good. Although some simmers say you don't need an entry in the dll.xml, there is an entry in mine. Wanna give it a try?

Share this post


Link to post

Mario,

 

Yes this is the correct path no issue with EZDoc or my Goflight entries they work as they should..

 

 

I would like to see the entries in your dll.xml file if you don't mind sharing?

 

Thanks,

Robert

Share this post


Link to post

Here you go:

 

<?xml version="1.0" ?>
- <SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
- <Launch.Addon>
  <Name>ObjectFlow</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>C:\Prepar3D v2\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\ObjectFlow.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>Addon Manager</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>bglmanx.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>FSUIPC 4</Name>
  <Disabled>False</Disabled>
  <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>RAZBAM Metroliner System Control</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>Addon Modules\MM3SM.dll</Path>
  <DllStartName>module_init</DllStartName>
  <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
- <Launch.Addon>
  <Name>Captain Sim Sound</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>Captain_Sim\bin\cs.sound.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>Flight Recorder</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>RAASPRO</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>.\RAASPRO\RAASPRO.dll</Path>
  <DllStartName>module_init</DllStartName>
  <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
- <Launch.Addon>
  <Name>FSTramp</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>C:\FSTramp\FSTramp.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>Migration Tool Plugin</Name>
  <Path>MigTool.dll</Path>
  <DllStartName>module_init</DllStartName>
  <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
- <Launch.Addon>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Name>UT2</Name>
  <Path>C:\Prepar3D v2\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
  <NewConsole>True</NewConsole>
  </Launch.Addon>
- <Launch.Addon>
  <Name>A2A Feel</Name>
  <Disabled>False</Disabled>
  <Path>Modules\A2A_Feel.dll</Path>
  <DllStartName>module_init</DllStartName>
  <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
- <Launch.Addon>
  <Name>AccuFeelMenu</Name>
  <Disabled>False</Disabled>
  <ManualLoad>False</ManualLoad>
  <Path>Modules\AccuFeelMenu.dll</Path>
  </Launch.Addon>
- <Launch.Addon>
  <Name>as_connect</Name>
  <Disabled>False</Disabled>
  <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>
  </SimBase.Document>

Share this post


Link to post

Thanks Mario,

 

It didn't seem to do anything, I still have to launch the UT2Services.exe manually to get it to work.

 

Strange

Share this post


Link to post

I didn't create any DLL or EXE files when I installed UT2 via the EMT. I just added the "SimObjectPaths" statement to the P3D.cfg file, and it has worked right off the bat.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this