Jump to content

Archived

This topic is now archived and is closed to further replies.

blake7

FSX Process not found. FSX_handle: 0

Recommended Posts

I have submitted this to the Flight 1 forums (sim forums), they are very slow to respond so will try here :

 
This delightful error appeared a couple of weeks ago, couldn't find a way around so reinstalled windows and FSX, worked great and again back into 2 weeks its back, the error window is headed Ezdok camera ?

FSX starts with the splash screen to almost hitting the main screen then disappears with the error in the attached picture.

Desperately seeking a resolution without the dreaded reinstall again. I've searched the forums but its confusing as hell what to do.


Untitled.png
 
If it helps, as discussed in the other forum I ran FSX through REX, still don't work and now the error message above no longer shows but FSX still fails to start in the same way.
 
Tried the uninstall and reinstall of EZDOK using the red Flight 1 logo method with absolutely no internet / virus programs running, still no good, the annoying thing is the main screen where you choose the aircraft and airport, weather etc. flashes up momentarily then disappears without trace. Checked the task manager and again no signs of FSX running ?
 
I have removed EZDOK again, carried out a registry clean, removed the lines I the .cfg and .exe files, still no good. Also read somewhere that FSDT products may cause this somehow and would resolve by reinstalling, so I reinstalled GSX but to no avail.

Getting desperate now smiley7.gifsmiley7.gifsmiley7.gif

 


Gary Blake.

Share this post


Link to post
Share on other sites

Also read somewhere that FSDT products may cause this somehow and would resolve by reinstalling, so I reinstalled GSX but to no avail.

If any FSDT product is involved it would be the Addon Manager so all you had to do was reinstall the Addon Manager. It gets corrupted sometimes and not even FSX will start up. That may be your solution here.

 

EZDOK should have an entry in the dll.xml. Did you disable that?

 

Computers do strange things. Sounds like your dll.xml is corrupted. You can move that file to a temporary directory on your computer and try to start up FSX.

 

AVSIM has changed its signature policy and kindly asking everyone to please put their system specs and flight sim information in their respective "My Profile". More details can be found at the following link - http://forum.avsim.net/topic/436632-new-signature-rules or under the Forums tab above. Thanks for your cooperation.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Hi Jim, I reinstalled the FSDT addon Manager, didn't work, but, I then isolated the DLL, EXE & CFG from App/Roaming/Microsoft/FSX and restarted FSX and it worked back to default settings.

 

I reintroduced the DLL, EXE and CFG one by one and it is the DLL with the problem, as soon as I reintroduced the DLL it stops working again.

 

So my next question, how can I fix the DLL without reinstalling everything ?

 

This is what it looks like if it helps ?

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

<SimBase.Document version="1,0" Type="Launch"><Descr>Launch</Descr><Filename>dll.xml</Filename><Disabled>False</Disabled><Launch.ManualLoad>False</Launch.ManualLoad>.manualload><Launch.Addon><Name>Flight1SoundStream</Name><Disabled>False</Disabled><ManualLoad>False</ManualLoad><Path>C:\Flight One Software\Flight1 SoundStream\Flight1SoundStreamFSX.dll</Path></Launch.Addon>.addon><Launch.Addon><Name>Addon Manager</Name><Disabled>False</Disabled><ManualLoad>False</ManualLoad><Path>bglmanx.dll</Path></Launch.Addon>.addon><Launch.Addon><Name>Object Placement Tool</Name><Disabled>True</Disabled><ManualLoad>False</ManualLoad><Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path></Launch.Addon>.addon><Launch.Addon><Name>Traffic Toolbox</Name><Disabled>True</Disabled><ManualLoad>False</ManualLoad><Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path></Launch.Addon>.addon><Launch.Addon><Name>Visual Effects Tool</Name><Disabled>True</Disabled><ManualLoad>False</ManualLoad><Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path></Launch.Addon>.addon><Launch.Addon><Name>FSUIPC 4</Name><Disabled>False</Disabled><Path>Modules\FSUIPC4.dll</Path></Launch.Addon>.addon><Launch.Addon><Name>PMDG Interface</Name><Disabled>False</Disabled><Path>PMDG\DLLs\PMDG_Interface.dll</Path><DllStartName>module_init</DllStartName><DllStopName>module_deinit</DllStopName></Launch.Addon>.addon><Launch.Addon><Name>RAASPRO</Name><Disabled>False</Disabled><ManualLoad>False</ManualLoad><Path>.\RAASPRO\RAASPRO.dll</Path><DllStartName>module_init</DllStartName><DllStopName>module_deinit</DllStopName></Launch.Addon>.addon><Launch.Addon><Name>IvAp</Name><Disabled>False</Disabled><Path>X:\IVAO\IvAp v2\ivap_fsx_bootstrap.dll</Path><Commandline/></Launch.Addon>.addon><Launch.Addon><Name>PMDG HUD interface</Name><Disabled>False</Disabled><Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path><DllStartName>module_init</DllStartName><DllStopName>module_deinit</DllStopName></Launch.Addon>.addon><Launch.Addon><Name>as_connect</Name><Disabled>False</Disabled><Path>as_srv\as_btstrp.dll</Path></Launch.Addon>.addon></SimBase.Document>


Gary Blake.

Share this post


Link to post
Share on other sites

So my next question, how can I fix the DLL without reinstalling everything ?

Look in the folder where the dll.xml resides. Most addon programs save your last dll.xml as something like dll.xml_before_addon_manager or dll.xml.raaspro.backup. One of those may be working okay. If so, you'll just have reinstall (repair) an addon that is not in the dll.xml anymore.

 

PMDG also has a guide for troubleshooting corrupted dll.xml's - http://support.precisionmanuals.com/kb/a92/dll_xml-information-and-troubleshooting.aspx.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Thanks Jim, that done the trick, there were several back up DLL files from various add-ons, I reverted back to the last backup.

 

All working now, really appreciate your help.


Gary Blake.

Share this post


Link to post
Share on other sites

Glad it works and I was able to help!

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Just got this error this morning after updating RAAS, reloaded the XML file from a back up and all works great thanks Jim  :)

Glad your problem was fixed too Richard!

 

I am totally impressed with your system specs with an overclock @5.2GHz. I heard only great things about the i7-4930K. And a 1TB SSD for FSX and 750GB SSD for Windows 7! Right now I think you have about the fastest gaming system on Planet Earth! Just a friendly reminder though that AVSIM has changed its signature policy and kindly asking everyone to please put their system specs and flight sim information in their respective "My Profile". More details can be found at the following link - http://forum.avsim.net/topic/436632-new-signature-rules or under the Forums tab above. Thanks for your cooperation.

 

Watch your settings though as you still only have 4GB's of Virtual Address Space (VAS) and I think cranking up the settings with a system like this will just use up the VAS even faster. At least this is the theory as we really did not have this problem with VAS several years ago before the i7 and Sandy Bridge chipset. It was rare 3-4 years ago hearing about an OOM. Now we are getting super fast computers. It's the graphics card too as they have gotten very powerful too.

 

In regards to your signature, I would save your specs to Notepad and put a link to the document on your desktop, then, when you write a post, you can open up the document quickly and copy and paste your specs inside the post or topic.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,535.00 of $25,000.00 Donate Now
×
×
  • Create New...