Jump to content

Sign in to follow this  
angeli662

My FPS went south..

Recommended Posts

Could you post your network setup?  MCE does not run inside your flight sim so it is highly unlikely it would cause a frame drop, not sure, maybe send an email to support?

Share this post


Link to post
Share on other sites

Thanks Will, I am going to do a little more investigation, I have a pretty powerful  FSXSERVER-PC a also a client PC, I also have commercial grade internet, as I use several addons like Project Magenta, Rex, SimToutchPlus2 ASN etc. before I installed MCE my FSX fully loaded was running 28/30 fps solid, the second time I use FSX with MCE got 4/6 .  I noticed in window mode I get them back but in full goes back 4/6.

tested without MCE full also back to usual 28/30.  I will post when I done more investigation. I love this addon for the simplicity, I have all the FS2crew but never used.

If you have any suggestion please let me know.

Share this post


Link to post
Share on other sites

Thanks Will, I am going to do a little more investigation, I have a pretty powerful  FSXSERVER-PC a also a client PC, I also have commercial grade internet, as I use several addons like Project Magenta, Rex, SimToutchPlus2 ASN etc. before I installed MCE my FSX fully loaded was running 28/30 fps solid, the second time I use FSX with MCE got 4/6 .  I noticed in window mode I get them back but in full goes back 4/6.

tested without MCE full also back to usual 28/30.  I will post when I done more investigation. I love this addon for the simplicity, I have all the FS2crew but never used.

If you have any suggestion please let me know.

 

I can tell you MCE itself isn’t a CPU hog at all. It’s probably something to do with your complex setup. And by the way, this is the main reason we have a Demo. Every add-on developer should consider one. It’s simply impossible to check for every add-on + Flight Sim version + Operating system + hardware combination compatibility.

 

Not even Microsoft has the resources to do that, hence their decision to provide a Demo for FSX.

 

I assume MCE is running on same machine as the simulator. You cannot run it through a network.

 

I can only give you as much relevant information as possible so you can see what could be the issue on your side.

Check that you don’t have anything in your setup that would trigger either <DEL> or <END> key by accident.

 

You may want to disable the option “Enable optimizations”. With option ON, MCE will refrain from using the first CPU core (on dual core CPU) or the first 2 cores (on quad core CPU). The intention is to let the sim FLY.

 

If you’re using custom affinities, or have set some other heavy add-on to work on the same MCE core, then speech engine and MCE could be starved of execution time, and you may experience strange behaviour.

 

I cannot explain why FPS is back in Window mode ad worse in Full Screen mode.

Are you sure it isn’t a graphics driver issue?

 

If using a multi-monitor setup, you are advised to set MCE to start to the system tray. This avoids having the MCE window appear unless you want it to, via system tray.

 

Go to General tab of the UI and click <More options> button.

In advanced options screen, select option “Start to tray”

 

Are you using Radar Contact on a networked machine?

 

If possible, post a screenshot of the <About> tab section of the user interface.

 

Thank you

Share this post


Link to post
Share on other sites

Thanks for the reply FS++,  I did download the demo but it kept saying  the demo period has expired. this is the first time. I think is I just found out in my  aerosoft airbus had something about MCE.

I is not a big deal, I would probably buy it anyway. I still have hope that I will be able to use it.

Here what is happening and I will post some pics below:

 

There are only a few addons I start with FSX on my FSXSERVER-PC (AirNav FS Live 3 and LINDA which is a lua based program) and every thing else are run on my FSXCLENT-PC.

Just to test I ran FSX alone with MCE and the results were the same.

If I run FSX on window mode with MCE no hits what so ever, then if I take to full screen it maintain the FPS.

If I start FSX in full screen with MCE that is when the problem starts.

The first time I installed MCE It ran very nice so I was wondering if the languages pack is the  problem. 

If you have any suggestions  I will be opened for it. Just in case I did buy good headset and changed my soundcard  settings from (Asus Sonar DX) to the onboard, didn't help either.

Here my FSXSERVER-PC specs:

 

Asus Rampage IV black edtion complete water cooled 

Intel i7 3970X six core Extreme, running @ 4.9 

65gig 2400mhz of memory @ 2400

Intel Raid Controller with 6 x SSD's raid O +++ 

2 Nvidia GTX 690 in quad SLI

3 30" displays  in Surround  @ 7985 x 1600

 

Windows 7 Ultimate

 

XGj7H.jpgEVmv.jpg6C0H1.jpg

 

Thanks again

Share this post


Link to post
Share on other sites

 

 


If you have any suggestions

 

There is certainly no power shortage with that PC. You could eventually run all add-ons on it.

 

A few more suggestions...

 

Make sure you run FSX in normal priority.

 

The <About> screenshot suggests you may not have the correct output. Use our supplied tool to select what audio input and audio output MCE will be using.

 

Click Start->All programs->Multi Crew Experience->Tools->Assign sound device.

 

Select a non-digital audio output from the list and obviously the correct input where your headset is connected. Click OK, and let the wizard automatically adjust things.

 

Be aware, MCE runs the entire speech engine inside “mce.exe”. Therefore, any issue with MCE, speech engine or audio device would eventually translate into app hang or crash, not just MCE code. By the way, this is why we will never run voice control software in a simulator gauge. Worst case scenario, MCE dies. Your flight, the most important thing, will rarely if ever be compromised.

 

If your PC is dedicated to flight simming and not running any other game, you may want to disable CPU hyper-threading. Although it’s nice to see 12 cores available, in reality it’s just 6 physical cores. FSX, P3D aren’t compiled to make use of hyper-threading. That’s up to you though.

 

Because you are on Windows 7 64 Bit, suggest you un-install the Realtek audio drivers, reboot the machine and let Windows 7 use its own digitally signed drivers. They are better than Reltek supplied ones for the x64 platform.

 

Finally, to understand whether the issue is really linked to triple monitor setup and full screen, suggest you only use one screen for now and see whether switching to full screen mode causes any adverse effect.

Share this post


Link to post
Share on other sites

Thanks for the reply FS++  - Some good news.....

 

 

 


The screenshot suggests you may not have the correct output. Use our supplied tool to select what audio input and audio output MCE will be using.

 

I was just testing different options.  I usually disable Realtek from the Bios :lol:

 

 

 


If your PC is dedicated to flight simming and not running any other game, you may want to disable CPU hyper-threading. Although it’s nice to see 12 cores available, in reality it’s just 6 physical cores. FSX, P3D aren’t compiled to make use of hyper-threading. That’s up to you though.

 

This is also a test as I desable from bios, although hyperthread was enabled I had on the cfg file with affinity 63 (6cores)  so FSX wouldn't crash.

So now the good. I don't know if this was in the manual but if it was I missed it, I started FSX with plane/scenery/airport/etc ready to fly, then I started MCE, when I waited a few and noticed the writing changing, when  the splash screen disappears the little window console come up and only then I clicked fly now on FSX and there it was   :P .

 

It didn't give me a 30fps, more like 16/20 but it is a improvement.

Now Do you think is is about right in terms of perform?  or maybe there is something I still could investigate further? 

I really like your program, I have every FS2Crew ever created  but could never figure them out this one it is a lot easier to operate.

 

Thanks again

 

Rick 

Share this post


Link to post
Share on other sites

 

 


Now Do you think is is about right in terms of perform? or maybe there is something I still could investigate further?

 

You’re welcome.

 

No, it’s not normal. You should see zero performance loss even on dual core CPU, let alone a 6 core one.

 

I have a feeling one of your sound devices isn’t in good shape.

 

The difference between pre-MCE and after-MCE is that unlike before where your sound device was mainly tasked with playing audio, now it must deal with audio-in and audio-out at the same time.

Could be drivers? Eventually disable “Asus Sonar DX” and use Realtek with Windows 7 own drivers to see if it makes a difference.

 

For start-up, suggest....

 

 

Case 1: You want to interact with MCE UI

 

 

Start FSX in windowed mode. Wait until aircraft is on the tarmac ready to fly, and then start MCE.

When it’s up and running and you have set all your preferences, switch to full screen mode. You can even do that via voice.

 

Case 2: You’d rather always start to full screen mode and don’t want the MCE UI to interfere.

 

Use options “start to tray”, and “auto-start with FS”.

You fire up FS in full screen mode and MCE will follow automatically. Just wait until you see the message “Ready to go”.

 

Note: For aircraft like PMDG 777 and PMDG 737, auto-start with FS isn’t recommended. You have to wait until those airplanes have completed their initialization process (countdown in green bar to zero) before starting MCE.

Share this post


Link to post
Share on other sites

 

 


(Asus Sonar DX)

 

I don't know if it's the key thing, since you're running Quad SLI, you want all your PCI-Express lanes to be used by the graphics cards. In the context of speech reco, the PCI_E "Asus Sonar DX" would be using some of those lanes quite a lot I guess. Therefore, you'd be better off using the built-in sound device if only for the sake of graphics..

 

And should you find the onboard card wanting, you can always get a wired USB headset. It doesn't have to be of the expensive variety.

Share this post


Link to post
Share on other sites

I don't know if it's the key thing, since you're running Quad SLI, you want all your PCI-Express lanes to be used by the graphics cards. In the context of speech reco, the PCI_E "Asus Sonar DX" would be using some of those lanes quite a lot I guess. Therefore, you'd be better off using the built-in sound device if only for the sake of graphics..

 

And should you find the onboard card wanting, you can always get a wired USB headset. It doesn't have to be of the expensive variety.

Thanks for the reply FS++,  The GTX 690 are dual GPU cards  2 slots 16/8,  also I have the a Raid controller.  I had a blutooth Logitech headphone before now I am using a better quality headphone with 35mm connector further more I got another Asus card(Zonar DSX) I need this card as I have a 7.1 surround going into a receiver.

I follow you previous advice on how to start FSX/MCE and it seems got I lot better now

23/28 FPS which is fine considering using Orbix Scenery +  my sliders are all the way up and several addons running in the background.  I will retry the Logitech again as the new headphone is big and wired.

 

thanks again 

 

Rick

Share this post


Link to post
Share on other sites

 

 


I will retry the Logitech again as the new headphone is big and wired.

 

Probably not worth trying as Bluetooth headsets aren't supported by the speech engine. Maybe just settle with your current configuration.

 

One last thing to keep in mind...

 

Your speech profile is tied to "specific sound card /headset and ambient noise conditions".

 

Once you have decided which headset and sound card to use, suggest you create a brand new speech profile in Windows Control Panel, make it active and train it from scratch using our supplied tool.

 

Click Start->All Programs->Multi Crew Experience->Tools->Speech training.

 

You will get the best results with all sounds coming out of headset. Although it's possible to have engine sounds coming out of speakers, you will have to position those in a way that they don't feed directly into the microphone and set them at low volume. Othewise speech engine will be extremely busy trying to analyze engine noise as speech, wasting CPU cycles in the process.

Share this post


Link to post
Share on other sites

 

 

You will get the best results with all sounds coming out of headset. Although it's possible to have engine sounds coming out of speakers, you will have to position those in a way that they don't feed directly into the microphone and set them at low volume. Othewise speech engine will be extremely busy trying to analyze engine noise as speech, wasting CPU cycles in the process.

 

I thing this explain all. I have the sound out coming from my speakers  and use the mic from the headset. this headset has noise canceling and thats why I think is working better.

 

Thanks again

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...