Sign in to follow this  
stonelance

Flight Toolkit 1.1.3

Recommended Posts

http://www.flighttoolkit.com/Downloads/FlightToolkit_1_1_3.zip

 

Changes:

- Changed writing of floating point numbers in SimProp to be culture invariant (always write with decimal points instead of commas).

- Added versioning support in FSX conversion to allow for incremental updates.

- Fixed bug in MDL conversion that would allow converting LODs that were empty.

- Updated LOD numbers during MDL conversion to use the actual radius of the model.

- Fixed some threading issues in Addon Builder when the Flight configuration selection dialog is displayed.

 

Try rerunning the FSX conversion with this new version.  You don't need to delete any of the old temp conversion files, it should automatically delete the ones that it needs to regenerate.  Don't forget to run Addon Manager afterwards and re-enable the addon after conversion.

 

Please let me know if you run into any issues.  I didn't test it heavily yet.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks stonelance, the new version work well, and Tokyo no longer crashes.

 

A couple of questions if I may:

 

I see many bridges missing, will it be possible to convert those in future, or hack in some road segments or generic bridges to fill the gaps?

 

I enjoy free flight, but might it be possible to get 'jobs' working in future, to provide some goal in flying between airfields?

Share this post


Link to post
Share on other sites

Thanks Steve! Currently rerunning the conversion, hopefully it works. I've noticed that the Addon Builder is extremely slow, is it just me or is everyone having this problem?

Share this post


Link to post
Share on other sites

I enjoy free flight, but might it be possible to get 'jobs' working in future, to provide some goal in flying between airfields?

 

     Possible, but will take some time since creating missions requires a Mission Editor. I've tried with .XML but  something like the Object Placement Tool in FSX is required.

Share this post


Link to post
Share on other sites

Thanks, compiling the weather themes works fine now for me!

 

Unfortunately I had deleted the FSX temp conversion files and when trying to run the conversion again, it complains that the file "path\to\temp\FSX World\OutputStatus.txt" can't be found. Do I have to uninstall the addon before running the conversion?

 

 

     Possible, but will take some time since creating missions requires a Mission Editor. I've tried with .XML but  something like the Object Placement Tool in FSX is required.

 

I think the existing missions should also work, but the converted airports are probably lacking the required parking spots.

Share this post


Link to post
Share on other sites

I think the existing missions should also work, but the converted airports are probably lacking the required parking spots.

 

     Probably. However, Proximity triggers also need to be set up.

Share this post


Link to post
Share on other sites

majuh: It should be handling a missing OutputStatus.txt, but it looks like the writing may fail if the directory doesn't exist.  I'll fix that for the next version, but in the mean time you can create a "FSX World" folder under the path that you choose as the output folder and it should unblock you.

 

winjimon: I'm guessing the bridges you are talking about are the extrusion bridges.  Ideally I would convert them to VectorScenery bridges in Flight, but that would require me figuring out the vector format.  I might be part of the way there already, so it could be possible if we are lucky.  The other option would be to convert them to landmark objects during conversion, but that would require reimplementing all the code in FSX that renders the bridges.

 

I thought job missions would work on these new airports.  Are they not working?  I might be able to look into why, but I don't know the missions system very well.

Share this post


Link to post
Share on other sites

majuh: It should be handling a missing OutputStatus.txt, but it looks like the writing may fail if the directory doesn't exist.  I'll fix that for the next version, but in the mean time you can create a "FSX World" folder under the path that you choose as the output folder and it should unblock you.

 

I thought job missions would work on these new airports.  Are they not working?  I might be able to look into why, but I don't know the missions system very well.

 

Yep, creating the folder "FSX World" worked for me. I can confirm the game doesn't crash in Tokyo anymore.

 

It says there are no jobs available at the new airports. The DisplayRequirements for the PaxCharter2-4 mission for example look like this:

 

return (runway_surface_present('CONCRETE') or

... or

runway_surface_present('TARMAC')) and

(parking_type_present('RAMP_GA') or

parking_type_present('RAMP_GA_SMALL') or

parking_type_present('RAMP_GA_MEDIUM') or

parking_type_present('RAMP_GA_LARGE') or

parking_type_present('RAMP_CARGO'))

 

So I guess parking_type_present always returns false for the new airports.

Share this post


Link to post
Share on other sites

Found the problem.  Apparently Flight uses a new airport summary format and I wasn't converting them.  This new version can convert the airport summaries to the Flight format, and now jobs are working in a large portion of the FSX airports:

 

Thanks, generic jobs work fine now!

Share this post


Link to post
Share on other sites

Any chance this release will improve FSX Aircraft conversion chances? Any possible mutiplay in future releases?

Share this post


Link to post
Share on other sites

Flight Toolkit 1.1.6 or 1.1.2 do not launch Flight in NonGFWL mode (Unmodified or OfficialGFWL are OK for running Flight).

 

I just downloaded all my purchased Flight + Hawai + Alaska using the last gfwlsetup into my new Dell XPS 27 (Windows 8.1).

 

In NonGFWL mode : the Microsoft Flight windows appears then the message "do not respond" (ne répond pas) is displayed and stay here.

 

I have do an uninstall of the Flight Toolkit using the configuration panel before reinstalling it several times.

 

Thanks for advice.

 

OK, uninstalling all the stuff, Flight, toolkit ... Reinstalling, running with LIVE connected. All fine (without the toolkit).

 I have Flight 1.1.130063 with Hawai Alaska - Icon A5, Boeing Stearmann PT-17, Van's RV-6A, Red Tails P-51

Share this post


Link to post
Share on other sites

Is anyone else having this problem?  Can you post your xlive.log which should be in "%localappdata%\Flight Tools\Flight Toolkit"?

Share this post


Link to post
Share on other sites

xlive.log :

Initializing Live...
  Loading Title ID
  Title ID is 4D5308D2
  Determining installed DLC list...
    Parsing enabled DLC from AddonConfiguration 'C:\Users\Claude\AppData\Local\Microsoft\Xlive\DLC\4d5308d2\00000002\AddonConfiguration.xml'...
    Enabled content: 00000000086E92117D68C147A780283D007F1120
    Enabled content: 00000000F6BC05C5E8C948A7B2A200C89ABCA411
    Enabled content: 00000000FB1C7B17183B8C41A46AC6E0DA92D50E
    Enabled content: 1D41D3A9122EA6E86B140300399FA28A33DB2114
    Enabled content: 208FF0A175569D6E76AE2019A6EAE54F04A486F9
    Enabled content: 2B2A32FCE7EFC6806355990BC540D1B586CE2A78
    Enabled content: 33ED0905E4A724475213B37EC4FE5A1442DF7271
    Enabled content: 00000000512B3076153BF84F9520F0D873FD3280
    Enabled content: 4474540481D064A2637E3C596D960EE101256722
    Enabled content: 6CEB63A6F8E30EB01603D1695F0DDC14AE95C8B1
    Enabled content: 786C79E0D4E4028749854F20655DD40DDE80F7FF
    Enabled content: B2101D64F9B60BE2BAA0671D710C0C957CFD3DA4
    Enabled content: CCAC8D9A6FF8ADEBE8EE9452A5FA89AC8DFDCF15
    Enabled content: DE89BCC501A1909CD3B5648582E66811B93831BC
    Enabled content: E08EFA1DEE5774B44AEA7BAF1A4D49C766F4FC4C
    Enabled content: 34B73A79B8261EBF8FE072E64E912C5428E5B535
    Enabled content: F46F1F00385FAD61777B8749716572F7511A311A
    Enabled content: F4CDE55C9A4158C4915759B1B3C00A49719EC8FF
    Enabled content: 09F31425A816B0A0B0E1BC32C64297B7B4ADA251
    Enabled content: A956054769629E09F0159D73DBF23B351F59B859
  Initializing SQL
  Connecting to Live SQL DB
  Found 350 aerocaches in the database
  Found 1 messages of the day in the database
LSPServer: Listening for connections...
XNetStartup
WSAStartup
Socket: create
    Result 558: 0
Socket 558: bind 0.0.0.0:1000
    Result: 0

Share this post


Link to post
Share on other sites

I am one of the followers of this rebirth of Flight with great respect for stonelance, and the members who try to give solutions for the problems.

My problem is the same as albaran has, with the same log, only Result and Socket 558 = 714.

On my W7 Desktop I have no problems, but on my W8 laptop it won’t start.

Hope someone has a solution.

Share this post


Link to post
Share on other sites

Unfortunately that log doesn't tell me anything useful.  Do you have any sort of firewall settings that may be blocking the app?

Share this post


Link to post
Share on other sites

After updating to FT 1.1.6, when I start Flight, it just keeps loading and never stops until the whole system freezes. Before 1.1.6 it was working ok with the World Addon and FSX enabled. Anyone else having this problem?

Share this post


Link to post
Share on other sites

"Unfortunately that log doesn't tell me anything useful.  Do you have any sort of firewall settings that may be blocking the app?"

 

I tried it with the firewall shut off, no result.

In Unmodified and OfficialGFWL mode it works fine, in NonGFWL it doesn't switch to the 2nd screen, Microsoft Studio's.

Can it be a W8 issue? Because in my W7 desktop it works fine.

Share this post


Link to post
Share on other sites

This is a reply to my earlier post about 1.1.6: apparently, my system in general went nuts and it has nothing to do with the Flight Toolkit. After some diagnostics and testing, everything is working ok.

Share this post


Link to post
Share on other sites

I am curious too, because I don't know what is going wrong.

Flight works fine exept in NonGFWL mode. It hangs after the first screen.

Share this post


Link to post
Share on other sites

I am afraid I can't be of much help here. I am running in NonGFWL mode with everything enabled and tool kit 1.1.6. I am running Windows 8.1 Pro 32 bit and have converted the FSX library as outlined by Stonelance and others. Everything is working ok after some initial system problems on my end. The only problem I have encountered is one already known: some of the aerocaches don't work. You can fly to them and the counter for the 20 mile, 10 mile, etc. works, but you can't find the star and collect it. Most of them do work. I have collected 200 of them since I restarted Flight with the toolkit. Sorry I could not be of much help but I don't know exactly what happened.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this