Jump to content

Sign in to follow this  
IanHenry

Graphics Problem with FSX-SE

Recommended Posts

Hi,

     I was wondering if anyone here has any suggestions for a problem that I'm having with FSX-SE. I've just done a complete re format and re install of Windows 7 64 bit and FSX-SE in an attempt to solve this problem but it's re-occurred.

My system is quite old consisting of an i7 920 processer, Nvidia 580 GTX Graphics card and 12 Gb Ram. FSX-SE runs great on this machine with all the sliders to the far right with the exception of Traffic, set at 20%.

 

On first installation with a few add-ons, REX Texture direct and soft clouds, Orbx Global, Vector and EU LC everything is fine, but after a short time, the problem appears. When I want to finish a flight and press the escape key the screen just turns black and the only way that I can return to the start up screen is to press Control-Alt-Delete and start the Task Manager. This problem doesn't happen if you use DX10 mode, but I've discovered that DX10 carries a performance penalty with the Steam edition, which it didn't with the Microsoft version. 

 

As the Sim is still running behind the black screen (you can still click on the icons and hear them operating) I started to think maybe it's a problem with my Graphics card, but all my other Flight Sims work ok and I think they are more demanding on the graphics than FSX (P3D v.5, DCS World, Rise of Flight & IL2 Battle of Stalingrad).

 

Any suggestions would be greatly appreciated, because at the moment, I'm completely baffled by this.

 

Thanks,

         Ian     

Share this post


Link to post
Share on other sites

When I want to finish a flight and press the escape key the screen just turns black and the only way that I can return to the start up screen is to press Control-Alt-Delete and start the Task Manager.    

 

FSX has always had some problems when changing screen modes. When you press the ESCape key it is trying to display a Message Box with options. I've always found you only need to toggle into Windowed mode and back to get it displayed correctly again -- ALT+ENTER, twice.

 

Alternatively run in maximised Windowed mode all the time, though you might lose as few FPS that way.

 

Pete

Share this post


Link to post
Share on other sites

Whenever you have a black screen, one of the first things you should do to diagnose is to return your FSX-SE.cfg settings back to the default by deleting the config and letting it rebuild when you restart fsx-se. When you first installed fsx-se, you did not have a black screen as I see you have installed several products since then. Make sure all of the products installed are compatible with fsx-se. For instance, I heard some time ago that FTX/Orbx was having some issues with fsx-se and they need to develop a new installer to make sure the product is installed properly. Perhaps that has been fixed but I use it as an example as the installation process of addons is not the same as for FSX products. So, if a product is calling for a texture to render, it may not be found as it is not located where it should be.

 

The next thing you can do to investigate your issue is to disable all of your addon scenery to see if the problem still exists.

 

Best regards,

Share this post


Link to post
Share on other sites

Many thanks for your replies Pete and Jim,

I've gone through all the scenery add-ons and disabled them one by one as Jim suggested and that didn't make any difference, and they are all compatible with the Steam version of FSX.

 

Following Pete's suggestion did produce some interesting results. As I always run FSX in full screen mode, I pressed ALT+Enter to put the program into windowed mode, then pressed escape, the "do you want to end the flight" box appeared (this has always appeared) to which I confirmed that I did and the program exited to the start screen, I thought great I'm getting somewhere!

 

I then restarted the default flight, switched to full screen and exited the flight and it exited normally to the start up screen as it should do. When I tried to repeat that I got the black screen again.

 

I can't help but think the problem is with the graphics, but I'm using the latest drivers so I thought maybe I should install some earlier drivers, which I did, but still the problem persists. I know I can work around this, but it still irritates me when I know something isn't working properly.

 

Thanks,

        Ian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...