Sign in to follow this  
planenut

No HGS Display

Recommended Posts

Haven't flown the NGX in a while.  Just loaded it up but I have no HGS display.  Just blank.  I went to the FMS and it says the HGS is installed.  The HGS goes up and down - just no info on it.  Been going through the manuals but so far have come up blank.  Any ideas?

 

Jim

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Haven't flown the NGX in a while.  Just loaded it up but I have no HGS display.  Just blank.  I went to the FMS and it says the HGS is installed.  The HGS goes up and down - just no info on it.  Been going through the manuals but so far have come up blank.  Any ideas?

 

Jim

Hey Jim,

 

Have you tried altering the HGS brightness using the knob on the roof beside where the HGS is mounted?

 

Also, PMDG like users to sign posts with their full name, thanks :).

Share this post


Link to post
Share on other sites

As mentioned:

Check the brightness

Check to ensure CLR isn't pressed on the HGS console (down by the transponder)

If none of those are the issue, submit a ticket at support.precisionmanuals.com

Share this post


Link to post
Share on other sites

Hi,

 

I checked those items you mentioned. They are both set ok. Guess I'll head over to PM.com and submit a ticket.

Thanks.

 

Jim Allen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this