Sign in to follow this  
C-FMWQ

FSX CTD On Startup

Recommended Posts

I recently decided to jump ship from FS9 to FSX and I have been running into an issue trying to get FSX to run properly (or open in most cases).

 

One my first fresh install of FSX, I installed FSX without any issues. I then tried installing Acceleration and I got an error saying that Acceleration did not install properly as there was an error reading the disc. As such, I uninstalled Acceleration and installed SP1 and SP2 (without uninstalling FSX or running CCleaner/cleaning up any files pertaining to Acceleration). FSX with SP1 ran without any issues even when shutting down and restarting my computer. However, SP2 initially caused FSX to "Encounter a fatal error" with the splashscreen. A few others seemed to have similar issues and they seemingly solved this by updating their graphic drivers. I updated my graphic driver and FSX with SP2 started working without any issues. However, when I restarted my computer, FSX again "Encountered a fatal error" at the splashscreen.

 

After a bit of reading I figured I made a mistake by partially installing Acceleration, then uninstalling it and installing SP1/SP2. I tried following this link to completely remove FSX: http://support.precisionmanuals.com/kb/a87/how-to-uninstall-and-reinstall-fsx.aspx, but I could not perform steps 5-7 as the folders did not exist when I tried deleting them (I assumed they were already deleted?). In more recent iterations, I have gotten FSX with acceleration installed, by using an external DVD drive, and had similar issues as above. Here are some of the things I have noted:

  1. Uninstalling SP2 or Acceleration causes FSX to work without any issues.
  2. If I have SP2 or Acceleration installed, rollingback or updating my graphics driver causes FSX to work as long as I don't restart my computer
  3. If I restart my computer, FSX with SP2 or FSX with Acceleration again CTD at the splashscreen until I rollback/update my graphics driver.

Looking at the event viewer, here are the error messages I am getting:

  1. Error Message - Please correct me if I am wrong, but I think this means that there is some sort of bad access of memory (from: Exception code: 0xc0000005). This is also fairly ambiguous as it does not tell us the faulting module, meaning it could be just about anything?
  2. Information Message - I beleive this points to it being a BEX error (Branch Exception)?

 

Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x03d2df74
Faulting process id: 0xb88
Faulting application start time: 0x01d07e4917a34e3c
Faulting application path: C:\FSX\fsx.exe
Faulting module path: unknown
Report Id: 5f78c41a-ea3c-11e4-b9c0-bcaec5289f90

Quote 1: The Error message

 

 

Fault bucket , type 0
Event Name: BEX
Response: Not available
Cab Id: 0

Problem signature:
P1: fsx.exe
P2: 10.0.61637.0
P3: 46fadb14
P4: unknown
P5: 0.0.0.0
P6: 00000000
P7: 03d2df74
P8: c0000005
P9: 00000008
P10:

Attached files:
C:\Users\User\AppData\Roaming\Microsoft\FSX\fsx.CFG.txt
C:\Users\User\AppData\Roaming\Microsoft\FSX\dxdiag.txt
C:\Users\User\AppData\Roaming\Microsoft\FSX\scenery.cfg
C:\Users\User\AppData\Roaming\Microsoft\FSX\fdr.dat
C:\Users\User\AppData\Roaming\Microsoft\FSX\dll.xml
C:\Users\User\AppData\Local\Temp\WERDB22.tmp.WERInternalMetadata.xml

These files may be available here:
C:\Users\User\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_fsx.exe_b86cef97d7f3044bcdedbf16c428e57f31ab871_122fdfb4

Analysis symbol:
Rechecking for solution: 0
Report Id: 5f78c41a-ea3c-11e4-b9c0-bcaec5289f90
Report Status: 1

Quote 2: The Information Message

 

Finally my system specs are as follows:

  • Windows 7 Ultimate 64-bit
  • i7 960 3.20 GHz
  • 16 GB RAM
  • NVIDIA GeForce GTX 560 Ti (Flipflopping between drivers 350.12 and 346.XX (I can't remember off the top of my head))
  • Note that I did have the Wilco E-jets, Flytampa scenery/some freeware sceneries and ASN installed but I uninstalled those and still had the same results.

Again, I am not really sure what to do so any ideas or suggestions are greatly appreciated!

 

Thanks,

Nehal

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


but I could not perform steps 5-7 as the folders did not exist when I tried deleting them (I assumed they were already deleted?)

 

Those folders are hidden folders so you will not see them unless you "unhide" them.  See page 1 and 2 of the AVSIM CTD Guide on instructions to unhide your folders based on Windows 7 or Windows 8 installations.

 

You had a BEX crash or Buffer_Exception_Overrun.  See page 11 of the AVSIM CTD Guide on possible solutions.  BEX crashes are usually accompanied with a Stackhash which is explained in the guide.  Your faulting module is "unknown" but that's because it wanted to tell you it was a StackHash.  A StackHash is something stuck in memory at a certain memory address.  How you get rid of it is unknown.  BEX crashes are the most difficult types of crashes to fix.  Did you recently mess around with the system voltage settings in the BIOS?

 

Your error reports show it crashed only with Acceleration installed.  I do not see any crash with SP2 installed.  I doubt it is Acceleration or SP2 that are causing your problem as long as you don't have both of them installed (do not think you can install SP2 if Acceleration is installed and vice-versa).

 

The crash report you are showing is the Microsoft Windows Error Reporting (.wer) report.  The AppCrashView report discussed on page 1 of the AVSIM CTD Guide deciphers .wer reports and provides more information.  It also shows all of your crashes and other crashes might give you a clue as to what's going on.

 

Best regards,

Share this post


Link to post
Share on other sites

Hi Jim,

 

To follow up with this.

 

I followed the AVSIM CTD guide and reinstalled W7. So far it has worked and I have been able to migrate over to FSX. Thanks again for your help.

 

Just out of curiosity, why is it that a reinstall of the OS is required? Is there the installation of FSX corrupting OS files?

 

Regards,

Nehal

Share this post


Link to post
Share on other sites

 

 


ust out of curiosity, why is it that a reinstall of the OS is required? Is there the installation of FSX corrupting OS files?

 

There is no known "magic bullet" that fixes BEX or StackHash or NTDLL.dll crashes.  We have made some suggestions at the beginning of the guide to help you troubleshoot a problem.  They say deleting your fsx.cfg, restarting fsx and letting the config rebuild is the same as reinstalling FSX.  That's because someone threw in a bad tweak or wrong parameter.  So, if none of the suggestions provided for fixing these types of crashes, we recommend reinstalling Windows and FSX.  Sometimes it's good to clean house especially if you have a lot of addons, any of which could be the Source of the problem.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this