Sign in to follow this  
Demious

Pitch Hold Problem

Recommended Posts

Every time I try to make an ILS landing, at the last part of the approach, when AP is already turned off for landing, the Pitch Hold turns on and I cant decent any further. The aircraft levels off and keeps flying straight on. I cant find how to turn the Pitch Hold off and this prevents me from landing.

 

I read about this being a known problem, but that are old posts, from 2 years ago, about version 1.07, so I expect this problem should have been solved by now.

Can it be I'm doing something wrong, or is it something I can fix in an ini or cfg file? I'd appreciate some help with this.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Tried today version 1014, I confirm I can reproduce WRONG behavior. It is bug introduced in 1014. Please report. Add me as cc in the report.

 

Thank you!

Share this post


Link to post
Share on other sites

Glad somebody has reported this issue as I too have the same problems. Unlike any other prop aircraft, this one seems so stubborn to wanting to land. And now to add to add to those issues, the tiller no longer works. I can see the tiller moving left,right but the nose-wheel stays put.

Share this post


Link to post
Share on other sites

I reported it on the Majestic forums and hope it will be addressed soon.

Share this post


Link to post
Share on other sites

@Demious,

 

The issue that you are referring to is not related to the Pitch Hold issue that some users experienced in earlier versions of the Q400.  How are you disabling your autopilot?  It almost sounds like your autopilot is not disengaging.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this