Sign in to follow this  
utd4life

Autogen buildings loading up in 'blocks'

Recommended Posts

Hello guys,

 

Hoping some can maybe offer some advice on guidance on an issue I've spent the last couple of weeks trying to resolve/improve but have unfortunately had no look.

 

I'm trying to solve the problem of autogen, particularly buildings, loading/popping up in 'patches' or squares, which is really obvious and detracts a lot of realism from the simming experience for me. Rather than it loading up subtly, it loads up in horrible blocks/chunks.

 

I've tried numerous settings, including a whole variety of Fiber_Frame_Time_Fraction=xx values, as well as tweaks such as TextureMaxLoad=30 and adding an afffinity mask, but haven't been able to get this problem to improve.

 

I'm hoping somebody can offer some insight on anything I am possibly doing wrong?

 

The sim apart from this runs great, performance is good etc, just this little niggling issue I would love to fix. In terms of In - sim settings, I have LOD at Max (Although I believe this has been limited anyway in P3D 2.5 to help combat the VAS issue, I am wondering if this is possibly causing the Autogen loading up like this due to the LOD restriction?)

 

Kind Regards,

 

Daniel

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I doubt you'll find a real solution. Prepar3d inherited this from FSX. While it's not quite as obvious as in FSX, it's still there.

 

As far as I remember, the first versions of Prepar3d2 (2.0, 2.1?) had a more fluid autogen handling, This seems to have got lost, maybe because of modified memory management (OOM avoindance) or performance.

 

You can manage this by chaning the zoom factor, within certain limits. According to my observations, smaller zoom factors seem to dampen autogen popping. Too small zoom factors create a fish-eye effect though. As a side note, zoom factor is not saved with the settings but with the default flight.

 

Kind regards, Michael

 

Share this post


Link to post

I doubt you'll find a real solution. Prepar3d inherited this from FSX. While it's not quite as obvious as in FSX, it's still there.

 

As far as I remember, the first versions of Prepar3d2 (2.0, 2.1?) had a more fluid autogen handling, This seems to have got lost, maybe because of modified memory management (OOM avoindance) or performance.

 

You can manage this by chaning the zoom factor, within certain limits. According to my observations, smaller zoom factors seem to dampen autogen popping. Too small zoom factors create a fish-eye effect though. As a side note, zoom factor is not saved with the settings but with the default flight.

 

Kind regards, Michael

 

Hi Michael,

 

Thanks for the info, and I have to agree I didn't notice this problem as much in the earlier versions of 2.0, it definitely seems to have got worse in P3D 2.5, which I suspect the same as you is due to memory management and an attempt to reduce OOMs.

 

I have tried experimenting with Zoom levels as you suggest, I run in Wide view aspect so I usually use a zoom level in the flight deck of around 0.70-0.80, but unfortunately it's still pretty noticeable for me.

 

Kind Regards,

 

Daniel

Share this post


Link to post

I run with wide view off (however without panel display as I have a hardware panel) and zoom 0.5. I agree to you, it's still annoying. Taking off from KSFO turning North to downtown San Francisco (ORBX)  the city still pops in in blocks.

 

However, I believe designers can control  this within limits, too. Consider Sydney city (again ORBX), I think this one pops in much more smoothly using the same zoom.

 

Some alternative solutions?

 

Kind regards, Michael

Share this post


Link to post

I run with wide view off (however without panel display as I have a hardware panel) and zoom 0.5. I agree to you, it's still annoying. Taking off from KSFO turning North to downtown San Francisco (ORBX)  the city still pops in in blocks.

 

However, I believe designers can control  this within limits, too. Consider Sydney city (again ORBX), I think this one pops in much more smoothly using the same zoom.

 

Some alternative solutions?

 

Kind regards, Michael

Ah ok Michael that's interesting to know.

 

Yes, hopefully someone can offer some alternative solutions?

 

Kind regards,

 

Daniel

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this