Sign in to follow this  
ben2491

SDK fails to initialize - FSX - NGX Reboot

Recommended Posts

Hello guys,

sorry that i come up with a problem already :/ When I want to start the Fs2Crew panel there comes the error message: PMDG SDK failed to initialize. I have a fresh NGX install with service pack 1d, 2D panel at startup, the Pmdg short turnaorund panel state loaded and I did everything according to the manual/tutorial. I'm using button control and SOP2 is activated.The NGX is not my default startup aircraft.

Thanks for your help!

Ben

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks for the quick reply Bryan!

Unfortunately that didn't work... I have the SDK line in my ini. NGX file, the FSX (running as admin) is not installed in the default program folder and I don't use a saved situation, only the default PMDG short/long state

Share this post


Link to post
Share on other sites

only the default PMDG short/long state

 

Try not using that.

 

When my NGX loads, the engines are running, then I load the short/long/cold and dark panel state.

Share this post


Link to post
Share on other sites

Sorry for the misunderstanding: I do that too. I start the flight in the PMDG default state, I wait until the aircraft is ready (green bar, 17-20 seconds) then I go to the FMS and load the PMDG Panel state (short or long - another green bar 17-20 seconds). I also tried to start Fs2Crew without loading any default panel state (engines running) but the same error message occurred...I also tried to reinstall, but nothing changed :(

Share this post


Link to post
Share on other sites

Did you own the legacy version of FS2Crew NGX? Even if you didn't, try re-installing the PMDG 737 and then FS2Crew Reboot.

Share this post


Link to post
Share on other sites

Yes I own it, but before I installed the reboot I completely uninstalled the legacy version and the NGX and then I made a clean reinstall (without the legacy of course) - 737 NGX incl. update 1d + Fs2Crew Reboot. I also use Fs2Crew for the 777 and everything works fine there. When I'm home tonight I'll reinstall everythig again but I don't have much optimism because I had a clean installation of the 737 already. Maybe I have to check the registry for any data that might cause problems

Share this post


Link to post
Share on other sites

So, I uninstalled my NGX and the reboot again, cleared my registry, restarted my computer, installed everything again, restarted my computer and have still the same problem... this is getting frustrating :/

Share this post


Link to post
Share on other sites

 

 


So, I uninstalled my NGX and the reboot again, cleared my registry, restarted my computer, installed everything again, restarted my computer and have still the same problem... this is getting frustrating :/

 

Cleaning registries always scares me.

 

But send me a Support Ticket.

 

I'll help you via a remote desktop.

 

You're sure you're starting in the 2D cockpit if using FSX?

 

If it works in the 777, it should work in the NGX.

 

Cheers,

Share this post


Link to post
Share on other sites

One user had everyone setup right, but still kept getting the SDK error.


 


We solved his problem by doing a total clean install of the NGX:


 


1. Uninstalling the PMDG 737 NGX.


2. Manually deleting any left over PMDG737 folders in the SimObjects folder in FS.


3. Re-installing the NGX.


4. Re-install FS2Crew Reboot.


 


That way you are totally clean.


 


There was some strange junk in his old PMDG folder that we causing the problem.


Share this post


Link to post
Share on other sites

How do you force the 737NGX to load in the 2D cockpit?     I am loading the trike,    making sure i have the 2D cockpit in that,  then load the NGX but it still comes up in the virtual cockpit.  

 

And I'm getting the SDK error too,   and I have checked that i have those two SDK lines in the _options.ini file. 

 

Cheers

MIke Kear

Windsor, NSW, Australia .


How do you force the 737NGX to load in the 2D cockpit?     I am loading the trike,    making sure i have the 2D cockpit in that,  then load the NGX but it still comes up in the virtual cockpit.  

 

And I'm getting the SDK error too,   and I have checked that i have those two SDK lines in the _options.ini file. 

 

Cheers

MIke Kear

Windsor, NSW, Australia .

 

OK oi was a bit quick on the trigger with that.      Dr Google was my friend and I found out how to do that.     Sorry. 

 

Here's hoping that solves the problem of the SDK thing.     I've been wrestling with FSX for almost all day.  First it was Norton 360 deleting dlls again, ( saying that because they didnt have a reputation,   I couldn't run them.  so it deleted them. - not quarantine - fully deleting them so I had to download the addons again !!)    then dumping Norton because it was the FOURTH time I have had to wrestle with this problem and then install Microsoft Security Essentials and learn how to configure it,    then reload the NGX and its variations,  then load my new FS2Crew Reboot,  then discover there was another add-on that Norton had broken,   so I had to go and get that all over again,   then finally I could work on starting up FSX.  

 

THEN the SDK Missing issue!!     The air went blue I can tell you!!! 

 

 

Cheers

Mike Kear

Windsor, NSW, Australia 

Share this post


Link to post
Share on other sites

Hi Mike,

 

So is your issue solved?

 

If you're going direct to the VC, it's because you're using EZDOK.

 

You should be fine though even with EZDOK doing that.

Share this post


Link to post
Share on other sites

Oh ok   I'm still in strife.     I go direct to the VC,  and still get the SDK message from FS2Crew.     What do I do now?

 

Have I got a simconnect issue?       Please tell me i dont have to completely reinstall FSX - that's a HUGE HUGE job with all the scenery and aircraft I have. 

 

Cheers

Mike Kear

Share this post


Link to post
Share on other sites

Sadly no, Bryan.     MY NGX loads into the VC  and I think its because yes I"m using EZDok.    But I still get the SDK problem    Where do I go now? 

 

On the basis that I might well have a SIMCONNECT problem,  I'm reinstalling some of my other add-ons that use it.  

 

 

Cheers

Mike Kear

Windsor, NSW, Australia

Share this post


Link to post
Share on other sites

 

 


MY NGX loads into the VC  and I think its because yes I"m using EZDok.

 

Yes, it's because of EZDOK.

 

There's a way to prevent EZDOK from force loading you into the VC cockpit.

 

From another user:

 

I had the same problem and one simmer told me how to fix it and it works for me now, and looks to me this is the only option which works for those who has same issue. So here:
Start up FSX then open the EZDOK studio and under options select Define keys and buttons and there you will find a Global enable setting (it is actually an enable/disable function). I have this mapped to a joystick button and I use this a lot to temporarily disable EZDOK camera effects when using the mouse to click on Cockpit buttons.You need to do all this before loading the NGX. Once the NGX is loaded in 2D you can switch to 3D and enable EZDOK.
Let me know if it doesn't work but it should. 

Share this post


Link to post
Share on other sites

Sigh.   It's getting to the point where there are so many things like this to do before I can even get started flight simulating it's hardly worth the effort any more. 

 

I have to disable my internet connection so I can disable my antivirus.   But before I can do that i have to use Active Sky Next to get the weather, and log on to my VA.    Then go off line,  disable my antivirus and argue with it  "YES I DO want to disable antivirus!!! now just shut upt!!" 

 

Then plan my flight.    Sometihng to do with this project at last. 

 

Now I have to load FSX, but not EZDOK.    Load a trike into the departure airport.   Disable EZDOK    Make sure the trike's in 2d cockpit.    Load the NGX.    Load the 3D cockpit.    Start FS2Crew.      Enable EZDOK.   

 

All this can be up to half an hour.      Who ever heard of a game that takes that many steps and half an hour to actually get started??

Anyway I'll give it a go and see how it goes.

 

Cheers

MIke Kear

Share this post


Link to post
Share on other sites

Hi Mike,

 

1. Normally you shouldn't need to disable your anti virus.  I use Windows Defender that comes with Windows.

 

Your anti virus should have an option to exclude the FS Folder.

 

 

2. You don't need to actually load the Trike onto the runway.  But the trike should be the default aircraft visible on the Free Flight screen.

 

Saved flight files can cause complex 3rd party addons like the PMDG to not initialize properly.  Even PMDG recommend against them.

 

 

3. EZDOK.  Some people don't have to disable.  Some do.

 

From the time I load Flightsim to the time I can be in the NGX with the FS2Crew Main Panel open ready to go is around 20 seconds depending on the state of my scenery sliders  B)

 

 

If you're still grappling with the SDK warning, send me a support ticket and I'll help you via a remote desktop.

 

 

Cheers,

Share this post


Link to post
Share on other sites

Ok question .... I know its a long time since we last had a discussion about this,  but Its the first time I've been able to get time to look into it .... 

 

How do you disable EZDOK before you load an aircraft?   It seems to me the only way to disable EZDOK is to load an aircraft that has a definition set up for EZDOK,    global disable it,  then load the PMDG  NGX.  

 

Or have I missed something? 

 

Cheers

MIke Kear

Windsdor, NSW, Australia 


Oh well it didnt help anyway.     I loaded the trike to a gate at YSSY,   shut down the engines and the power.   Turned off EZDOK, using the button on my joystick I had configured to global disable EZDOK.  

 

Then I checked that EZDOK was disabled by looking a the menu option .   It said "Global enable"  which would imply EZDOK was properly disabled.  

 

Then I switched to the PMDG NGX B737-800.   It came up in the 2D cockpit with the engines running and EZDOK disabled.    But when I pressed Shift-C to open FS2Crew I still got the SDK ERROR message.  

 

What now? 

 

Cheers

MIke Kear

Windsdor, NSW, Australia 

Share this post


Link to post
Share on other sites

Mike,

 

Try disabling EZDOK entirely to see if it's the cause of your SDK issue.

 

You can probably disable it via the DLL.xml.

Share this post


Link to post
Share on other sites

Ok i finally got it all to work.. . here's what I had to do 

 

1.  Start FSX

2. PIck the trike and load it at the gate on the airport I'm wanting to use as departure point. 

3. Check the trike is in 2d cockpit.  (normally isnt - have to select that manually,  despite having the settings to "load in 2d cockpit")

4.  Disable EZDOK either from button 12 on my joystick or from the add-ons menu.   ( FSX always loads with EZDOK enabled.   Is there a way to change that? ) .

5.  Change aircraft to the PMDG NGX

6.  Change cockpits to 3 VC

7.  Re-enable EZDOK

8.  Start FS2Crew.

 

I'm hoping with more time using the products I can eliminate one or more of these steps because it's a pain in the neck to do all that.   Miss one step and i have to shut down FSX and start all over again.  

 

But at least i have it going!!   Which is progress indeed!  

THank you Bryan.   I can see this is a very complex thing,  specially since you have to work with the limitations of not just one complicated application (PMDG NGX) but also a complex and increasingly obsolete program FSX.    As a programmer myself, I am impressed with what you've been able to pull off here. 

 

Cheers

Mike Kear

Windsor, NSW, Australia. 

Share this post


Link to post
Share on other sites

4.  Disable EZDOK either from button 12 on my joystick or from the add-ons menu.   ( FSX always loads with EZDOK enabled.   Is there a way to change that? ) .

 

Hi Mike,

 

Glad you got it sorted.

 

Some people have to momentarily disable EZDOK, others don't.

 

It funny how computers don't behave the same way all the time.

 

As for your question, I don't know.  You'd want to ask the EZDOK developers.

 

Best,

Share this post


Link to post
Share on other sites

(With P3D), ezdok is automatically start With fsuipc.ini and not exe.XML and so no problem With sdk...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this