Sign in to follow this  
GFD150

Windows 10 and FS2004 Discussion

Does FS9 Working In Windows 10  

9 members have voted

  1. 1. Does FS9 Work In Windows 10?



Recommended Posts

Just A Roll To Get Answers To A Very Much Asked Question. Feel Free To Comment and Discuss But Please Keep It Clean.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

And so does ASE, RC4.3, FSCommander, FSBuild, FSNav, GEPro, PMDG MD11 and most everything else I have.

Share this post


Link to post
Share on other sites

And so does ASE, RC4.3, FSCommander, FSBuild, FSNav, GEPro, PMDG MD11 and most everything else I have.

Active Sky 6.X locking up FS9 in full screen mode when going to Window Mode Alt + Enter.. What GPU are you using, and if it's an NVIDIA what are your graphic settings within the control panel, and are you running full screen, or window???

 

                                          Thanks 

                                             J.R.

Share this post


Link to post
Share on other sites

I think the problem is fixed. I changed one thing in the configuration (random), and restarted the program. Changed the configuration back to what it was...seems like it's working. However Sluggy if you can still pass on your settings...I would greatly appreciate it.

 

                                                       J.R.

Share this post


Link to post
Share on other sites

After two Windows 10 upgrades...went back to my Windows 7 configuration, In my original upgrade all was working until I found out that I didn't have permission to install anything into the addon scenery, or just add scenery to FS9. The problem was fixed after the second upgrade...and that's when i found out that Active Sky wasn't working correctly. Reinstalled the program, and it got more of a fiasco. FS9 works great on Windows 7, I have better frame rates...so going to stay with this until the bitter end of Windows 7 life. 

Thanks to all who gave me help, and I hope I was helpful to anybody on other threads.

 

                                       Take Care/Happy Flying

                                                        J.R.

Share this post


Link to post
Share on other sites

Sorry, here's my hardware and settings :

 

i7-3770K @4.3

GTX980 Strix

Running dual monitors windowed @ 1080p

 

FS9.cfg (relevant bit)

[DISPLAY.Device.NVIDIA GeForce GTX 980.0]
Mode=1920x1080x32
PanelAsTexture=0
TextureAGP=0
TriLinear=1
MipBias=6
 
driver 353.62
 
using NickN's Inspector settings. FS9 is running well at 60 frames locked with dips in heavy clouds (REX)

Share this post


Link to post
Share on other sites

I upgraded one of my Win 7 systems and FS9 doesn't even start.  It asks for permission to make changes to computer, etc., answer yes but nothing happens.  I even renamed the FS9 directory, did a clean install and still nothing.  I tried moving my UAC slider all the way down, but then a different screen popped up saying access denied or something close to that.  So I tried checking the 'Run as Administrator Box' and also the compatibility boxes.  No help.  Does anyone have any ideas on how to get it at least running.

Share this post


Link to post
Share on other sites

If it helps, FS9 is on it's own SSD in my case, and I too have UAC turned all the way down. The only drama I had was for some reason FS9 re-enabled it's joystick (making everything uncontrollable since I use FSUIPC for my controllers), a quick change and all was back to normal.

 

What happens if you rename the FS9.cfg file and let FS9 build a new one? I think Win 10 is even more protective of it's own directories than Win 7, have you tried to install in, say, C;\FS9?

 

Actually, if the UAC change you try is not allowed, it would indicate to me that your user account may not have sufficent priviliges to install new programs. Maybe check your account settings?

 

Cheers, SLuggy

Share this post


Link to post
Share on other sites

Yes...BUT

 

It works, but my Nvidia antialiasing no longer works. I was using NickN's config for Inspector in Win 8.1 with great success. Upgrade to Windows 10, jaggies everywhere. I've reloaded the driver, rolled back drivers, removed NI, reapplied settings, run in compatibility mode, no luck.

 

For those of you running smoothly, any tips?

 

i5 4670k @ stock

GTX 970 - 353.62

8gb RAM

Running off SSD

Share this post


Link to post
Share on other sites

I did have to reset my NI settings, but no problems with AA here. When I have some time this arvo (around 2 or so hours) if you're around, I'll try to work through things with you. Starting to feel like I'm one of the lucky ones here.

 

Cheers, SLuggy

Share this post


Link to post
Share on other sites

I did have to reset my NI settings, but no problems with AA here. When I have some time this arvo (around 2 or so hours) if you're around, I'll try to work through things with you. Starting to feel like I'm one of the lucky ones here.

 

Cheers, SLuggy

Any tips or things I should look for? I updated to the new Nvidia driver, 355.60 hoping that would help, but no luck there either.

 

This is killing me, everything is working fine just crap graphics.

Share this post


Link to post
Share on other sites

I tried installing out of the normal FS9 directory with the same result.  Finally, installed the cd patch and everything came right up.  Went back to my normal install and did the same thing and the only problem I had was that FS9 would load straight into the last airport minimized and could not maximize it.  So I found a setting in the FS9 config file Startup section an option for 'Show_Opening_Screen'.  Changed that to '1' and it starts normally.  Just have a problem running Full Screen mode right now.  Flashes rapidly.  Something to work on later.  But, no permissions required or admin privileges.  All of my other associated programs seem to be working also, TTools, ADE, Abacus EZ Scenery, Instant Object Studio.  The video could be something with my NVidia driver.  I downloaded a new one, but maybe not set up correctly.

Share this post


Link to post
Share on other sites

The problem I think is with the video drivers. NVIDIA only has one current driver for Windows 10: 353.30. Hopefully NVIDIA will fix the problem in future updates.

 

                                                     J.R.

Share this post


Link to post
Share on other sites
These are my NI settings : 

 

Antialiasing

AA - behaviour flags : none

AA - setting : 8xS (combined: 1x2 SS + 4x MS)

 

Texture Filtering

Anisotropic filtering setting : 16x

Texture Filtering - Negative LOD bias : Clamp

Texture filtering - Quality : High Quality

 

I removed all AA using Inspector and FS9 descended into jaggy hell, put it back and FS9 got all pretty again, so my NI is working. Using 1.9.7.3 with the folder on my desktop.

 

Cheers, SLuggy

 

ps - downloading driver 355.60 now.

Share this post


Link to post
Share on other sites

 

These are my NI settings : 
 
Antialiasing
AA - behaviour flags : none
AA - setting : 8xS (combined: 1x2 SS + 4x MS)
 
Texture Filtering
Anisotropic filtering setting : 16x
Texture Filtering - Negative LOD bias : Clamp
Texture filtering - Quality : High Quality
 
I removed all AA using Inspector and FS9 descended into jaggy hell, put it back and FS9 got all pretty again, so my NI is working. Using 1.9.7.3 with the folder on my desktop.
 
Cheers, SLuggy
 
ps - downloading driver 355.60 now.

 

 

Everything works now! Thanks!

Share this post


Link to post
Share on other sites

Sweet, what was the issue in the end? Glad it's working now.

 

Cheers, SLuggy

Share this post


Link to post
Share on other sites

Sweet, what was the issue in the end? Glad it's working now.

 

Cheers, SLuggy

 

I honestly don't know. Everything is working now...preview window, windowed mode, full screen. Glad it's back. I have WAY too much invested into FS9

Share this post


Link to post
Share on other sites

Hi guys,

 

I see three topics in this about fs9 and Win10.

 

What's the deal? Does it work correctly? Can I upgrade safely? Do I have to keep some things in mind before I start the upgrade?

Share this post


Link to post
Share on other sites

No problems here, but as you can see above some people have. Only you can decide whether Win 10 is for you or not. If you're happy with what you've got there's no real reason to change.

 

I was happy with Win 7 but after 6 or so years I was ready for a change plus I wanted DX12. As I am pretty PC savvy (not an expert mind, but more betterer than the average bear  :Tounge: ) I was aware off the potential pitfalls and confident enough that I could work through any problems. Plus I have nightly backups onto a home server in case the apocalypse visits my PC, so I dived straight in.

 

Cheers, SLuggy

Share this post


Link to post
Share on other sites

Thanks.

 

Im not a pro on solving problems but I can find my way in all these years of having fs9 on my desktop. I think I will it try this weekend.

 

Is it difficult to roll it back in case it wont work out?

Share this post


Link to post
Share on other sites

Thanks.

 

Im not a pro on solving problems but I can find my way in all these years of having fs9 on my desktop. I think I will it try this weekend.

 

Is it difficult to roll it back in case it wont work out?

There shouldn't be any problems rolling back to the previous version of Windows. However with that said...you have to do it before the thirty day trial period ends.

 

                                                     J.R.

Share this post


Link to post
Share on other sites

Would love to meet the fellow who voted "no"...

 

16% of posters report that FS9 doesn't work in Windows 10.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this