jetsmell

Hat Track problem

Recommended Posts

I purchased the HatTrack along with their special webcam. I can't get it to work. Are there any videos that shows step by step if I use FaceTracknior of what to download?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

hello I have just done the same,you have got me worried! as i also want to use Face Tracknoir, but there are a few vids on you tube one in particular walks you through all the setup,but not using Face Tracknior,they use the program recommended by track hat,there is a free facetrack website,loads of info and advise try there I have enclosed the link to set up vid and hope this helps you,I intended to build a face track hat but discovered hat track so decided to give it a go,I have used Face Tracknoir without any leds it worked reasonably well,

peter

  http://www.free-track.net/english/

 

Share this post


Link to post
Share on other sites

Go to the trackhat.org website and click on the FAQ page.

 

Download their software Open Track and the videos will show you hot to setup. Only a couple of options required.

Share this post


Link to post
Share on other sites

Go to the trackhat.org website and click on the FAQ page.

 

Download their software Open Track and the videos will show you hot to setup. Only a couple of options required.

I've found that OpenTrack is quite jerky compared to FaceTrackNoIR. If you move your head very slowly, it moves in small jumps. A number of users have reported the same problem. I use a PS3 Eye camera running at 60 FPS.

 

Jet, I had the same problem with no response when I first tried FaceTrackNoIR. There are FSX setup files available to download if you search around. To start from scratch, first, check that you have the latest stable version of FaceTrackNoIR (v170). When you run the program, make sure that you are using PointTracker as the tracker source, SimConnect as the game protocol and Accela as the filter. Open the settings page for PointTracker and make sure that you enable each axis on the General tab. Under the Camera tab, make sure that your camera is detected and the FPS is appropriate for your camera (I set 60 FPS for my PS3 Eye). You may have to adjust the Theshold slider to get just your LEDs appearing without background noise. Open the Model tab and click on the Cap tab. Ensure that the LED spacing corresponds to your hat. Next, click Calibrate and move your head left/right/up/down and rotate your head clockwise/anticlockwise, all whilst keeping you shoulders steady. When the x,y,z readings are reasonably stable, click Caliibrate again to save the settings. Look here for more details - http://ftnoirpt.sourceforge.net. You should now be good to go in FSX. You can fine tune the curves and the smoothing slider to get the response you want. Let me know if you need any more help.

Share this post


Link to post
Share on other sites

Vortex, I have followed your post and set all the settings that you recommended. Still nothing in FSX. I'm using the driver from Code Industries where I paid 2.99, but I'm starting to wonder if that is the problem. Any thoughts ?

Share this post


Link to post
Share on other sites

I have v5.3.0.0341 of the CL-Eye driver. Have you tested your Hat Track with the CL-Eye Test program that was installed with your CL_Eye driver? If you don't see an image, make sure your hat is definitely switched on and go into the Devices menu and check that your camera is ticked. Next, go to the Options menu and make sure Preview is ticked - you should now be able to see the LEDs on your hat. You may need to adjust the Video Capture Filter in the options menu to get the best image. Ideally you're looking for the darkest image with just the LEDs visible. Don't worry if the image is slightly fuzzy, the IR filter has probably been removed to improve LED detection and this often gives a fuzzy image. If you don't get an image, try the camera in a different USB port (try not to use an unpowered hub). If you still have no luck, try reinstalling the driver - the PS3 Eye camera will not work in Windows without the driver. If you get an image but no LEDs, you should check that the Hat Track is working properly. Most smartphone cameras show IR LEDs (iPhones definitely do) so go somewhere fairly dark and check the LEDs show up when viewed through your smartphone camera.

 

If it's all OK but still not working in FSX, you could try my working .ini file that I use with my hat. Download the following file and copy it to the Settings folder of your FaceTrackNoIR installation:

 

https://www.dropbox.com/s/wbd9n93j7nqdbye/FSX_Cap.ini?dl=0

 

Run FaceTrackNoIR and make sure that the tracker is stopped at the bottom of the window. Select FSX_Cap.ini in the Profile box and follow the instructions in my previous post then start the tracker again. You'll need to check that the Model/Cap dimensions match your Hat Track and then re-calibrate it for your setup. Let me know how you get on.

Share this post


Link to post
Share on other sites

I sent an e-mail to the developer of HatTrack. Told him what was going on. Told him I was using FaceTrackNoir and his responce was why in the heck are you using that? That responce took me back since I'm pretty sure that was one of the optoions on his own website. He advised me to un-install that download and that's where I am right now. This is really giving me fits.

Share this post


Link to post
Share on other sites

My webcam has no driver, maybe that is the problem. I do have the CLEye driver from Code Labs. installed on my E Drive which is where all my FSX is installed.

 

When I do the CLEye test it says there is no video capture. How do I put the driver into the webcam ? I'm not too good with files.

 

 

 

 

 

Share this post


Link to post
Share on other sites

I sent an e-mail to the developer of HatTrack. Told him what was going on. Told him I was using FaceTrackNoir and his responce was why in the heck are you using that? That responce took me back since I'm pretty sure that was one of the optoions on his own website. He advised me to un-install that download and that's where I am right now. This is really giving me fits.

The TrackHat is just an LED source so it shouldn't make any difference which tracking software you use it with as long as you can set up the model type and dimensions within the software. I would definitely avoid FreeTrack as it was never very good with FSX (very jittery) and hasn't been updated for several years. OpenTrack seems to work well for some people but I find that the tracking is not very smooth when you move your head very slowly even with the latest version. For me it moves in a series of very small jumps no matter how I try to adjust the settings and filter. For LED tracking, both OpenTrack and FaceTrackNoIR use the same tracking source (PointTracker) and filter (Accela) so if your hat works with one, it should definitely work with the other. I've found that FaceTrackNoIR is easier to set up and, certainly for me, produces much smoother tracking (even with the smoothing slider fully left). I would, personally, recommend it over OpenTrack. However, if you want to experiment, you can have both OpenTrack and FaceTrackNoIR installed at the same time without any conflicts (I have). If you do opt to use OpenTrack, I would use the customised version available from the Track Hat website.

 

My webcam has no driver, maybe that is the problem. I do have the CLEye driver from Code Labs. installed on my E Drive which is where all my FSX is installed.

 

When I do the CLEye test it says there is no video capture. How do I put the driver into the webcam ? I'm not too good with files.

Not sure what you mean when you say that your webcam has no driver - that's what the CL-Eye driver is for. The driver installs to your PC and enables the webcam. I would start by reinstalling the CL Eye driver (make sure that the camera is NOT plugged in during installation). You say that you have it installed on your E drive but I wasn't given an option where to install it - it just installed by default to C:\Program Files (x86)\Code Laboratories\CL-Eye Driver\Driver. Sorry if I'm insulting your intelligence but did you just copy the installation file (the .exe file) on to your E drive or did you double-click it to install the driver? If it's installed correctly it should appear in your Windows Control Panel, Programs and Features list as CL-Eye Driver. There is an installation video here but it seems to be for an older version of the driver installer: https://codelaboratories.com/screencast/cl-eye-driver/.

 

Next, make sure that there are no other cameras connected to your PC and plug the PS3 Eye camera into a USB port. Do you get a blue LED iluminated on the right-hand side of the camera? If not, there's a problem with either the camera or the USB connection (to rule out the USB connection, try it in another USB port). If the blue LED comes on, there's a good chance that the camera is working. Assuming that the blue LED illuminates, go to the Windows Control Panel, Devices & Printers and check that the camera appears in the Devices section - mine shows up as "USB Camera-B4.09.24.1". Make sure that your Track Hat is plugged in to a USB port (try to avoid using a USB hub unless it's powered) or a USB charger and retry the CL-Eye Test program following the instructions in my previous post. Under Options, Video Capture Filter... I have Auto unticked for both Gain, which I set fully left, and Exposure, which I have about 3/4 of the way across to the right - your settings may vary from mine as my hat is home-made. I leave the White Balance set to Auto and the Color Bar unticked. You should see 3 white dots. If you do, close CL-Eye Test and try it with your headtracking software.

 

If you decide to try FaceTrackNoIR again (perhaps with the .ini file from the link in my previous post) you should see 3 red crosses in the Video Widget window (make sure that it's ticked under the View menu). If your room is brightly lit, or in sunshine, you may see more than 3 - go into the PointTracker settings and under the Camera tab, adjust the Point Extraction Threshold until you just see the 3 LEDs. Move your head around to check that they don't disappear near the limits of movement. Calibrate your hat as described in my earlier post. Leave FaceTrackNoIR running when you start FSX and you should be able to fly with head tracking! Let me know if you're still having problems.

Share this post


Link to post
Share on other sites

I downloaded the FSX_Cap.ini.txt and pasted to the settings to FaceTrackNoiR . When I opened FaceTrackNoir I saw  the default ini. and the FSX_Cap.ini.txt was not in the drop down. The camera works, just not in FSX yet.

Share this post


Link to post
Share on other sites

Still not working. I have done all the settings that you recommended. The webcam works. The cap ini. that I copied  then pasted in the settings wasn't able to be pasted directly into the default ini., but it's in the settings. I don't know if that's normal. Either way in the FaceTrackNoir  pop up the default is shown as default ini. still. I went in to the Windows Firewall and excluded the eye cam and FaceTrackNoir.

 This is all mind boggleing to me. I don't know what is left. I have the FaceTrackNoir on my E Drive but not directly in FSX could that be the problem?

Share this post


Link to post
Share on other sites

It shouldn't matter that you have FaceTrackNoIR in a different folder or on a different drive to FSX (that's what I have). The program is not designed just for FSX.

 

If my FSX_Cap.ini file appears as just a list of text, copy it into Notepad and save it as FSX_Cap.ini (make sure that Notepad doesn't add .txt to the end of the file name) - don't paste it into the default.ini file. Just save the complete file into your FaceTrackNoIR/settings folder and then select it from the Profile dropdown when you run FaceTrackNoIR. If you've definitely saved it to the correct folder but it doesn't appear as a Profile option then it's probably got the .txt suffix added (but it may be hidden by Windows). Alternatively, you can click Load from the Profile box and select FSX_Cap.ini that way. The default.ini file is just a generic file which (if I remember correctly) sets FaceTrackNoIR for basic face tracking rather than head tracking with LEDs.

Share this post


Link to post
Share on other sites

Vortex, I finally, finally got it working. It looks like the FSX Cap_ ini. was all I needed. Now I need to get the motion working using the graphs because the view is all over the place. I've been working on this problem for well over a month. Thanks so much again for your help.

Share this post


Link to post
Share on other sites

Great news! Sounds as if you're 3/4 of the way there. A few things can cause the view to jump around. First, run FaceTrackNoIR without FSX and when you start the tracking make sure that you see only 3 red crosses in the video widget box. If you see more than 3, go into the PointTracker Settings, Camera and adjust the threshold slider until you see only the 3 crosses. Whilst you can still see the threshold slider, turn your head about 30 degrees left/right and about 20 degrees up/down and make sure that the 3 red crosses remain visible. If not adjust the threshold slider. Remember that you need to set the dimensions and spacing of the LEDs of your Track Hat on the PointTracker Settings, Model, Cap tab. Once they're set, click on Calibrate and move your head left/right/up/down and rotate your head clockwise/anticlockwise, all whilst keeping you shoulders steady. When the x,y and z readings are reasonably stable, click Caliibrate again to save the settings. Make sure that all three LEDs are still visible at the limits of your head movement - if not, this always causes the view to jump for me.

 

If you've used my .ini file, the centering shortcut key should be Page Down and the start/stop should be Delete. I've mapped these keys to buttons on my joystick to make freezing and centering the view easier. Page Up disables the sideways translation which can be a little distracting at times. In the Curves settings (bottom right of the interface), I've made the Roll curve flat because I don't like having a roll view input - you'll need to adjust it if you want a roll view. If things are still jumping about, look at the curves as you move your head - the curves may need adjusting. Also, try adjusting the smoothing slider to dampen out any jitters.

Share this post


Link to post
Share on other sites

Now my camera is not working. This is unbelievable. I have the cam that I purchased from the TrackHat site. Paid 2.99 for the driver at Code Labs. The blue light is always on on the right side of the cam. Run I run the test or TrackHat Noir, then the red light comes on, but just a black screen.

Share this post


Link to post
Share on other sites

Everything is working. I'll follow your advice on the motions. You have been very very helpfull. Thank you so much.

Share this post


Link to post
Share on other sites

Now I find it works part of the time. When it does work it will last for about ten minutes then shut down.Other times it won't work at all.

Share this post


Link to post
Share on other sites

When it stops, can you still see the 3 red crosses moving about in the video widget in FaceTrackNoIR? If so, it might be a Simconnect problem.

 

Also, if you normally plug your Track Hat into a USB port, it might be worth plugging it into a USB charger to make sure that the LEDs are getting plenty of power. I can't think of any other reason for it to suddenly stop after working for a while.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now