Sign in to follow this  
bbuckley

Saitek Pro Flight Yoke disconnects with PilotEdge Client FSUIPC4

Recommended Posts

I've just started encountering a problem and I don't know what initiated it.  When I fly FSX SP1&2 on my high end PC (4790K) with the Carenado Phenom 100 and registered FSUIPC4, everything is fine until I connect to the PilotEdge client, then when I go back to FSX the Saitek Pro yoke & throttle are disconnected.  If I fly the Carenado Archer under the identical conditions and start the PE client and go back everything is fine.  I tried setting the JoystickTimeout=5000 in FSUIPC4.ini thinking the Phenom model took longer and it was timing out but no joy.  I'm not using the Saitek profiler or drivers, just the windows drivers and FSUIPC for some button assignments (PTT).  Here is my FSUIPC.ini.
Any help appreciated.  I've also posted in the PE forum in case it's a client issue.
Bruce

[General]
UpdatedByVersion=4853
History=4FJX4PTSL1MFDSBBYVPAQ
InitDelayDevicesToo=No
MouseWheelMove=No
MouseWheelTrim=No
MouseWheelTrimSpeed=1
JoystickTimeout=5000
PollGFTQ6=Yes
BlankDisplays=No
FixControlAccel=No
FixMachSpeedBug=No
DeleteVehiclesForAES=Yes
AutoScanDevices=Yes
VisibilityOptions=No
OneCloudLayer=No
CloudTurbulence=No
CloudIcing=No
GenerateCirrus=No
SuppressCloudTurbulence=No
MaxIce=-4
MinIce=-4
UpperWindGusts=No
SuppressWindTurbulence=No
SuppressWindVariance=No
WindTurbulence=No
TurbulenceRate=1.0,5.0
TurbulenceDivisor=20,20,40,40
SuppressAllGusts=No
MaxSurfaceWind=0
WindLimitLevel=200
WindDiscardLevel=400
WindAjustAltitude=No
WindAjustAltitudeBy=2000
SmoothBySimTime=No
WindSmoothing=No
WindSmoothness=2
WindSmoothAirborneOnly=Yes
PressureSmoothness=0
TemperatureSmoothness=0
DisconnTrimForAP=No
ZeroElevForAPAlt=No
ThrottleSyncAll=No
WhiteMessages=No
ShowPMcontrols=No
SpoilerIncrement=512
MagicBattery=No
RudderSpikeRemoval=No
ElevatorSpikeRemoval=No
AileronSpikeRemoval=No
ReversedElevatorTrim=No
ClockSync=Yes
ClockSyncMins=5
ClearWeatherDynamics=No
OwnWeatherChanges=No
TimeForSelect=4
LoadFlightMenu=No
LoadPlanMenu=No
PauseAfterCrash=No
BrakeReleaseThreshold=75
SaveDataWithFlights=No
ZapSound=firework
ShortAircraftNameOk=No
UseProfiles=Yes
EnableMouseLook=No
AxesWrongRange=No
TCASid=Flight
TCASrange=40
AxisCalibration=No
DirectAxesToCalibs=No
ShowMultilineWindow=Yes
SuppressSingleline=No
SuppressMultilineFS=No
AxisIntercepts=No
DontResetAxes=No
InitDelay=0
GetNearestAirports=Yes
OOMcheck=Yes
WeatherReadFactor=2
WeatherRewriteSeconds=1
CustomWeatherModify=No
SimConnectStallTime=1
LuaRerunDelay=66
Console=No
FSVersionUsed="Microsoft Flight Simulator X",10.0.61472.0
SimConnectUsed=10.0.61259.0

[JoyNames]
AutoAssignLetters=No
0=Saitek Pro Flight Yoke
0.GUID={23B97E30-1B54-11E5-8001-444553540000}

[buttons]
ButtonRepeat=20,10
1=R0,3,C65615,0
2=R0,2,C65607,0
3=P0,0,C1001,0
4=P0,14,C66237,0
5=P0,15,C66237,0
6=P0,16,C66059,0
7=P0,17,C66060,0
8=U0,0,C1002,0
9=R0,1,C65588,0

[AutoSave]
Next=1
Interval=60
Files=10
SaveOnGround=No
AutoSaveEnabled=No

[GPSout]
GPSoutEnabled=No
Port=COM1
Speed=4800
Interval=2000
PosTo6Decimal=No
SimModeIndicator=No
Sentences=RMC,GGA,GSA

[GPSout2]
GPSoutEnabled=No
Port=<none set>
Speed=4800
Interval=2000
PosTo6Decimal=No
SimModeIndicator=No
Sentences=

[WideServer]
WideFSenabled=Yes
AdvertiseService=1
Port=8002
Port2=9002

[sounds]
Path=C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Sound\
Device1=Primary Sound Driver
Device2=Speakers (Realtek High Definition Audio)
Device3=Realtek Digital Output (Realtek High Definition Audio)

[JoystickCalibration]
AllowSuppressForPFCquad=Yes
ExcludeThrottleSet=Yes
ExcludeMixtureSet=Yes
ExcludePropPitchSet=Yes
SepRevsJetsOnly=No
ApplyHeloTrim=No
UseAxisControlsForNRZ=No
FlapsSetControl=0
FlapDetents=No
ReverserControl=66292
Reverser1Control=66422
Reverser2Control=66425
Reverser3Control=66428
Reverser4Control=66431
MaxThrottleForReverser=256
AileronTrimControl=66731
RudderTrimControl=66732
CowlFlaps1Control=66162
CowlFlaps2Control=66163
CowlFlaps3Control=66164
CowlFlaps4Control=66165
SteeringTillerControl=0
MaxSteerSpeed=60
Aileron=-16383,0,512,16383
Elevator=-16383,0,512,16383
Throttle=-16256,16256
Mixture=-16256,16256

[LuaFiles]
1=ipcinit


Sorry if this should be in the controller subforum...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this