Sign in to follow this  
WebMaximus

Not asked for product verification in P3Dv3.1

Recommended Posts

Just installed the NGX in a clean P3Dv3.1 installation but I was never asked for the product activation key like you normally are when you first load the NGX and also this is what the panel looks like so clearly something went wrong during the installation.

 

Any idea what could cause this and how to fix it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Did you install the simconnect files after installing 3.1? Those need to be installed for PMDG to register properly.

 

It should be in the read me from PMDG where those files are to install.

Share this post


Link to post
Share on other sites

Nope, I didn't and just tried installing the SimConnect found under P3D\Redist but still no joy. Guess I'll just start all over again and reinstall both the NGX and P3Dv3.1.

Share this post


Link to post
Share on other sites

Normal, an update to P3D does not necessarily mean you are going to have to activate the product. In fact, after reinstalling P3D from scratch the PMDG authentication will be retained.  The black displays sure do point to the simconnects as an issue.

 

I don't thing reinstalling twenty times is going to solve this problem. Try support.precisionmanuals.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this