Sign in to follow this  
rlashier

All Dark When Loading Aircraft in FSX

Recommended Posts

I have been running the FSX boxed/Acceleration version on Windows 7 (64 bit) without issues until today.  My rig is built with the i7- 4790K processor, with an Nvidia GTX 770 video card by EVGA.  Windows and FSX are installed on separate SSDs.  I used the AVSIM Configuration Guide and Nick Needham's Bible to set up and configure FSX and the FSX.cfg file, and NVInspector to adjust the video driver settings.  I run GEX and UTX and ORBX PNW regional scenery.  Until today, the performance and display quality was flawless.

 

The most recent change to my setup, other than the standard Windows updates, was the installation of a new aircraft, the Beechcraft Bonanza F33A from Carenado.  I installed this aircraft to follow along with the Aviator Pro video pilot training from Angle of Attack, as this is the aircraft used in their training episodes.

 

When I start FSX, I can access all the regular program menus and features, up to loading a flight (selecting aircraft, time of day/season, airport).  However, the preview screen is black when I select an aircraft, and when I click on Fly Now, the full screen becomes pitch black.  I can hear the engines running, and I can rev the engine with my throttle, etc., so the software is running, but without any aircraft display at all.

 

To troubleshoot this, I tried an uninstall of the Carenado aircraft.  With no improvement, I tried a system restore to a restore point prior to the aircraft's installation.  No luck.  I further allowed FSX to rebuild by FSX.cfg file.  When these efforts produced no result, I reinstalled my display driver, reset Nvida Inspector settings, and also downloaded and reinstalled the Direct X 9.0c runtime, since it seemed as though we have a graphics issue.  So far, no luck with any of these attempts, and my screen is still pitch dark when I try to load any flight. 

 

Any suggestions for a fix for this?

 

Many thanks,

Rich LaShier

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Go to your FSX settings and make sure DX10 Preview is checked.

 

Whenever you rebuild your fsx.cfg, make sure you placed the following parameter into the graphics section:  highmemfix=1.

 

Best regards,

Share this post


Link to post
Share on other sites

Jim,

Thanks for the tip.  Unfortunately, I can not get the DX 10 preview checkbox to appear among my graphics settings, even after changing the entry in the fsx.cfg file to D310=1.  Whether this item is set to 0 or 1, there is no DX10 preview box in my graphics settings in FSX.  This is odd, as the program entries clearly show that it is Microsoft FSX:Acceleration that is installed, and that should have included the SP2 content that included the quasi DX10 content. 

 

The Nvidia drivers are properly installed for the GTX 770 card, and running Dxdiag, it shows that Direct X has been updated to  DX 11, which is running on the Windows 7, 64 bit platform.

 

I have seen others that have had this issue have reported that the checking the DX 10 preview box indeed provides the fix.  But what do you do when you can't get the check box to appear?

 

Still in a quandary on this one!

 

Rich

Share this post


Link to post
Share on other sites

Unless there is an epiphany on this Epiphany Sunday, looks like a reinstall of FSX and add-ons is in my future.  Talk about drudgery!

 

Rich

Share this post


Link to post
Share on other sites

All was well with me (Win7) until I installed Win10 and then I had the same problem with "Fly Now" and "End Flight", a black screen. Everything else works normally (Settings, and flying). those screens will appear if I use DX10 preview, but my computer can't quite handle that, or if I use Control-Alt-Delete and pick Task Manager it will appear briefly and then disappear. As long as I can still fly it is more of and annoyance than a problem but it would be nice if it could be figured out.

Share this post


Link to post
Share on other sites

 

 


Unfortunately, I can not get the DX 10 preview checkbox to appear among my graphics settings, even after changing the entry in the fsx.cfg file to D310=1.

 

DX10 Preview only shows up if you have FSX SP2 or Acceleration installed.  It will not work with the basic FSX or with SP1 installed.

 

Best regards,

Share this post


Link to post
Share on other sites

Jim,

That is why this issue is so frustrating.  I have Acceleration installed, so the service packs with DX10 were included in that installation.  The installation shows up as FSX/Acceleration when I start it, and the aircraft unique to Acceleration appear in my hangar as available to load, so there is no question that Acceleration is installed.  I have a video card that is more than competent to handle Directx 10 or 11, and I have installed the most recent Nvidia Windows 7 drivers for it using the Nvidia installer.  I have installed (and recently reinstalled) the current DirectX drivers from Microsoft, and the dxdiag tool shows that I have Directx 11 installed.  The FSX.cfg file has the D3D10=1 line included under the graphics tab. 

 

Are there driver settings in Nvidia Inspector that might prevent the DX10 preview from appearing?  I tried reverting to the Nvidia Control panel, and restored default settings to remove the Nvidia Inspector settings from the picture, but there was no change. 

 

I have looked at numerous posts that deal with this black screen issue, and the "fix" of ticking the DX10 preview box in the Graphics settings, and my system as installed and configured should be offering be the DX10 preview option to check, but for whatever reason, it will not.  And without that, I am at a loss how to restore my display during flights, and get beyond the current black screen.

 

Maybe it's time to move to Prepar3d!

 

Rich

Share this post


Link to post
Share on other sites

cant  see  how  it  would  disappear  the option to check,  you  sure  your looking in the right  area in fsx  " display settings"

Share this post


Link to post
Share on other sites

Are there driver settings in Nvidia Inspector that might prevent the DX10 preview from appearing? I tried reverting to the Nvidia Control panel, and restored default settings to remove the Nvidia Inspector settings from the picture, but there was no change.  I have looked at numerous posts that deal with this black screen issue, and the "fix" of ticking the DX10 preview box in the Graphics settings, and my system as installed and configured should be offering be the DX10 preview option to check, but for whatever reason, it will not.  And without that, I am at a loss how to restore my display during flights, and get beyond the current black screen.

 

Based on your comments you have DX10 Preview and you have properly enabled it on the Graphics page of the FSX settings.  In post #3 above, you indicated you could not see the DX10 Preview setting in FSX and you were fiddling with the DX10 entry in the fsx.cfg which should not have showed up if you could not see the DX10 Preview box.  Now you are stating you can see the DX10 Preview box in the Graphics tab.  This is all very confusing and contradicting.

 

So, now that you can "see" the DX10 Preview box, what happens if you disable it and run FSX in DX9?  If that is okay and you are seeing the black textures with DX10 Preview enabled, then the textures you have installed for your scenario are not DX10 compliant and will be black or they will be invisible.  There's an addon you can get for around $20 that will convert your DX9 or DX8 textures to be compliant with DX10 Preview textures - http://www.flightsimtools.com/adconvx/. It does not permanently change the textures, just during the session. They have a demo you can try to see if it works for your situation.

 

DX10 is a preview of DX10.  Even if you have a DX11 or DX12 compatible video card, FSX will only display DX10 preview.  SteveP, the developer of the DX10 Fixer did an excellent job making DX10 better for FSX and got rid of most of the shimmering on taxiways, etc., but it still is not perfect.  I would never use FSX without it enabled though as it provides better performance for me. 

 

If you have SweetFX or the ENBSeries modifications, then this is likely the problem, not DX10 Preview.  Very, very few people have gotten these graphics hacks to work properly in DX10 Preview Mode.  I doubt you are using these hacks but mentioning them just in case.  These hacks put an initiator file, like enb.ini in your main fsx directory and they are loaded every time you start FSX causing anomalies.  Maybe you had tried one of them, couldn't make it work and then tried to remove the hack and you didn't get rid of all of the files.  The AVSIM CTD Guide provides a list of all the files this hack installs and how to get rid of all of the files.

 

P3D is capable of DX11 graphics and one of the pluses for purchasing this product.

 

Best regards,

Share this post


Link to post
Share on other sites

Jim,

To be clear, I am not seeing the DX10 preview box in the FSX graphics setting page.  I was only attempting to set the D3D10 line in the fsx.cfg to D3D10=1 on the chance that this would then enable the DX10 preview box, so that I might check it, and so that this might fix the dark screen issue I get when I try to load any flights or even view the flight preview screen.  There is no contradiction here; I have indicated consistently that I continue to experience the black screen for all flights (other than missions), and that I can not even get the DirectX 10 preview checkbox to appear so that I might activate it.  I have no particular interest in running DirectX 10, I am only trying to activate it because others who have posted with this black screen issue were able to work around it by checking the preview box.  No such luck here.

 

Thanks,

Rich

Share this post


Link to post
Share on other sites

 

 


To be clear, I am not seeing the DX10 preview box in the FSX graphics setting page. I was only attempting to set the D3D10 line in the fsx.cfg to D3D10=1 on the chance that this would then enable the DX10 preview box,

 

Then you need to do a repair and reinstall Acceleration as it definitely is not installed.  Just insert the Acceleration disk and, when prompted, click on repair.  The repair will not mess up your FSX.cfg or scenery.cfg.  Even if you reinstalled Acceleration it would not mess with those files.  With Acceleration you will get DX10 Preview but it will not be enabled when you start up your sim. 

 

Best regards,

Share this post


Link to post
Share on other sites

Happy to report that the issue is resolved.  It had become clear that the problem was either a corrupted install of Acceleration, or a video driver issue.  I tried the repair reinstall of Acceleration, and at least initially, I was still experiencing the black screen on loading flights.  I then checked the Nvidia display drivers, even though I had already reinstalled the display drivers after I first encountered the black screens.  So, last night, I attempted again a "clean install" of the latest and greatest Nvidia display driver, but found that the driver install was aborting midstream, and concluded with a "failed" status for the install of the display driver.  After some additional effort aimed at fully uninstalling all driver components, I was able to get the clean install to actually accomplish a clean install. 

 

Fired up FSX, and behold, and we again have flyable aircraft in both the full screen and preview screen displays.  And there under the graphics settings page in FSX, there is indeed a check box for DX 10 preview.

 

It looks like the video drivers became corrupted, and despite NVidia's best efforts to provide an installer that removes prior driver remnants and then performs a clean install, it does not always work as advertised.  It may be best to do a complete driver uninstall first, rather than relying on the Nvidia installer to do it for you.

 

Thanks for everyone's help with this,

Rich

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this