Sign in to follow this  
ideoplastic

P3D v3.1 black screen and freeze

Recommended Posts

Have installed P3D v3.1 after previously uninstalling all PMDG products and P3D v3. P3D is working Ok but when trying to load either the B737 or B777 it results in a black screen and P3D freezes. The installation files are the latest which I downloaded from PMDG site. Grateful for any feedback.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I also got this.

 

7 hour flight and I was on climb out putting in leg page winds.

 

Every gauge froze so I saved and restarted.

On reload everything was black and the yoke was full left.

Share this post


Link to post
Share on other sites

The installation is brand new with nothing added except for the PMDG B737 and B777 aircraft. I haven't even been able to see the VC or anything else, except for a black screen. I can see the aircraft model in the selectiion screen but that's it.

Share this post


Link to post
Share on other sites

The installation is brand new with nothing added except for the PMDG B737 and B777 aircraft. I haven't even been able to see the VC or anything else, except for a black screen. I can see the aircraft model in the selectiion screen but that's it.

 

Can you describe your process of loading the simulator?

Share this post


Link to post
Share on other sites

In the same manner as usual. Run as admin, get to the selection page, select aircraft B737-800 and go fly. Has always worked fine like this in FSX and P3D with no issues.

At no point was I asked for a serial.

 

Thanks

Share this post


Link to post
Share on other sites

 

 


In the same manner as usual. Run as admin, get to the selection page, select aircraft B737-800 and go fly. Has always worked fine like this in FSX and P3D with no issues.

 

"Get to the selection page."

 

Does this mean that the sim loads directly to this, or you have to navigate to it?

 

 

 


At no point was I asked for a serial.

 

Is this a new computer, new hardware, or a new OS install?

Share this post


Link to post
Share on other sites

PC has win7 64 bit install. It had P3D v3 installed with the PMDG aircraft and others. On return from Xmas break I decided to install P3D v3.1 and proceeded to uninstall all PMDG aircraft via the Control Panel/Programs followed by P3D version in the manner advised by LM including the P3D respective folders in AppData/Roaming - AppData Local - Program Data and Document folders. After deleting all temp files and reboot installed P3D v3.1, the page for selecting, scenery and time of day, etc., comes up when the sim is started. Tested P3D and it worked OK so installed the 737 series followed by the 777 series. Rebooted but when selecting any of the PMDG aircraft it takes me to a black screen devoid of sound and the sim freezes.

I also installed the simconnect FSX SP" version.

 

Perhaps I will need to wipe the OS and do a complete and clean reinstall of OS, P3D and PMDG if this cannot be resolved any other way.

 

Thank you Kyle.

Share this post


Link to post
Share on other sites

 

 


PC has win7 64 bit install. It had P3D v3 installed with the PMDG aircraft and others. On return from Xmas break I decided to install P3D v3.1 and proceeded to uninstall all PMDG aircraft via the Control Panel/Programs followed by P3D version in the manner advised by LM including the P3D respective folders in AppData/Roaming - AppData Local - Program Data and Document folders.

 

Unless you change computers, change hardware, or reinstall your OS, you won't have to reactivate. The license is still on your system.

 

 

 


After deleting all temp files and reboot installed P3D v3.1, the page for selecting, scenery and time of day, etc., comes up when the sim is started. Tested P3D and it worked OK so installed the 737 series followed by the 777 series. Rebooted but when selecting any of the PMDG aircraft it takes me to a black screen devoid of sound and the sim freezes.
I also installed the simconnect FSX SP" version.

 

ALL of the SimConnects mentioned by the readme file that comes with the installer need to be installed.

 

 

 


Perhaps I will need to wipe the OS and do a complete and clean reinstall of OS, P3D and PMDG if this cannot be resolved any other way.

 

This would be a case where you'd want to return the license, and you will be prompted to reactivate on the other side of the install. If you can't release the license, don't worry. Unless you've tried to activate more than a few times, you'll likely have extra activations. Try to activate. If you receive an error, submit a ticket.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this