Sign in to follow this  
olspsd08

P3D update v3.1

Recommended Posts

Good day, just wanted to know how to update P3D to v3.1 without having to re-download and reinstall the addons. Is there a certain way to update or install a certain part for v3.1? Thank you.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Good day, just wanted to know how to update P3D to v3.1 without having to re-download and reinstall the addons. Is there a certain way to update or install a certain part for v3.1? Thank you.

Hello Olisa, sorry, but all P3Dv3.1 addons must have updated installers from the vendor for things to work correctly. So you must re-download and  reinstall.

Share this post


Link to post

Olisa,

 

What version of P3D are you currently running? If v3, the upgrade won't touch your addon content. Pls reply and we'll go from there.

Share this post


Link to post

I am using V3.1 file 3.1.2.15831. I only just switched from FSX to P3D a few months ago. I downloaded the Professional Client like it said on the LM P3D website. Now i am able to start but it crashes on me in seconds. The vehicle area with the default F-22 is black and i am not able to click on anything. I have restarted, done the AV exclusion, updated WIN 7 Home Prem. My PC specs are:

 

27" HP Z1 All-in-one 2TB SSD, GTX 980M, 32GB Mem. IntelR XenonR CPU E3 1245 V2 @3.40Ghz Windows 7 Home Premium 64Bit


"Updating Prepar3D v3 When minor updates are released for Prepar3D v3, there are now two options available to update Prepar3D v3. The recommended method is simply updating using the Client installer. This is the quickest and least error prone. You can also update by doing a complete uninstall and reinstall of the entire application, but often that is not necessary or desired"

 

That's basically what i did.

Share this post


Link to post

Obvious question, but did you uninstall the 3.0 client first? When I upgraded, I uninstalled client, content and scenery. Then did a full reinstall. All addons except FTX Global and REX were intact; they live in the texture folder. Ive never had update/upgrade issues...just lucky.

 

Did you delete your shader cache? That will sometimes create issues. Beyond that, this will require better minds than mine. I'd suggest other things, but I'd just be fishing. Sorry I can't be of more help.

 

If this thread doesn't solve it, a trip to the official Prepar3D forum might be your next step.

Share this post


Link to post

I uninstalled Client first, then installed the new Client. Basically what i did last night was remove the old full version of P3D V3.0 and install v3.1 and it works. I am now adding PMDG, Aerosoft and a few other airports and i should be ok. I did delete the Shader files as per LM forum but it didnt help so i just did a fresh install. Thanks for your help and have a good week.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this