Sign in to follow this  
C130FE

FSX Problem

Recommended Posts

I just installed FSX on my new computer and everything was working great until all of a sudden I cannot get any

aircraft to accelerate to take off speed.  Just extremely slow, if I take off there is not enough power and they

stall.  This just popped up out of nowhere.  I have tried everything I can think of and nothing works.  Can anyone

help me??

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just installed FSX on my new computer and everything was working great until all of a sudden I cannot get any

aircraft to accelerate to take off speed.  Just extremely slow, if I take off there is not enough power and they

stall.  This just popped up out of nowhere.  I have tried everything I can think of and nothing works.  Can anyone

help me??

What are you using for a throttle? Sounds to me that it is a hardware problem, try accelerating with keyboard only.

Share this post


Link to post
Share on other sites

Calibrated joystick done everything I could think of and just before I was gonna hang it up for the night I decided to just for the heck of it, unplug the joystick and plug it back in and reboot.  It worked for some crazy reason.  I'll take it though.  Been seeing some wierd things.  Thinking its Windows 10 problem.  Thanks for the help guys.

Share this post


Link to post
Share on other sites

Since it's all plugged into USB, make sure you have the latest Windows 10 compatible chipset drivers for your computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this