Sign in to follow this  
martinlest2

Strange noise from my PC

Recommended Posts

My PC runs Windows 7 x64 and is basically an Asus H97I+ M/b, I7-4790K CPU & GTX970 GPU. There are two SSDs for hard drives...

 

Whenever I am running FS9 I get a strange, high-pitched 'chirping' noise from what should be a silent PC, fans apart. After Googling I kind of decided it was coil whine from the GPU:

 

http://www.pcper.com/news/Graphics-Cards/GeForce-GTX-970-Coil-Whine-Concerns

 

but having opened up the case and listened more closely (literally) the noise seems to be coming more from the CPU. If so, what could it be? Pretty sure it's not mechanical (i.e. fans).

 

Oddly, as I say, I don't get the noise other than when I run FS. I tried stress testing the CPU with Intel Burn and the GPU with this:

 

https://unigine.com/products/benchmarks/valley/

 

..also copied large files from one SSD to another. None of which caused any noise at all. It's only when running FS9 (haven't tried FSX). Makes no sense to me.

 

Recording of the noise is here:


https://mega.nz/#!rgRxWY6J!kvSfOr6tfAIanzkXkqZzshTU7iTooTjxfXt-LXdkAdQ

Any ideas??

Thanks!
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

but having opened up the case and listened more closely (literally) the noise seems to be coming more from the CPU. If so, what could it be? Pretty sure it's not mechanical (i.e. fans).

 

Oddly, as I say, I don't get the noise other than when I run FS. I tried stress testing the CPU with Intel Burn and the GPU with this:

 

 

 

Regarding you fans, I'm sure you've done the logical thing and stopped each one to test. If it's coming from the region of the CPU, then perhaps the CPU fan. Perhaps only apparent at higher CPU fan RPM, for example when FS9 is active. I've used the finger test before. With care... stopping each fan with pressure from a finger in the middle of the hub. Not too long, just enough for a brief stop. we don't want to be stopping our CPU's fans for an extended period for obvious reasons of course.

 

 

Fan bearings worn is a common one.

 

Some kind of coil whine, maybe.

 

If not the above, then it's interesting that the only time it occurs is in FS9. Which  points to a software issue rather than hardware. Are you sure it's coming from the enclosure rather than your speakers?

 

Is it perhaps coming from the mini post speaker?

Share this post


Link to post
Share on other sites

Definitely from the PC, not the speakers, and it's not the fans (I did stop them briefly with a finger: it's an electronic noise not mechanical in any case).

 

Thanks.

Share this post


Link to post
Share on other sites

<p>Well, I tried the steps outlined by one of the posters there, viz:</p>

<p> </p>

<p><em>Could be power management issue - try this - works a treat<br />

<br />

1. Execute: "regedit"<br />

2 .Locate: HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Power \ PowerSettings \ 54533251-82be-4824-96c1-47b60b¬740d00 \ 5d76a2ca-e8c0-402f-a133-215849¬2d58ad<br />

3. Change Attributes from 1 to 0.<br />

4. Then, through the control panel - power - in the settings mode select power management processor. There will be an option disabling idle processor and high pitched noise immediately disappears.</em></p>

<p> </p>

<p>and the noise has completely gone! I've only been testing with FS9 for 10 minutes or so, but there is no high-pitched chirping at all now, and before I ran this 'tweak' I always had it start up immediately FS9 opened, so I am cautiously optimistic this is a cure rather than a flash in the pan!</p>

<p> </p>

<p>The thread over there is closed so I can't thank the poster directly, but thank you for posting the link. You've made my day <img class="bbc_emoticon" src="http://www.avsim.com/public/style_emoticons/default/smile.png" title=":smile:" /> Fingers crossed that this is the end of the problem. (I hardly dare click on the 'Post' button for fear of jinxing it! You know how the fates work!!)</p>

<p> </p>

<p>Martin</p>

<p> </p>

<p><u>LATER</u>: Been flying for a couple of hours, still no chirping noises. Sweet!!!</p>

Share this post


Link to post
Share on other sites

CLEANED UP VERSION OF THE ABOVE (THOUGHT AVSIM HAD SOLVED THIS ISSUE).

 

Well, I tried the steps outlined by one of the posters there, viz:

 

Could be power management issue - try this - works a treat

 

1.  Execute regedit

2 . Locate: HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Power \ PowerSettings \ 54533251-82be-4824-96c1-47b60b¬740d00 \ 5d76a2ca-e8c0-402f-a133-215849¬2d58ad

3. Change Attributes from 1 to 0.

4. Then, through the control panel - power - in the settings mode select power management processor. There will be an option disabling idle processor and high pitched noise immediately disappears.

 

and the noise has completely gone! I've only been testing with FS9 for 10 minutes or so, but there is no high-pitched chirping at all now, and before I ran this 'tweak' I always had it start up immediately FS9 opened, so I am cautiously optimistic this is a cure rather than a flash in the pan!

 

The thread over there is closed so I can't thank the poster directly, but thank you for posting the link. You've made my day :smile:  Fingers crossed that this is the end of the problem. (I hardly dare click on the 'Post' button for fear of jinxing it! You know how the fates work!!)

 

Martin

 

LATER: Been flying for a couple of hours, still no chirping noises. Sweet!!!

Share this post


Link to post
Share on other sites

Wow, that is a very strange noise issue and even stranger fix. Interesting.

Share this post


Link to post
Share on other sites

CLEANED UP VERSION OF THE ABOVE (THOUGHT AVSIM HAD SOLVED THIS ISSUE).

 

Well, I tried the steps outlined by one of the posters there, viz:

 

Could be power management issue - try this - works a treat

 

1.  Execute regedit

2 . Locate: HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Power \ PowerSettings \ 54533251-82be-4824-96c1-47b60b¬740d00 \ 5d76a2ca-e8c0-402f-a133-215849¬2d58ad

3. Change Attributes from 1 to 0.

4. Then, through the control panel - power - in the settings mode select power management processor. There will be an option disabling idle processor and high pitched noise immediately disappears.

 

and the noise has completely gone! I've only been testing with FS9 for 10 minutes or so, but there is no high-pitched chirping at all now, and before I ran this 'tweak' I always had it start up immediately FS9 opened, so I am cautiously optimistic this is a cure rather than a flash in the pan!

 

The thread over there is closed so I can't thank the poster directly, but thank you for posting the link. You've made my day :smile:  Fingers crossed that this is the end of the problem. (I hardly dare click on the 'Post' button for fear of jinxing it! You know how the fates work!!)

 

Martin

 

LATER: Been flying for a couple of hours, still no chirping noises. Sweet!!!

 

 

That's fantastic news Martin.  :wink:

Share this post


Link to post
Share on other sites

From your thread...

 

(When MSFS is running, I get core temps between 45 degrees C & 70 degs (usually around 55). Adding 15 degs to those temperatures is not really acceptable.

 

 

 

This is important Martin... How are you measuring that temperature?  I ask because there is a difference between "CPU temp" and "core temp". CPU temp is measured from a sensor just under the centre of the IHS. Core temp on the other hand is measured from several sensors embedded in each core, in the CPU die itself. Core temperature will be higher therefore than CPU temperature, so it's important to know what you are measuring that with.

 

Use RealTemp or Core Temp!

 

 

If "core temperature"... 55 degrees under load is not very warm Martin. It isn't an issue you know. An occasional peak to 70 isn't an issue either. Your CPU doesn't hit TJ Max till around 100 degrees. 

 

As for your question regarding C-States... CPU's have several power modes, they are collectively called C-States. They are low power modes. The normal operating mode with no power saving is labelled "CO". The max power saving mode is something like C6 I recall. C-States works by shutting off the clock signal and power from idle units.

 

There was an issue with the introduction of Haswell, some power supplies were having trouble waking from a deep low power C-Sate. Thus, why for Haswell and newer platforms you need a Haswell certified PSU that can wake up from a low power state. I presume you have a Haswell certified PSU? If so, no issue there with C-States on.

 

The disadvantage in completely disabling C-States is that you will use a bit more power, as the clock signal and power to idle units won't be shut off when not under laod. Not a huge deal, many overclockers deliberately disable C-Sates believing they get better stability at higher overclocks.

 

Not sure of this but I presume  you won't be able to use "sleep" or "hibernate" as they are both low power modes and C-Sates is off.

 

With SpeedStep still on though, your CPU should still throttle back to a lower frequency and voltage when not under load. easy to test by comparing frequency and voltage with CPUZ at idle and under load.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the reply.

 

I am measuring core temperatures, using Core Temp, (whose data is transmitted to the All CPU desktop utility). No, 55-70 degrees is OK with FS running, but what I was saying is that by disabling Processor Idle, as I originally did, average temperatures under load are 70-85 degrees, which is a bit too warm for my liking. Disabling the C states in the BIOS gets rid of the CPU noise but means I can have the Processor Idle enabled.

 

My PSU is a "CORSAIR 650W CS SERIES MODULAR 80 PLUS GOLD", which is Haswell certified. I have no problems with standby, it all works as before (I don't use hibernation though).

 

Yes, I read in my 'research' that the C states are often disabled by overclockers. I don't o/c my CPU, but whatever.. I can look at CPU-Z to see voltages (haven't done that yet) but for the moment I seem to have settings that I shall keep - BIOS: C states disabled; Speedstep On, Power Options: Processor Idle enabled. No noise and no temperature increase in the cores. Hope it stays that way!

 

Thanks again.

Share this post


Link to post
Share on other sites
No, 55-70 degrees is OK with FS running, but what I was saying is that by disabling Processor Idle, as I originally did, average temperatures under load are 70-85 degrees, which is a bit too warm for my liking. Disabling the C states in the BIOS gets rid of the CPU noise but means I can have the Processor Idle enabled.

 

 

Oh right, got you, that certainly is high for a CPU that's not overclocked.

 

Hope it all stays to your liking.  :smile:

Share this post


Link to post
Share on other sites

Thanks! (Flying FS now, pretty much max settings - core temps around 55 -60 degs and no CPU noise)...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this