Sign in to follow this  
Demious

ESP Simconnect client missing

Recommended Posts

I just had a look at my programs and features list and I saw that there is no ESP Simconnect client listed. Normaly it's there after P3D installation and I think to remember I've seen it in the list before, but now it's not there anymore.

I tried repairing P3D, I tried reinstalling P3D, but still no ESP Simconnect.

 

Can someone help me out by explaining how to (re)install ESP Simconnect Client, please?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I just had a look at my programs and features list and I saw that there is no ESP Simconnect client listed. Normaly it's there after P3D installation and I think to remember I've seen it in the list before, but now it's not there anymore.

I tried repairing P3D, I tried reinstalling P3D, but still no ESP Simconnect.

 

Can someone help me out by explaining how to (re)install ESP Simconnect Client, please?

 

I think that was only ever installed for version 1 of P3D.

 

For P3Dv2 I think you'd have to download and install the P3D2 SDK, but I'm not sure about that. 

 

With P3D version 3, if you need versions of SimConnect installed to suit many add-on programs, look in the P3D3 subfolders:

 

redist\Interface\FSX-SP1\retail\lib.

 

for FSX SP1 Simconnect.msi, and 

 

redist\Interface\FSX-SP2-XPACK\retail\lib

 

for the SP2/Acc version. Just run the msi files. Those two will satisfy just about any FSX SimConnect application out there.

 

Pete

Share this post


Link to post

Sorry, I forgot to mention, I'm using P3Dv3.1.

 

I've the FSX SP1 and 2 Simconnect installed from the redist folder, indeed. I just cant remember seeing the list of Simconnect programs without the ESP Simconnect at the top of the list... I must have a picture in my head from quite some time ago, I guess. ;)

 

But good to know I dont have to worry about it. Thanks, Pete! :)

Share this post


Link to post

I don't recall any app needing the ESP version, even with P3d V1.

 

Some apps are specific to one version of SimConnect and other apps check to see what SimConnect versions are installed before deciding how to communicate with the sim.

I don't recall any app needing the ESP version, even with P3d V1.

 

Some apps are specific to one version of SimConnect and other apps check to see what SimConnect versions are installed before deciding how to communicate with the sim.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this