Jump to content

Sign in to follow this  
ryanbatcund

P3Dv3.1 Stops Loading After Splash Screen

Recommended Posts

I have the same issue as this guy's post in the P3D official forums

http://www.prepar3d.com/forum/viewtopic.php?t=113712

 

Now I have done a bandaid fix (meaning a temp fix that I don't like), I've changed the situation= to blank so it loads the default P3D situation file.  But I have been loading the same (my personal) default flight since the beginning of P3D v2.2 without issue.

 

What did I change now that I have this error?

1)  Installed the latest Citation X installer

2) Installed many navigraph airac updates to 1602.

 

That's it.

 

Has anyone had this happen and is there another way around it other than starting with P3D's default scenario?

 

edit:  Looks like my GTN install is screwed up too...  the gauge isn't showing up in my panels I manually configured or the VC's with native integration

 

UGH


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post

navigraph 1602 working with out any problem here ...


i7 4777k 4.6mhz, 32gddr3, GTX 760 4g sci ,Saitek x52,yoke and quadrant, 60 Led . SSD

 

Share this post


Link to post

Hello Ryan

 

I'm not on my PC now, but has a similar problem with another Carenado aircraft. It added a weatherxml entry to the dll.xml, sometimes P3D displayed an error msg, other times none.

 

the fix was to change the Manual Load to True for that entry. ( I have to accept it every time, but it works)

 

If I remember correctly the Citation X installer adds an hypergauge.dll (or something like that) entry.

Try changing its Manual Load to True and  move that entry down and give it a try.

 

Hope that helps.


Ramón.
Time, is the one thing no one can buy.
ovbe94a9nab0bbc6g.jpg

 

Share this post


Link to post

Hmmm...  I don't see any new entries in my dll.xml file

 

More digging required.

 

Disregard the GTN issue - got that working - had an error code 11, MSE quarantined some file it needed.


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post

Ryan,

 

Temporarily disable any MS anti-virus and/or malware detectors. Today's updates started reporting one of the GTN files as malware.

 

As to the default situation issue, there have been a few reports of the following:

 

1) It's caused by directly editing Prepar3d.cfg directly with a text editor or

 

2) It's related to a recent update to Process Lasso.

 

I can't personally vouch for either.

Share this post


Link to post

It's odd though... in that it started just today.  Was working fine yesterday.  Anyway yes got the GTN issue fixed as I wrote above.

 

As for the startup - I saved a new start file and so far so good.  In case anyone has this you'll need to edit your p3d.cfg and blank out whatever comes after the "situation=" line..  That will revert to stock scenario loading.


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post

Hello Ryan

Glad you sorted it out, although

 

I don't know how you got it working, at least on my system there has to be an hypergauge.dll entry in dll.xml

 

I just installed it on P3D V3.1 and at first thing I got was a blak panel and an app crash due to ESDG_CitationX.gau

So I just added it to dll.xml and voila. Its working. (copied it from my FSX install)

 

Cheers.


Ramón.
Time, is the one thing no one can buy.
ovbe94a9nab0bbc6g.jpg

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,540.00 of $25,000.00 Donate Now
×
×
  • Create New...