Sign in to follow this  
Grahm

Is my system to slow?

Recommended Posts

FSX SP2 with ASX on Windows 7 Home Premium Running a i5 2500K CPU @ 3.30GHZ 3.60GHZ 16GB RAM 1TB hard drive. Video Card is a  ATI Technologies AMD Radeon HD 6800 Series.

 

All my scenery settings in FSX are on low and im getting 25 to 50 fps with drops of 1.5 to 10fps in turbulence for some reason. (What I have noticed)

With all my settings up on HIGH im getting at most 15fps. Is it my system or my video card?

 

I would give anything to have a smooth running FSX with sliders to the max or even half way.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the same i5 2500K CPU but I run it at 4.7 Ghz along with a GTX980.

My advice is OC that i5 to at least 4.4 Ghz, you really are wasting the potential of that chip by not overclocking it  then invest in a GTX 970 or upwards, AMD cards are not that great in FSX compared to Nvidia.

 

FSX/DX10 and P3D3.2 run well here.

Share this post


Link to post
Share on other sites

Well coming to find out, it was a big heat issue. I've had it for years and never realized it. That explains why the frame rate drop. I have since cleaned off my heat sink and reapplied Artic Silver 5 Thermal Paste and a HUGE night and day difference. I am currently running smooth at 60fps + @ maxed out in detail with a core temp of 50 degree Celsius at max load. I'm in love all over again! Heat Kills! I would still like to bump my clock up to 4.5ghz! I need a walk thru though. I also have that fan on the way! Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this