Sign in to follow this  
Angelo Cosma

Yoke happy Win7 but Win10=NO-GO

Recommended Posts

Hey guys, I am hoping someone from the community can help me out as I am quite down in the dumps about this and have been struggling for a couple of weeks to get this resolved.

 

I have a Floor Column Yoke and rudder that are both USB and have been working great so far. They are from Precision Flight Controls and are each one USB to the computer.

 

I have had Windows 10 since last September and am still on 10 now. My flight controls worked in 10 with a few struggles here and there to get them to stay connected but they worked. 

 

I have since changed rooms and moved my whole setup and now they refuse to connect to the PC and Windows cant load the controls. (Code 43) device cannot start etc. I have called PFC and they told me their USB boards don't support 10 and I would need to buy 2 with the latest firmware to support 10.

 

Well if you caught my last few sentences, my controls have been working fine in 10 since September to end of June. That clearly negates what they have been saying but they are adamant the boards need changing to support 10.

 

I am a little peeved off by this, as each board is $110 plus shipping. So we are talking nearly $250 just to get something that used to work fine in 10 to operate again. I can't fly, I just down to a simple joystick and keyboard now, and I refuse to cave and fork over that large amount of money for basically nothing.

 

Is there a way to emulate Win7 USB ports to these flight controls? Or have the computer wipe memory of ever seeing these controls as if it were the first time being connected? I have already tried new USB cables, getting a powered USB hub, and trying every port on my PC. I was successful in getting Windows to see only the Yoke, but when I rebooted the machine, on the next boot the problem reappeared.

 

I want to win this battle I am having with these things, because I cannot justify $250 just to use them again.

 

If anyone can provide any help, hints or ideas no matter how small please let me know. I want to enjoy my sim again and right now I am literally stuck.  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

That clearly negates what they have been saying but they are adamant the boards need changing to support 10.

 

 

 

To be honest, the fact that everything was fine until you moved rooms, doesn't necessarily negate what they are saying. What you may be dealing with is instability. You may have had everything working but a stable and working configuration is tenuous. 

 

It may be a case of messing about to regain that stable configuration. Plug, unplug, reinstall drivers etc. 

 

Have you checked on the internet to see if others are having the same issue with W10, and if they have found a solution?

 

 

Does this apply to you...

 

 

 

Atmel-based USB Cirrus Yoke, Throttle Quadrant Console and Rudder Pedals

If you have one of these, they show up as joystick only. The Atmel chip used was not specifically designed as a USB device, so USB functionality is in firmware ("Bit banged"). As far as we can tell this does not cause the same enumeration issues in this discussion; however, the parts are not capable of performing proper USB timing, and so may not work. Earlier versions of Windows are fairly relaxed about the USB standards, but other operating systems (including more modern Windows versions) may be more strict. If you have one of these devices it is likely possible to purchase a Cypress direct replacement control board; please contact PFC tech support if you wish to upgrade.

 

 

 

If not,something else in that link might...

 

http://flypfc.net/tiki-index.php?page=Windows+10+Issues

Share this post


Link to post
Share on other sites

Yeah I spoke to them on several occasions and they say the USB firmware on the USB cards in each the yoke and rudders needs to be re flashed if it'll take or spend $220 for two new boards shipped. Either way I am not a happy camper. 

Share this post


Link to post
Share on other sites

Have you tried this from PCWorld?

"

Device Managerdeviceworkingproperly-100575584-medium.p

This USB component is working, but if you've got a device problem this tab will tell you.

On Windows 8.1, right-click the Start button and select Device Manager from the contextual menu. Windows 7 users can find out how to open Device Manger here.

Let's continue using the borked USB port example. Fixing code 43 isn't just for USB devices, though—it's a quick tip you can use to help troubleshoot any PC component that ceases to work due to a software issue.

Once the device manager is open look for the heading that says Universal Serial Bus controllers and click it to reveal a list of all the USB devices on your PC.

In the list, you may see an item that has a yellow triangle with an exclamation mark in it and says "Unknown Device." Click on that and another window will open. Under the General tab you'll see a window that says Device status. For this tip to work, that window should say "Windows has stopped this device because it has reported problems. (Code 43)".

Now it's time to get to work.

devicemanager1-100575585-medium.png

Sometimes an uninstall can fix it all.

Open the Driver tab and then click the Uninstall button. This will remove the USB controllers driver software (the low-level programming that makes the hardware work) from your system.

 

Next, you have to put it back. Close the smaller window for your USB device and in the main Device Manager window click Action > Scan for hardware changes. Windows will notice that the USB device is lacking driver software and will reinstall it.

After that's done, you can click on the USB device again and under the General tab and under Device status it should now say the device is working properly. "

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this