Sign in to follow this  
Ben3083

XML issue help?

Recommended Posts

I keep getting messages saying my XML is corrupt. GSX is not showing in the menu or neither is Active sky next working but i can't see any errors in the XML. Can anyone else?

 

Any help is much appreciated. 

 

<?xml version="1.0" encoding="windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>Addon Manager</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>bglmanx.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>iFly 747-400 Menu</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\iFly744.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>ObjectFlow.dll</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\fsx\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\ObjectFlow.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Object Placement Tool</Name>
    <Disabled>True</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Traffic Toolbox</Name>
    <Disabled>True</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Visual Effects Tool</Name>
    <Disabled>True</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>VistaMare Core</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\fsx\VistaMare\ViMaCoreX.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Flight Recorder</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>PMDG HUD interface</Name>
    <Disabled>False</Disabled>
    <Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>PMDG Interface</Name>
    <Disabled>False</Disabled>
    <Path>PMDG\DLLs\PMDG_Interface.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>RAASPRO</Name>
    <Disabled>False</Disabled>
    <Path>.\RAASPRO\RAASPRO.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>VAInterface</Name>
    <Disabled>False</Disabled>
    <Path>Modules\VAInterface.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>CMeteoXml</Name>
    <Disabled>False</Disabled>
    <Path>.\CMeteoXml.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSLOptions</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>FSLabs\DLLs\FSLOptions.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSLEvents</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>FSLabs\DLLs\FSLEvents.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSLSounds</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>FSLabs\DLLs\FSLSounds.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSUIPC 4</Name>
    <Disabled>False</Disabled>
    <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSLSpotLights</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>FSLabs\FSLSpotLights\DLL\FSLSpotLights.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>SODE Animation Module</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>C:\Program Files (x86)\12bPilot\SODE\SimObjectAnimationModule.dll</Path>
  </Launch.Addon>
</SimBase.Document>
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

During install or normal operation?

 

Sometimes it's just matter of moving the entry to a different location.

Share this post


Link to post
Share on other sites

Hey Ben, I Don't Know !! - Question : Is there a Backup Xml File Anywhere ?? Question : Will the Xml File Regenerate on Boot, If Deleted - If You are Running FSX SE, Use this File to Compare with and or Replace with the SE file ?? - Be Sure to Backup Your XML File Before Fidling with it !! Hope This Helps - Johnman B)

Share this post


Link to post
Share on other sites

During install or normal operation?

 

Sometimes it's just matter of moving the entry to a different location.

 

Both. I first noticed when i started Active Sky next and it come up with an error about the DLL.xml and then i noticed GSX wasn't in the menu so i tried reinstalling it and it come up with an error saying there was an error with the XML. I just can't find an error in there. 

Hey Ben, I Don't Know !! - Question : Is there a Backup Xml File Anywhere ?? Question : Will the Xml File Regenerate on Boot, If Deleted - If You are Running FSX SE, Use this File to Compare with and or Replace with the SE file ?? - Be Sure to Backup Your XML File Before Fidling with it !! Hope This Helps - Johnman B)

 

That's another strange thing, I've tried a back up XML that was in the folder and it also has errors and also some products are working fine. I've also just tried deleting it to rebuild and Active sky is still saying the following. You will have to copy and paste the link's, they won't show by clicking on them for some reason. 

 

http://prntscr.com/d31y39

http://prntscr.com/d31xtb

Share this post


Link to post
Share on other sites

Hey Ben, - Maybe You need to Start doing some Uninstalling, One Item at a time, to try and pinpoint whats giving You aggravation ?? - or maybe a Windows Restore ?? - Johnman B)

Share this post


Link to post
Share on other sites

 

 


Both. I first noticed when i started Active Sky next and it come up with an error about the DLL.xml and then i noticed GSX wasn't in the menu so i tried reinstalling it and it come up with an error saying there was an error with the XML. I just can't find an error in there. 

 

I've ran into the error on install a few times with Flight1 programs.  

 

My solution was to add .backup to the production dll.xml and/or exe.xml files and let the app I was installing recreate the xml files with just the entry for the program.

 

I then copied the single entry to the production xml, deleted the new one, and removed the .backup suffix from the production xml.  No issues after that.

 

However, I'm not sure what you would do on one that you've been running. 

Share this post


Link to post
Share on other sites

with your  gsx  error  simple  download  the latest addon manager  and  that will solve  your  gsx  error,  with a bit  of  luck it  might  also fix  your  asn  error  as well

Share this post


Link to post
Share on other sites

Thanks for your help everyone. I found the issue. ChasePlane had made a change to the EXE.XML and it was corrupt. I put the back up in ChasePlane made and all is back to normal.  :smile:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this