Sign in to follow this  
charlie130

MU-2 compatible with REX WX Advantage Radar?

Recommended Posts

I recently looked at the REX WX Advantage weather radar. It looks identical to the Bendix RDR 4B unit installed in the panel of the MU-2, which does not function.

 

Has anyone installed the REX WX Advantage radar in the Flysimware MU-2?

 

Reading the REX product page, it may be installable in any 3rd party aircraft.

 

Anyone done this?

 

Cheers,

 

David

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

You can install it in any aircraft, but by default it will be a 2D popup.

Some aircraft are prepared to use the REX weather radar inside the virtual cockpit.

The Flysimware MU-2B is prepared for this since the latest patch, see http://flysimware.com/website/MU_2B_60_UPDATES.html

 

I have the MU-2B and the radar, but haven't tried this combination yet (or forgot that I already did :smile:). But the REX WX radar works great with Flysimware's C441, so I do not expect any problems here.

 

I'm using it with FSX, but as others are using it with P3D, this should just work.

 

(assuming your GPU is not as old as mine, I have a GTX260 and with that old card it only works in Windows 7, not 10)

Share this post


Link to post

Thanks Thomas, since the MU2 has the Bendix 4B unit sitting right there in front of me, with a blank screen, I was hoping it would be a 3d compatible install.

 

I don't think I have the MU2 2016 version and I can't remember where I bought it from in order to re download it. The link you posted states to re download the entire sim again to get the latest version?

 

But thanks again, its an underrated simulation!

 

Best regards

 

David.

Share this post


Link to post

Thanks Thomas.

 

Found it, re downloaded from Just Flight.

 

Got the gauge.

 

Just one small problem, when P3dv3 loads, I get an error warning "MV-WXM.dll" is not compatible with this simulator?

 

I sent a ticket to REX (Where I purchased it).

 

The gauge loads fine with the MU2, the test screen runs, however there is no weather displayed, in heavy rain, no display...At least I can see the rain drips on the wind shield (MU2 does this well!!)......oh well wait and see what REX come back with.....

 

Regards

 

David

 

Ps The best weather radar I have is on the Aerosoft Airbus series. 100% spot on!

Share this post


Link to post

I'm using it with FSX Steam and it works perfectly with the MU2 so there must be hope!

Share this post


Link to post

I assume you have the latest update for P3D released 1-2 weeks ago. For that the gauge needs an update, which should be released soon. According to the REX forum it is in testing since Monday.

By the way, I tested it with the MU-2B in FSX yesterday, it works fine there, as expected.

Share this post


Link to post

I assume you have the latest update for P3D released 1-2 weeks ago. For that the gauge needs an update, which should be released soon. According to the REX forum it is in testing since Monday.

By the way, I tested it with the MU-2B in FSX yesterday, it works fine there, as expected.

I am on P3dv3.0. It's the first version of P3d. (3.0)

 

Everything I have installed (REX TD + SOFT CLOUDS, Orbx scenery, etc.) all works 100%. I am one of those folks who says "if it ain't broke don't fix it". So if I have not gone down the constant upgrade path. To put P3DV3.XX, instead of 3.0.

 

I see no reason why the WX gauge should not work. I will experiment further today with finding rotten weather and hope I see some pretty patterns in the display.

 

Hopefully REX Support will reply to my ticket?

 

If not, it's another reason I despair at these constant upgrade cycles that do little for the overall sim yet conspire to make running add ons require constant patches, in order for them to run in newer versions of the base simulation. This just causes headaches for add on devs and confusion for folks like me. Not to mention the threat of wasting money!

 

I sometimes consider re loading FSX, since that sim will never change and will always be a fixed target for developers!;)

 

 

Best Regards

 

David

Share this post


Link to post

Just to report on the WX Advantage.

 

I spent my day testing each .dll that comes with the WX Advantage. They include a full set of modules and files, from FSX up to P3dv3.4. These are located in the WX folder.

 

I replaced each one, in turn, from the basic FSX up to the P3dv3.4 version. Then tested each with a flight in the MU2. Using heavy thunderstorms and rain in each flight.

 

Unfortunately each version failed to work, The "not compatible with sim" error occurred each time. It appears others have experienced this problem (on the REX forum) but have fixed it by swapping .dlls.

 

So my personal experience is a rather poor one. But others may succeed where I have failed.

 

Just to put the cat among the pidgeons, I ended up with my P3d key assignments being messed up! I have no idea how that happened, but it required re assigning every joystick assignment, as if from a new install.

 

Should have gone to the pub instead:-)

 

Regards

 

David

Share this post


Link to post

http://store.rexdownload.com/advanced-weather-radar-for-fsx-fsx-steam-edition-and-p3d-v25-v323/10-wx-advantage-radar.html shows:

Supports FSX SP2, FSX + Acceleration, FSX - Steam Edition, Prepar3D v2.5 (latest build), and Prepar3D v3.2.3, v3.3.5, and v3.4.9.

I assume that you will have to upgrade to at least 3.2.3. I would not expect them to support even more versions, because I assume they want to test each DLL before publishing it.

 

Regarding your lost key/joystick assignments: I have given up doing these assignments directly in FSX a long time ago. I assign everything in FSUIPC4 and make regular snapshots of FSUIPC4.ini (and now the Profile\*.ini files I use per aircraft class, too) using an SCM (in my case Mercurial), so I can always see what has changed. Doing assignments in FSUIPC4 has the additional benefit that I can assign multiple functions to a single button, e.g. AP Master and Parking Brake on the same button and FSUIPC will use one when the aircraft is airborne and the other if the aircraft is on the ground.

Share this post


Link to post

Supports FSX SP2, FSX + Acceleration, FSX - Steam Edition, Prepar3D v2.5 (latest build), and Prepar3D v3.2.3, v3.3.5, and v3.4.9.

I assume that you will have to upgrade to at least 3.2.3. I would not expect them to support even more versions, because I assume they want to test each DLL before publishing it.

 

Thanks Thomas. That's what I am beginning to realise, after testing each of the .dll files for each simulation variant, my P3dv3.0 (the first original release) is not supported. I would like to know what exactly is different between the versions that needs such special coding of the .dll.

 

I see countless reports in the Orbx forums of scenery not running after upgrading to the latest and greatest P3d. So either I stick to what works with my current install, or update and re install everything. Provided, that is, that the developers have managed to keep up with the changes?

 

Nah!! The pub seems like a better option.

 

Thanks again.

 

David

Share this post


Link to post

Supports FSX SP2, FSX + Acceleration, FSX - Steam Edition, Prepar3D v2.5 (latest build), and Prepar3D v3.2.3, v3.3.5, and v3.4.9.

I assume that you will have to upgrade to at least 3.2.3. I would not expect them to support even more versions, because I assume they want to test each DLL before publishing it.

 

 

I bit the bullet and upgraded my P3d to the latest 3.4.14.18.

 

I re installed the WX Advantage gauge, have the latest version of that.

 

However, I still get the Error MV-WXM.dll is Not Compatible with the simulator!!! :unknw:

 

I got a message from support, they affirmed that I needed the latest P3dv3.4. for the WX to work. Unfortunately it doesn't. :Hmmmph:

 

Another ticket has been submitted!

 

Sigh!

 

Regards

David

Share this post


Link to post

I bit the bullet and upgraded my P3d to the latest 3.4.14.18.

 

I re installed the WX Advantage gauge, have the latest version of that.

 

However, I still get the Error MV-WXM.dll is Not Compatible with the simulator!!! :unknw:

 

I got a message from support, they affirmed that I needed the latest P3dv3.4. for the WX to work. Unfortunately it doesn't. :Hmmmph:

 

Now my earlier comment kicks in:

 

I assume you have the latest update for P3D released 1-2 weeks ago. For that the gauge needs an update, which should be released soon. According to the REX forum it is in testing since Monday.

 

It will soon work with 3.4.14.18, but it will never work with 3.0.x, so the support was more than half (but not fully) correct.

Share this post


Link to post

It will soon work with 3.4.14.18, but it will never work with 3.0.x, so the support was more than half (but not fully) correct.

 

 

Thanks again.

 

I got an email from support that stated it will work with the latest P3d3.4.  That's what I am now on.  I guess the update is imminent?

 

Have you a link to the WX forum, I cant seem to find the bit where they are testing it out? Just blurb on the latest update v4, which I have installed.

 

They have acknowledged the latest ticket, but don't work over the week end so it will be next week. :sad:

 

Thanks again

 

Regards

David

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this