Sign in to follow this  
Astrosofia

Missing parts when camera is near fuselage

Recommended Posts

Hi guys... great job for this application! thanks so much.. so, ive a problem (see attach.)

 

practically, how can you increase the field of view of the camera to avoid seeing the plane's interior?

 

https://www.flickr.com/photos/134949723@N05/30686337853/in/dateposted-public/

 

Thanks so much

Ric

 

 

practically, how can you increase the field of view of the camera to avoid seeing the plane's interior?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Fairly certain it's an ESP-based simulator problem. It happens with all cameras, ChasePlane, EzDok, even default. They may be able to work something out, but it's definitely not just ChasePlane that has this problem.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have the same problem when I pan around the VC then switch to a view outside the camera is inside the plane. Too bad we couldn't set up two cameras

Share this post


Link to post
Share on other sites

If you are using Prepar3D v3, you can adjust the clipping distance by adding NearClipOverride = 0.3 to the Outside (ChasePlane) section of your cameras.cfg file located in %appdata%\Lockheed Martin\Prepar3D v3

 

You can play around with the value (expressed in feet). If this value is too small, you will see artefacts forming in the distance.

Share this post


Link to post
Share on other sites

If you are using Prepar3D v3, you can adjust the clipping distance by adding NearClipOverride = 0.3 to the Outside (ChasePlane) section of your cameras.cfg file located in %appdata%\Lockheed Martin\Prepar3D v3

 

You can play around with the value (expressed in feet). If this value is too small, you will see artefacts forming in the distance.

 

Clipmode and NearClipOverride... I have been fighting with them for months! :)

 

For cockpit (On-Board) camera, I prefer Clipmode=Normal, which is also P3D default. ChasePlane sets Clipmode to Minimum (btw. ezdok did the same). I understand this decision, because Normal makes objects that are very close to the aircraft "cut out" – GSX vehicles, jetways. But Minimum has its problem too – it causes z-fighting of textures. Flickering of apron and taxiway textures, airport buildings (especially windows), clouds intersecting mountains...  These effects are often severe (as in the case of recently released Aerosoft Menorca) and affect both on-board and outside cameras. I often read complains of users that an airport "flickers" while developers cannot reproduce it. I will bet that in at least 80% of cases, the cause is Clipmode=Minimum.

 

I have a dream :) I would like to adjust Clipmode according the phase of my flight. Keven, is it technically possible to change it dynamically? I presume that not. What about a possibility to select the Clipmode for individual presets (e.g. a checkbox "Anti-flickering Mode") ? This should be possible through double camera definitions in cameras.cfg – e.g. On_board Normal & On-Board Minimum and ChasePlane using one or another according the Clipmode ("Anti-flickering") setting of the specific preset...

 

I think that this "anti-flickering feature" would be interesting for many users.

 

Roman

Share this post


Link to post
Share on other sites

Clipmode and NearClipOverride... I have been fighting with them for months! :)

 

For cockpit (On-Board) camera, I prefer Clipmode=Normal, which is also P3D default. ChasePlane sets Clipmode to Minimum (btw. ezdok did the same). I understand this decision, because Normal makes objects that are very close to the aircraft "cut out" – GSX vehicles, jetways. But Minimum has its problem too – it causes z-fighting of textures. Flickering of apron and taxiway textures, airport buildings (especially windows), clouds intersecting mountains...  These effects are often severe (as in the case of recently released Aerosoft Menorca) and affect both on-board and outside cameras. I often read complains of users that an airport "flickers" while developers cannot reproduce it. I will bet that in at least 80% of cases, the cause is Clipmode=Minimum.

 

I have a dream :) I would like to adjust Clipmode according the phase of my flight. Keven, is it technically possible to change it dynamically? I presume that not. What about a possibility to select the Clipmode for individual presets (e.g. a checkbox "Anti-flickering Mode") ? This should be possible through double camera definitions in cameras.cfg – e.g. On_board Normal & On-Board Minimum and ChasePlane using one or another according the Clipmode ("Anti-flickering") setting of the specific preset...

 

I think that this "anti-flickering feature" would be interesting for many users.

 

Roman

 

Great research Roman!

 

This is definitely something we can provide as an option. While it might not be possible to change this setting while in flight (we will still research this avenue), we could ask the user for preference.

 

I added it to the list but it's not going to be before v1.0

 

Regards,

Keven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this