Sign in to follow this  
oeker

configuration tool location

Recommended Posts

After installing Mytraffic 6.

 

Loading time is now much longer.

 

Now this message shows up a couple of times:

 

Simconnect 50 seconds. Open configuration tool and select correct simulator.

 

 

Closing messages, and the sim runs fine.

 

Anyone have a simple procedure to fix this?

 

Thanks!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I tried to run the small msi program in redist folder.

Obviously not the program P3D is looking for.

 

Checking youtube there is a configure tool to download.

Is this really necessary?

Share this post


Link to post

What addons are you using? And what do you mean about closing the box and then everything runs fine? Are you saying that Mytraffic is loading traffic for you?

 

After installing mytraffic, load times are increased, and if you are loading alot of other stuff, you maybe stalling out simconnect.

If you did install mytraffic correctly , there is probably a misconfiguration somewhere. Maybe try deleting p3d.cfg and letting it rebuild a new copy. 

Share this post


Link to post

Thanks Jim.

 

Yes. Mytraffic and the sim in general runs fine after loading.

 

A bit annoying to close the message several times during loading, and not sure if P3D is running optimum.

 

 

ORBX scenery

ANS weather

Ezdoc

Rex clouds

Share this post


Link to post

 

Simconnect 50 seconds. Open configuration tool and select correct simulator.

 

Thats an EZdok Message 

 

There is a work around for that.  Do you have FSUIPC ? 

 

 

From the Prepar3D Forums............... 

 

"Start ezdok when sim is already load with FSUIPC starter
 
to add ezdok as auto start from fsuipc make that:
 
- go to \[prepar3d folder]\modules\ 
- here open file " FSUIPC.ini "
 
- scroll down the text, then add 2 news strings
  1) [Programs]
  2) RunIf1=READY,CLOSE,C:\Program Files (x86)\EZCA\EZCA.exe"==
 
 
===========================
 
System's differ,  But I had that message once and solved it by...........
 
Running Prepar3D and EZdok as administrator
 
 
 
Have you run the simconnect msi Installer in the above EZCA folder ? 

Share this post


Link to post

Elaine - I want to marry you.

 

Wonderful stuff you came up with, but still the same message.

 

Unfortunately I jumped straight into troubleshooting myself, a few hours before I read your post. I had the same hunch for culprit as you , Ezdok. Default is A2A T6. Suspected time out due to long loading time. Switched over to a simpler aircraft with no Ezdok. P3D then crashed to basic default F--22. Payware aircraft now bugged. Ezdok external view was just a few basic panels. Reinstalled aircraft and run Ezdok config.exe. OK now

 

Your troubleshooting

 

1. I do not have FCUIPC installed. Had it on old FS sim. Should I dig it up from my HD and install it?

 

2. Win 10 does not have exact same system. But there is a compability troubleshooting. I did run as administrator with no problem.

 

3. The Ezdok troubleshooting stopped with message :

FSX process not found. Apllication can not run.

 

4. When running Ezdok from folder and admin,, there is a short notice:

. Found 2 simconnects. Use xx.xxxx.xx

 

Even with the annoying loading message - P3D runs fine. I had a couple flights (A2A Comanche) with flight plan filed and traffic in real weather. A wonderful trip from ENZV to ENSG. IFR with no GPS. Highly recommended trip!

 

Elaine - thank you very much for your time and experience you put into this problem.

I really appreciate it.

As stated, I can live with this minor problem, and understand if you give priority to other things in life.

 

O.Eker

Share this post


Link to post

This is beyond me I'm afraid......

 

Maybe Kevin might jump in here  (Kevin is the EZdok man) 

 

 


Help Kevin !! 

Share this post


Link to post
Hi,
sorry I've been busy with Holiday preparations, did not pick up on this thread until now
 
under windows 10
You do not need to run compatibility settings except run as administrator on prepar3d.exe
ezdok gains Admin/elevated status from P3d. however it does no harm to add it to EZCA.exe too
 
ezdok config
it should only be run when
a. you add a new plane 
b. when you add a new controller device - joystick etc -
 
avoid running the ez config restore option - it can damage your cameras.cfg file.
 
AI traffic
this can be a factor in delaying sim load times resulting in ezdok simconnect timeouts
FSUIPC4 can defer ezdok opening until a flight is loaded, to avoid it.
 
FSUIPC4
always check you have the latest version 4.958 -: http://fsuipc.simflight.com/beta/FSUIPC4.zip
your existing purchase details can be re-used but the [programs] feature does not require users to have a paid licence. Just download it and run the installer after you unzip the download file
 
You must run the sim at least once to create the FSUIPC.ini file
 
the command "ready" is the key, without it ezdok will start exactly as it does using Exe.xml so a timeout would still be likely   READY delays loading and running the program until sim is up and ready to fly, and FSUIPC4 can supply valid data through its IPC interface.
 
EXE.xml file
FSUIPC4 cannot overide the sim Exe.xml file entry for ezdok,it must therefore be disabled - Location  c:\users\(your username)\appdata\roaming\Lockheed Martin\Prepar3D v3
it is disabled by altering the line <Disabled>False</Disabled> to True

example
 
<Launch.Addon>
<Name>EZdok camera addon</Name>
<Disabled>True</Disabled>
<Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>
</Launch.Addon>
 
Prepar3d.cfg
I would  suggest deleting your Prepar3d.cfg file as the section
[uSERINTERFACE]

line
SITUATION=C:\Users\(your username)\Documents\Prepar3D v3 Files\xx may be the issue
 
it seems the sim cannot read the files needed for your default flight and reverts to using the
Prepar3D_Default.fxml and Prepar3D_Default.wx files
 
P3d wil generate a new cfg file when run
 
I hope this helps you - O.Eker
  • Upvote 1

Share this post


Link to post

Thank you both.

No doubt you are very close, but no cigar. 

:smile:

 

Done all steps suggested by Kevin.

With disable true - the message does not appear, unfortunately also Ezdok is gone.

 

Reset back,to False and Ezdok is OK again.

 

Thanks again.  P3D is running OK, no need to give you two sleepless nights over this problem.

Appreciate your time put into this. 

:smile:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this