Sign in to follow this  
darthranger

Addon Aircraft Missing After Update

Recommended Posts

I finally got around to updating P3D v3 to V 3.49 and now none of my add-on aircraft are displayed with a "Failed to Initialize, visualization only" indication.  Can't seem to find a solution anywhere.  I tried deleting the C:/program data\ Lockheed Martin\P3Dv3 folder and let it rebuild. Still no addon aircraft.

 

Any thoughts/solutions would be appreciated.

 

Rick

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello Rick,

 

May possibly be a corrupt VehicleFavorites.xml file,  Do you have this file ? This is were your Saved Favorite Aircraft go,   Locate this file and Move it out of the below location onto your Desktop,  Launch Prepar3D and test  

 

Location:  Local Disk (C:) ► Users ► you ► AppData ► Roaming ►Lockheed Martin ► Prepar3D v3   VehicleFavorites.xml  

Share this post


Link to post

Hi Elaine

 

No, that didn't work !

 

FYI, I had already tried deleting the whole: Local Disk (C:) ► Users ► you ► AppData ► Roaming ►Lockheed Martin ► Prepar3D v3 file and let it rebuild, without success.

Share this post


Link to post

Have you checked the path in your simobjects.cfg folder?

 

 

Vic

Share this post


Link to post

What should the "Path" be ?    (My P3D is located on D:/, not C:/)

 

[Entry.0]
Title=Default Airplanes
Path=SimObjects\Airplanes
Required=True
Active=True
[Entry.1]
Title=Default Avatars
Path=SimObjects\Avatars
Required=True
Active=True
[Entry.2]
Title=Default Rotorcraft
Path=SimObjects\Rotorcraft
Required=True
Active=True
[Entry.3]
Title=Default Ground Vehicles
Path=SimObjects\GroundVehicles
Required=True
Active=True
[Entry.4]
Title=Default Boats
Path=SimObjects\Boats
Required=True
Active=True
[Entry.5]
Title=Default Animals
Path=SimObjects\Animals
Required=True
Active=True
[Entry.6]
Title=Default Misc
Path=SimObjects\Misc
Required=True
Active=True
[Entry.7]
Title=Default Submersible
Path=SimObjects\Submersible
Required=True
Active=True
[Entry.8]
Title=Default Weapons
Path=SimObjects\Weapons
Required=True
Active=True
[Entry.9]
Title=Default Countermeasures
Path=SimObjects\Countermeasures
Required=True
Active=True

Share this post


Link to post

I think I figured this out....

My P3D v3.3 was installed in my D:\ drive.

When the P3D client did the upgrade, it apparently changed + updated the P3D file located in the C:\ drive and changed the path to open that file.  Since none of my addon aircraft were in that file, they weren't recognized. 

 

Freakin' weird !!!

So, I moved my addon aircraft over to C:\Lockheed Martin\ P3D, then changed the sim objects .cfg file path and now it's working.  

Looks like I'll have to merge the rest of my D:\ P3D files with C:\ P3D  (Orbx scenery etc.) and then delete the D:\P3D file.

Now I also understand why ORBX Direct was saying that none of my Orbx scenery was loaded.  That file was in D:\P3D, not in C:\P3D.

I think I'm going to have a look at X-Plane 11.  LOL

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this